Applied recommended updates, Now can only reboot into command line mode

output from the rpm command you requested.

Name        : zypper
Version     : 1.13.45
Release     : 20.1
Architecture: x86_64
Install Date: Mon 15 Oct 2018 10:26:07 PM EDT
Group       : System/Packages
Size        : 7099571
License     : GPL-2.0+
Signature   : RSA/SHA256, Mon 24 Sep 2018 04:15:44 AM EDT, Key ID b88b2fd43dbdc284
Source RPM  : zypper-1.13.45-20.1.src.rpm
Build Date  : Mon 24 Sep 2018 04:15:17 AM EDT
Build Host  : lamb26
Relocations : (not relocatable)
Packager    :
Vendor      : openSUSE
URL         :
Summary     : Command line software manager using libzypp
Description :
Zypper is a command line tool for managing software. It can be used to add
package repositories, search for packages, install, remove, or update packages,
install patches, hardware drivers, verify dependencies, and more.

Zypper can be used interactively or non-interactively by user, from scripts,
or front-ends.

    Jan Kupec <>
    Michael Andres <>
    Duncan Mac-Vicar <>
    Martin Vidner <>
    Josef Reidinger <>
Distribution: openSUSE Leap 42.3
Name        : libmodman1
Version     : 2.0.1
Release     : 20.3
Architecture: x86_64
Install Date: Wed 02 May 2018 02:16:37 PM EDT
Group       : System/Libraries
Size        : 31344
License     : LGPL-2.1+
Signature   : RSA/SHA256, Tue 09 May 2017 08:36:11 PM EDT, Key ID b88b2fd43dbdc284
Source RPM  : libmodman-2.0.1-20.3.src.rpm
Build Date  : Tue 09 May 2017 08:36:05 PM EDT
Build Host  : lamb63
Relocations : (not relocatable)
Packager    :
Vendor      : openSUSE
Summary     : A Module Management Library
Description :
The Module Loading library offers the choice to use prelinked libraries
from your application out of a pool.
Distribution: openSUSE Leap 42.3
Name        : libproxy1
Version     : 0.4.15
Release     : 5.2
Architecture: x86_64
Install Date: Wed 22 May 2019 08:26:19 AM EDT
Group       : System/Libraries
Size        : 161726
License     : GPL-2.0-or-later AND LGPL-2.1-or-later
Signature   : RSA/SHA256, Tue 29 Jan 2019 11:26:04 PM EST, Key ID b88b2fd43dbdc284
Source RPM  : libproxy-0.4.15-5.2.src.rpm
Build Date  : Tue 29 Jan 2019 11:25:55 PM EST
Build Host  : build76
Relocations : (not relocatable)
Packager    :
Vendor      : openSUSE
URL         :
Summary     : Automatic proxy configuration management for applications
Description :
libproxy is a library that provides automatic proxy configuration

Proxy autoconfiguration (PAC) requires JavaScript (which most
applications do not have), and determing the PAC script location
requires a WPAD protocol implementation, which complicate proxy
support. libproxy exists to abstract this issue and provides
an answer how to reach a certain network resource.
Distribution: openSUSE Tumbleweed

Having this package from the TW repo is wrong. You should have 0.4.13 from 42.3. You should be able to download with wget or curl, then install with rpm:

sudo rpm -Uvh --oldpackage libproxy1-0.4.13-4.3.x86_64.rpm


Before you proceed further you may want to consider:

42.3 is almost at end of life (30 Jun 2019), the current stable Leap version is the recently released 15.1

Assuming you’re successful in returning your 42.3 system to a working state, you will need to carry out a distribution update to Leap 15.0, followed in the not too distant future to 15.1

It may be a better option to carry out a fresh install, keeping your current home directory, of 15.1. Thus bringing your system up to date in one operation.

I’m going to follow your suggestion. If I run into another issue (which seems likely) I may back up the things I need and re-image the machine. My P70 does not have network access because of this issue. So I will try to pull the rpm to a USB drive and install from there. May take some time with my novice skills.

Your suggestion is gaining traction with me because this is taking too long.

One question I have for both of you… How did a Tumbleweed repo get added as one of my repositories if I originally installed Leap? Is this common? I would think SuSE would keep the two separate.

If I have any success I will report back to this Forum.

That would be my recommendation, too.

Most likely by the use of “One-Click-Install” for a TW application… Very easily done I’m afraid. You need only search the forums to confirm that.

So seems I am not the only victim of the “one-click” install.

Please don’t shoot me but I’m and old IBM Mainframe tech. The software we used to install maintenance and apply patches was set up in a way where I could not apply an update to code using the wrong release or product level.

Seems this forum would reduce the amount of traffic if SuSE had a similar mechanism in place. Or instead of the one-click install that I fell victim to, put out a message on the desktop that instructs the user to use Yast or Zypper for the installation. In addition, have the maintenance or patch bundle inspect the users system and prevent Tumbleweed repo’s from being added to a Leap installation. And vise versa! Works both ways.

Often times when working on a laptop, I take a Windows approach to applying patches/fixes etc… I won’t make that mistake again. It would be nice if SuSE prevented users from making the same mistake I did.

Thanks for all your help. On to a re-image…

We see a steady stream of them.

Please don’t shoot me but I’m and old IBM Mainframe tech. The software we used to install maintenance and apply patches was set up in a way where I could not apply an update to code using the wrong release or product level.

But who wants to follow a well designed procedure, when you can just click on a web page?

The world has changed, but not always for the better.

Installer could reject one click install that does not explicitly specify for which distribution it is created instead of silently accepting it.


Partly you are correct, partly not.

First, please it is openSUSE, not SuSE (that was realy a long time ago).

Then we here (your fellow openSUSE users) are aware of the fact that the one-click install made more victims last year or so and some here took steps to communicate to the developers that a more carefull approach might be needed.

But Linux is not IBM 360 (or similar). Linux is about freedom to do what you want and to combine what you like. So in the end it is not “forbidden” or should kept blocked to add software feom what repo one wants, or install RPMs directly, or build software from source and install.

When you are searching outside of the standard repos that make the version of a distribution (for openSUSE: OSS, non-OSS, their Update compatriots), it is in the end you that are responsible for e.g. checking if a software is for the version you have running.

I assume, and you may take the trouble to prove otherwise and that will probably give us a case for a bug report, you searched for something and stumbled into a Tumblweed version for that software. It is not wrong to try that. You can do that and when it does not work, in most cases you simly de-install it again. But the one-click install tries to help by adding the repo and installing from it in one go. As far as I know (but I did not use the one0click since a long time), it asks you if the repo must stay added afterwards or not (or maybe it asks if it must make it disabled or not). You decided to keep it enabled. And that created the problems.

I found my problem and almost tripped over it again. I recently re-imaged to Leap 15.1. While researching HP drivers for my HP 8710 I came across sites that just say “Install”. This forum has taught me to be very careful about this. So I tried again to take the “One Button” approach, which launched Yast and attempted to add a new repository. Reading the repository, I noticed Tumbleweed in the path name. I stopped and immediately canceled that installation. Then I made sure no Tumbleweed repo was added. Whew… nothing was added.

I took the “hp-setup” from the command line approach as documented in a openSUSE wiki. I’m convinced this may have been the original cause of my mixed repo problem back a month ago.

This forum is great! I’ve learned a ton!

Just wanted to share this… john.

Yes software search tends to find TW versions first if you read carefully the result page you will see options for other versions. The old user interface, though not perfect, was much better then the new format. It makes it almost certain a TW repo will be selected instead of a leap by new users. :’(