application won't launch

greetings all,
i have got a few applications that i cannot launch anymore. i am pretty certain i was in the past, but when i try now, it looks like as if the process starts (like the app shows up in the control bar and the icon is bouncing on the desktop), but then it just quits. seems to be happening more often after i ran through an upgrade. also tried reinstalling those particular packages, no improvement. gladly accept some suggestions.
thanks, theo

Run the various applications from the command line and paste the output.

fenris@linux-g1bf:~> frostwire
bash: frostwire: command not found
fenris@linux-g1bf:~> camorama
[dialogue box: could not connect to video device (/dev/video0). Please check connexion.]
fenris@linux-g1bf:~> webKam
bash: webKam: command not found
fenris@linux-g1bf:~> ./webKam
bash: ./webKam: Datei oder Verzeichnis nicht gefunden
fenris@linux-g1bf:~> ./frostwire
bash: ./frostwire: Datei oder Verzeichnis nicht gefunden
fenris@linux-g1bf:~> cheese

(cheese:6267): GLib-GObject-CRITICAL **: g_param_spec_internal: assertion `(name[0] >= ‘A’ && name[0] <= ‘Z’) || (name[0] >= ‘a’ && name[0] <= ‘z’)’ failed

ERROR: Caught a segmentation fault while loading plugin file:

Please either:

  • remove it and restart.
  • run with --gst-disable-segtrap and debug.
    Fehler beim erneuten Einlesen der Registry , child terminated by signal

cheese [OPTION …] - Take photos and videos with your webcam, with fun graphical effects

-?, --help Hilfeoptionen anzeigen
–help-all Alle Hilfeoptionen anzeigen
–help-gtk GTK±Optionen anzeigen
–help-gst Die Optionen von GStreamer anzeigen

-v, --verbose Ausführliche Ausgabe
–display=ANZEIGE X-Anzeige, die verwendet werden soll

fenris@linux-g1bf:~> luvcview
luvcview 0.2.4

SDL information:
Video driver: x11
A window manager is available
Device information:
Device path: /dev/video0
Stream settings:
Frame format: YUYV (MJPG is not supported by device)
Frame size: 640x480
Frame rate: 30 fps

Quit signal received.
Cleanup done. Exiting …

as you can see, luvcview works fine, but so did frostwire, cheese … webKam and camorama never launched for some reason.
thanks, theo