Application only runs through terminal

Hello OpenSuse lads!

I’ve recently installed OpenSuse 12.2 KDE and I’ve encountered a brick wall in my exploration of this marvelous and sexy OS.

The thing is i’ve installed Matlab using the installer from their web page and then i created a launch icon on my desktop with the “link application” feature. In the command section i introduced what i think is the executable’s path (/usr/local/MATLAB/R2012a/bin/matlab). When i double click the icon, the matlab booting poster appears but 3 seconds after it dissapears and the matlab process is no where to be seen in the system monitor. I tried creating the laucher with an app entry in the kickoff menu and introducing the following command in the launcher properties but its still no use : cd /usr/local/MATLAB/R2012a/bin/ && ./matlab. Then i tried running it from the terminal et voilà.

Why is this happening ? Has it got something to do with permissions? Any ideas on how can i create the link or if i might of missed something during the installation?

TIA.

Neg.

Nope, nothing to do with permissions. Change the ‘Command’ field from

/usr/local/MATLAB/R2010a/bin/matlab

to

/usr/local/MATLAB/R2010a/bin/matlab **-desktop**

The following error appears when i double-click the launcher : KDEInit could not launch ‘/usr/local/MATLAB/R2010a/bin/matlab’

I’m sorry, I miss-typed a part. It’s the R2012b version you have, so the command should be

/usr/local/MATLAB/R201**2**a/bin/matlab -desktop

Doh ! You are totally right, should’ve noticed that my self. Thanks a lot !

That’s all right, I don’t know how I changed it myself too :stuck_out_tongue: