Application icons are missing

I was looking at the settings for themes. I have no idea what happened, but 70%+ of the icons are now not showing. The high majority are application specific icons. Some of the basic systems items are still showing. But as a strange feature of this, though they are not visible in the menu, some are in the active app list in the task manager. As an example the Brave icon shows for this browser being in use, but does not show in the quick launch or menu. Not a huge issue, but it is a pain. I am not sure what happened. Any help is appreciated.

I have LXQT and Cinnamon as UI, both are doing the same thing. Searched the forum and found this, but it did not help.
Kde lost icons - #3 by mohammad8

Should not this have been at the top of the post, or even in the title? A very important starting point to allow people to decide if this is something they can help, or better skip to the next one.

Did you make any changes to the themes or make any changes at all before this happened?

Thank you and yes. I noticed that there were no icons in the file managers, so I tried changing the icon packages first, and then the theme. I am not sure when the icons went missing. I had been paying attention to the file managers, trying to get that to work. I have tried to get it back to the original theme, but can’t seem to get the right combination.

Are you able to spin up a VM with Leap so you have a reference to what the defaults are?

Also does it happen with any theme/icon pacakge? Have you tried others?

Yes I tried multiple icon and theme packages and it seems to be everywhere at this point. It’s been awhile since I’ve done a VM but that’s a great idea. I might do the same thing with a live version of 15-4 and see what it looks like

As with most problems it’s pretty frustrating because he doesn’t make sense and I can’t figure out what changed

Yeah, I’m sorry I can’t be more help but a VM of 15.4 would at least allow you to compare and contrast.

1 Like

Are VMs pretty simple to set up these days? It’s been years since I’ve tried one

Yeah just install VirtualBox and it’s pretty easy.

Yes, install VMs it might help and it is easy to set up

Instead of setting up a VM why not going one step back and start with the basics like a new user profile for testing purposes? With this step you could easily rule out that it is a broken user profile and only takes 2 minutes time (in opposite to setting up a VM).

hui, good point.
Setting up a new user account has the same problems. The majority of icons are missing.

Hi, I don’t have lxqt and cinnamon to look at. Is there a way to increase the size of your icons in the settings. In xfce and kde there is a setting to adjust the icon eg: small, normal etc… Some icon themes
if you set it too small like setting it to tiny icons does not show up or in xfce it will only show the high contrast icons.
If it’s not the case you will have to leave with it til someone can point you to the right direction.
Have you tried reinstallng the icon themes?

Edit: A quick duckduck go search I found this,
Is lxqt-qtplugin installed? if not try installing it.

All notes below refer to being logged into LXQT running Cinnamon

Checked and had the lxqt-qtplugins. But I reinstalled them anyway. No difference.

Changing between the settings in the Themes tool I was able to get most, but still not all of the icons back by changing to the Mint-X icons. It only works on the basic green color. All of the other Mint-X options (orange, red, blue, etc) still loose most of the icons. Once those were back I tried Oxygen again and the icons successfully changed and didn’t loose any. This is great but odd. When Oxygen was selected (before changing to Mint-X) many were missing. Somehow the Mint-X changed something.
That change, allowing Oxygen icons only lasted about 10 minutes. When I changed workspaces and came back it had lost some icons again. Changing back to Mint-X is the only way to keep them.

The Menu icon is missing still as well as about 15% to 20% of the other icons.

There must be another setting or path that is out of wack.

Current Themes tool setting are:
Window borders - Mint-Y
Icons - Mint-X
Controls - BlueMenta
Moused Pointer - Adwaita
Desktop - Cinnamon

@idee normally themes, icons and fonts either look in ~/.[themes,icons,fonts] or ~/.local/share/[themes,icons,fonts] and for the system /usr/share but maybe the icon cache was not updated/triggered. Forcing the re-install of one of the system themes may help trigger a rebuild.

THank you Malcom,
I did some searching on the cache suggestion, and found the following string with similar issues and caches seem to be a culprit. I will dig through these and follow up. Hopefully this is it.
Reddit - Dive into anything

use ‘gtk-update-icon-theme -f’ to force the generation of caches

For the purpose of looking what this icon theme look like, I installed it. It was a big file.
One thing I notice is it’s like picking some from moka icon theme semilar to whats happening with the suru icon theme in xfce. I could be wrong.
A shot in the dark, maybe installing the moka icon theme might revitalized the mint theme :grinning:

Since 15.5 is out now, I think I am going to upgrade to that. Is should fix all of this as well as the benefits of the next version. Thanks.