Application:Geo, QGIS crashes with segmentation error /Speicherzugriffsfehler when opening a project

Hello comunity!

When i try to open some QGIS-Projects the appliation crashes immediately. Some other can be opened, but crash when trying to change the CRS or open the settings-window. This happens with all tree available versions (lte, stable, master) in the same way.

useher@eris:~/src/qgis-2.16.3> qgis
Warning: QCss::Parser - Failed to load file  "/style.qss" 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Datei oder Verzeichnis nicht gefunden
Warning: QFileSystemWatcher: failed to add paths: /home/useher/.qgis2//project_templates
Warning: QLayout: Attempting to add QLayout "" to QgsPanelWidgetStack "mWidgetStack", which already has a layout

When trying to compile the source, the following message is shown:

useher@eris:~/src/qgis-2.16.3> cmake .
-- QGIS version: 2.16.3 Nødebo (21603)
-- Could not find GRASS 6
-- Found GRASS 7: /opt/grass (7.0.5, off_t size = )
-- Found Proj: /usr/lib64/
-- Found GEOS: /usr/lib64/ (3.5.0)
-- Found GDAL: /usr/lib64/ (2.1.1)
-- Found Expat: /usr/lib64/
-- Found Sqlite3: /usr/lib64/
-- Found PostgreSQL: /usr/local/pgsql_9.4/lib64/
-- Qt WebKit support enabled
CMake Error at /usr/share/cmake/Modules/FindQt4.cmake:1326 (message):
  Found unsuitable Qt version "5.5.1" from /home/useher/bin/qmake, this code
  requires Qt 4.x
Call Stack (most recent call first):
  CMakeLists.txt:274 (FIND_PACKAGE)

-- Configuring incomplete, errors occurred!
See also "/home/useher/src/qgis-2.16.3/CMakeFiles/CMakeOutput.log".
See also "/home/useher/src/qgis-2.16.3/CMakeFiles/CMakeError.log".

So this seem to be a problem between QGIS and Qt. But i worked for the whole time and all parts are installled from the repositories. Removing the plugins didnt help. Another posibility could be soe issues with a python-package, but i can’t figure out which one. So can somebody give me a hint where this error coes from or maybe someone has solved this issue?

Best Regards

Uwe Seher

For me it run’s, if i use the new libproj12 from Geo repo and libproj0 from main repo. I also removed the older libproj9. I used openSuSE13.2. I will try to solve the problem in the same way on a Leap 42.1 computer with the same error later on.

Thank you for your help. The problem was that libproj9 and libproj12 where both installed, however this had happened. After removing libproj9 everything is ok.

best regards


Yep, many thanks, pge96, solved my problem here too. :slight_smile:

Hi people,

I’ve been having a similar problem with my Qgis here. How can I try and remote the libproj12 from the repo?

I appreciate any help!