apple wireless keyboard on opensuse 11


I updated my exiting installation to opensuse 11.0. I wanna use the aluminium apple wireless keyboard (bluetooth). I’m using a belkin usb bluetooth dongle. System is recognizing the usb-stick (hcitool dev), so everything is fine. If I want to connect with the keyboard I get a system message that it’s connected (kbluetooth). the message log says something different:
hcid[5497]: link_key_request (sba=00:0A:3A:65:91:24, dba=00:1E:52:FB:E4:95) QFile::open: No file name specified
and then nothing happens
here’s my hcid.conf

autoinit yes;
security user;
pairing multi;
name "BlueZ %h (%d)";
class 0x10010c;
iscan enable;
pscan enable;
lm accept;
lp rswitch,hold,sniff,park;

my mobile phone can connect without a problem…
so it seem to be that pairing doesn’t work because of a missing pin request (what’s about the pin-helper stuff?). I could reproduce the error with another machine running Kubunutu 8.04

Anyone tip to solve the problem?
Thanks in advance.

I have the same issue.
And after I googling I found This tutorial:
Apple Bluetooth Keyboard in Hardy - Ubuntu Forums

I follow it, but If I try to connect to my keyboard, I had this error message.

Error org.bluez.Error.ConnectionAttemptFailed: Required key not available

I give it a try in ubuntu hardy live cd, and it works perfectly :frowning:

Maybe this will help, add this line to /etc/sysconfig/bluetooth

# Arguments to hidd
HIDD_OPTIONS="--connect xx:xx:xx:xx:xx:xx"

Before that, I was copy hidd application from ubuntu hardy to my system, in path /usr/bin, and I don’t know why is not added by development in openSUSE 11.0 :confused:

So after that I can connect to my keyboard by this command, manually:

hidd --connect xx:xx:xx:xx:xx:xx

everything works as well, except FN key :frowning: , so I can’t using delete key or page up and down and multimedia keys too… etc.

I do a lot of things to make it works, like follow this article:
Gentoo Forums :: View topic - Apple Wireless Keyboard fn (delete, page up, etc) (SOLVED)

And installing pommed software, but without success!

I do a quick testing for fn key in ubuntu hardy, and it works by default.

Please, I need help for this if any one know about it.


Finally it’s works!

What I to do here is very sample, first at all I need a kernel source download it from repository, then I patching the file core.c in this path


I do it manually by opening file in a text editor and add this after line 686.

	/* Apple Wireless Aluminum Keyboard */
	{ 0x05ac, 0x022c, HID_QUIRK_APPLE_HAS_FN },

so it will look like this:

	/* Apple wireless Mighty Mouse */
	/* Apple Wireless Aluminum Keyboard */
	{ 0x05ac, 0x022c, HID_QUIRK_APPLE_HAS_FN },

I take this number (0x05ac) from my keyborad setting, by this command


And this is my output:

00:1E:52:F9:D9:E8 Apple Inc. Keyboard [05ac:022c] connected 

You should edit it as yours keyboard output!

After I save it, I go to the kernel source path /usr/src/linux-, then I do make an oldconfig for it:

make oldconfig

then, I start making for the kernel


It will take a long time to finish, after that, I do installing the modules only from it:

make modules_install

Actually I tried before to do that for bluetooth module only, but unfortunately I don’t know how do it, so i decide to do it like this way.

After finish installing modules, I restarting my system, and now my keyboard works perfectly as I want it. the only thing that I do after that is to configure a shortcut key for multimedia by gnome (fn + f7, fn + f8 and fn + f9).

I hope the openSUSE team to add this patch for next release kernel update.

Finally, sorry for my BAD English folks, it’s not my mother language.

PS: Before I add the last post, I was made a patching for another file, so that tutorial need a test for who Interested.

Hi, I successfully connected my apple wireless keyboard (the alu one) to my openSuse 11.0 box.
Everything seems working except the fn key. So I’m unable to enter pgup, pgdown, home, end and canc.

Xev doesn’t show a keycode when I press the fn key. Indeed showkeys under init3 shows the fn keycode, but when pressing fn+left/right/up/down arrow nothing changes (I get the arrow keycode unchanged).

I’ve also tried to use control, option and command instead of fn but nothing changed.

The keyboard layout is us. I’ve tried it with a macintosh laptop machine and it works fine.

Any hint?

is there anything in the detailed post made by 74141 at 18.12 that might be of help to you; he says that his keyboard now works perfectly, after following the steps that he detailed;

sadly, it seems as though if one wishes to use this particular keyboard, a series of steps that he details are needed; do you feel able to follow them?

those of us who use $15 USB keyboards plug and play

What a stupid, I didn’t notice the kernel patching steps the first time I saw 74141’s post!

Now everything works fine, in fact I’m writing from my apple keyboard lol!

Why openSuse kernel isn’t already patched? it’s a pity…

I have this keyboard and I am having issues. I have exactly the same problem both on my desktop with a USB dongle and on my laptop with built in bluetooth. I am using Gnome.

I have the bluetooth icon in my tray. I right click it, click browse, put the keyboard in pairing mode, select it, and click connect. Then I get this error:

Couldn’t display “obex://[00:1F:5B:FA:62:2C]/”.
Error: Host down
Please select another viewer and try again.

Same thing happens if I try to connect my laptop and my desktop together. If I use the other method I’ve seen:

I right click the bluetooth tray icon, click preferences, and go to the services tab. Input service is checked. I click it, click add, and see the Apple keyboard. I select it and click connect. I get a blank box that says “connecting” and shortly afterward a box pops up in the lower right of the screen that says:

Pairing request for:
Apple Wireless Keyboard (00:1F:5B:FA:62:2C)
Click to enter passkey.

I I click “Click to enter passkey” a box pops up where I can type in a pin, but I can’t type anything with the Apple keyboard. I tried entering a pin and hitting enter when it says “connecting” but that doesn’t make any difference. After a little while the I get a bug report that the application bluetooth-properties crashed.

I tried using kinputwizare instead, which has almost the exact same procedure. I still can’t type anything with the apple keyboard, but instead of crashing kinputwizard just says it failed to create an account for my device.

I should also note that when I type “hidd” into the terminal, bash comes back saying it doesn’t recognize the command.

What am I missing? I’m getting quite frustrated trying to get this thing to work. Is it normally this difficult to use bluetooth in OpenSUSE?

Actually I just updated bluez-gnome in YaST to the latest version and now the keyboard was able to connect. Sorry for the long post. Luckily my fix was very simple.

FWIW I connected by going to preferences, input services, add. I did have to type in the code (which I created with the Apple keyboard) with my old keyboard though. I wasn’t able to type anything until after the keyboard had been verified.