Apper Updated some package, and after there is no kernel file on boot

Hello,

I’m a beginner OpenSUSE User…(and my english is poor…)

Few weeks ago I have installed OpenSuse 12.2 64 bit and almost everyday Op/system updates itself with adviced packages!
I haven’t had any problem until now.
Today I have engaged to updated some packs too , and it’s shown after the restart button to enable the updates.
I’ve restared and it says at the boot:

file '\boot\3.4.2.8.2.20 kernel…(bla bla bla) not found

Press any key to continue…

I’ve tried to start in recovery mode, but just repeat the message!

What do I have to do?
Start an Istall DVD again with restore?
Please help!

Thx, H

https://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

In your case you might be wise to run

*grub2-mkconfig -o /boot/grub2/grub.cfg*

Thx a lot, but theres a problem again

I have 2 harddisks sda ntfs and sdb 1. part ntfs 2. part linux (with boot/system and swap and data area)

I understand that the 3rd step is mount /dev/sdb(X) with the boot device’s number… /mnt

it answers: unknown file system
but there is a boot * near by the dev/sdb(x)…
and of course there is no other boot on that drive

I tried to mount the data part of sdb (6) also.
But the last operation, the grub2 command havent worked.

And after Dont know the command grub2 or grub sometimes or wait until…??

or it opens a sub menu

grub>

and I tried without grub only with the parameters again and again
still havent worked

I try to write it down correctly again:

I choose any kind of menu at the startup it answers:

Loading linux 3.4.28-2.20-desktop...
error: file '/boot/vmlinuz-3.4.28-2.20-desktop' not found
Loading initial ramdisk...
error: you need to load the kernel first.

Press any key to contnuie…

Thanks for the help

Finally I made it…

thanks for the help

Hugo

Well done
Sorry I was away

Is this safe also on UEFI installs/systems?

All it does is probe for installed systems and build a menu

Have a same problem with op on my usb system yesterday (kernel not found).

Followed your instructions but I don’t know what is DVD rescue. So I run a live opensuse usb system and boot to it to fix the other broken usb system.

When I execute “chroot /mnt”, it says "chroot: failed to run command ‘/bin/bash’: No such file or direcotry?

https://forums.opensuse.org/content/146-using-livecd-take-over-repair-installed-system.html

Thanks. Saw the last line later.