Apper Unsigned Packages

I’m running OpenSuse 12.1 KDE x64.

I added the Packman repos. Apper notified me that I had 76 updates, so I let it go ahead and get started. Now I keep getting the error:

“You are about to install unsigned packages…”

I keep clicking yes, and after 10 times or so Packagekit gets mad and starts asking for a password. I’ve had to enter my root password 5 times now. I bet I’ve clicked “yes” more than 20 times.

Is there some way to get updates without being nagged to death?

Tried several commands online, but they aren’t working:

mooreted@linux-8qz9:~> su -c <nowiki>“rpm --import”</nowiki>
bash: syntax error near unexpected token newline' mooreted@linux-8qz9:~> sudo rpm --import root's password: curl: (56) response reading failed error: import read failed(2). mooreted@linux-8qz9:~> sudo lynx --dump |gpg --import gpg: directory /home/mooreted/.gnupg’ created
sudo: lynx: command not found
gpg: new configuration file /home/mooreted/.gnupg/gpg.conf' created gpg: WARNING: options in /home/mooreted/.gnupg/gpg.conf’ are not yet active during this run
gpg: keyring /home/mooreted/.gnupg/secring.gpg' created gpg: keyring /home/mooreted/.gnupg/pubring.gpg’ created
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

So, I decided to take a break from clicking “Yes” over and over again and came back to another error: “You have failed to provide correct authentication.”

So, basically, I can’t update my system right now.

Tried changing the Packman repo to one in Germany; no change. I guess I just wont update this system for awhile.

Crud, installed Lynx and tried again:

Looking up
Making FTP connection to
Looking up
Making FTP connection to
Can’t Access `’
Alert!: Unable to access document.

lynx: Can’t access startfile
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Talking to myself, but maybe it will help somebody. Success for the GPG key.

mooreted@linux-8qz9:~> sudo lynx --dump |gpg --import
gpg: /home/mooreted/.gnupg/trustdb.gpg: trustdb created
gpg: key 9A795806: public key “PackMan Build Service (PackMan Build Service) <>” imported
gpg: Total number processed: 1
gpg: imported: 1

Now, can I update?

Nope, still doesn’t work.

Ok, I’m lost. Need help.

Ok, it’s actually not Packman, it’s the official OpenSuse repos. I just disabled Packman, and still getting the error.

Changing mirrors.

Go into Yast. Check “Software Repositories”. Click on “GPG Keys”. That should check whether you have the repo keys installed.

Well, it doesn’t show any. No update should be this hard, by the way.

Guess I’ll search around and see if I can find some.

Once installed
Follow this

*You don’t need to add keys for the default repos that are there from the installation.

Anyone know where I can get the GPG key for the OpenSuse update server?

Well, then, why am I getting this error?

Using Yast2 it doesn’t gripe about unsigned packages, but it says Dolphin doesn’t pass checksum.

Is it possible to remove Apper? So far it seems like a buggy PITA.

I’ve deleted it
But you can just configure it to Check for updates > Never

Ok, I shutdown and disabled Apper, then I downloaded Dolphin from the update repo and installed it manually, once that was done Yast2 had no problem updating the system.

I posted plenty of times here to dump Apper.

:slight_smile: Enjoy

Yeah, boy that program is annoying. Wish I would have found your posts before tearing out most of my hair.

Have a good one.