Apper unkown error after upgrading to 12.1 from 11.4

I am kind of newbie in the openSUSE community and I have never upgraded a distribution before. So, I followed the instructions given here SDB:System upgrade - openSUSE (form Running the Upgrade) and the Installation did happen BUT ever since there is a massage asking a password for a proxy, the message shuts down on its own and an “Apper unknown error occured” appears. I tried to check the Updates manager but the same happens there. I’d like to ask if anyone has some idea over this AND if it is recommendable to repeat the upgrade on my system (upgrading to 12.1 now that I already have 12.1). In general, repeating upgrades while upgraded causes/solves problems?

Thnx in advance

I am inclined to think that apper itself is a known error. Its name should be changed to “crappy”.

I disabled the automatic start of apper in the service manager settings of KDE. I have since started it a couple of times manually, and it gives me an error message - I think that might be the error message you are seeing.

It is complaining that it cannot find the install DVD.

As it happens, I marked the DVD (really a USB in my case) as “no autorefresh” in the repo list. Yast online update is quite happy about that, and does not ask that I load the DVD image. However, apper complains every time.

I have now disabled it in the repo list. That seems to solve the problem.

I didn’t do the installation using DVD or USB. Although, the system does NOT have updates ever since. That is the problem. When authentication is required, the same message appears and it closes on its own./

What is more recommendable? Repeat the upgrade or perform complete installation using a DVD or a USB?

There have not been any updates, yet.

Well, okay, that’s not quite correct. There was an initial update to yast/zypper, and a second update due to the “pull in flash”. I got those by doing Yast online update shortly after install.

There has not been anything else, though I haven’t checked yet this morning.

There should be a firefox update any time soon. My 11.4 system was updated to firefox 8.0 last week. So now, I am holding back on upgrading my desktop system to 12.1, since that would downgrade firefox to 7.0.1 (if I remember the version correctly).

You can use yast online update in place of apper. With 11.4, I would occasionally start kpackagekit to check for updates (having disabled it from starting with KDE). But I don’t like apper at all, so I am inclined to do it all with yast online update for 12.1

On 2011-11-19 09:36, patti225 wrote:
> What is more recommendable? Repeat the upgrade or perform complete
> installation using a DVD or a USB?

Disable apper and use yast.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)