Apper closes unexpectedly when installing Epson printer RPM

I am a relative newbie with a fresh 12.1 and I am trying to add the printer driver for my Epson WP-4020 printer which is out on my network without success.

I download the RPM from the Epson website and an installer starts, tells me that there are 16 programs that must be installed and provides the list. I say ok and it starts to act and then fails saying KDEInit could not launch /usr/bin/apper. I looked for that file “apper” and it does exist in that location.

When I ok that box, I get another that looks like this:

If I push the “Restart Application” button, it goes grey but nothing seems to happen.

I am not sure what to do now. I did this successfully on my SUSE 11.4 and the printer works fine. Now I would like it to work on this 12.1 system.

Thanks for any suggestions.


This could be a bit difficult to answer because almost nobody here uses apper.

We use the system management tool of choice: YaST. In this case Yast > Software > Software manager. An alternative is the CLI command zypper.

Those people have switched apper off or even deinstalled it.

Thanks. I guess it comes about because I get the software specific to my printer from the Epson website and they provide an RPM and on my default 12.1 installation, Apper is the default installation tool.

So how do I install a vendor provided RPM with YaST?

Silly me. I just checked YaST for “Epson” and there is a driver. I will try it.

Still no joy. I installed the YaST “Epson inkjet printer driver” and tried to set up the printer with CUPS. CUPS finds the printer on the network but does not find the YaST installed driver, so perhaps it is not the right one?

This worked on my 11.4 system.


George, you can install the rpm using “rpm -ivh foo.rpm”. Are you using YAST to setup the printer? With openSUSE I use that instead of the CUPS web interface. Also, I just uninstall apper as it doesn’t seem to be much use except for update notification, so I just run “zypper up” every day or so.

This method worked for me to install an Epson printer.

I am still working on this so thank you for your replies. I got the printer located in YaST add a printer but I haven’t got the right driver sorted/installed. I am not using Apper this time.

hello lak611

I tried using your first method and this is what I get. The Epson rpm file name was quite long so I really did rename it foo.rpm:

george@linux-jsez:~/Downloads> rpm -ivh foo.rpm
warning: foo.rpm: Header V3 DSA/SHA1 Signature, key ID 8aa65d56: NOKEY
error: Failed dependencies:
lsb >= 3.2 is needed by epson-inkjet-printer-201113w-1.0.1-1lsb3.2.i486

Not sure what to do now. What does “lsb >= 3.2” mean?



Sorry sometimes things are not as clear as they could be!

What the message is trying to say is that you can’t install the epson printer driver as you need to install the lsb package first.

If you go to this webpage (assuming that you are using opensuse 12.1) you can install the lsb package:-

Index of /distribution/12.1/repo/oss/suse/i586

Then you should try again. If you hit any other road blocks please post back as I have recently managed to install my epson scanner/printer.

Well, as that is the normal OSS repo, there is no need to go to the website.

Just use YaST > Software > Software management, search for lsb and install it.


zypper in lsb

Solved - the Epson printer is working here now with my 12.1 system

Thanks for all the help!

Would you please post your solution so others may benefit?

+1. It is important for those who tried to help to learn from it and others who come here via a (Google) search will not love it when they see their problem is solved but not how to do it.


I followed the advice given here which was to first install lsb using YaST. That part went smoothly.

I then used YaST, not CUPS to add the printer. The Epson driver however was not found by YaST so I found the appropriate .ppd printer descripion file with a search, unpacked it from that .gz, probably installed by the Epson driver install in that archive, unpacked it and placed it in a known location and then told YaST about it. The printer worked from there.

This Epson WP-4020 printer is very new, only started shipping last month I think and the Linux driver is dated a week or so ago. I am sure they will make it more installable eventually. The printer is great. Unfortunately, the quality of the Linux system graphic output is not as good as from a Windoze system as tested here with the same source file. Good but not as good. Do not use the “force rasterize output” option, it does not work correctly. It does auto duplex and promises low cost quality color and text printing. So far, I am impressed. Part of a line of four-in-one inkjets, this is the only printer-only.

I hope it will be a real workhorse around here. Nice to get it working with both SUSE and WinXP. Installation on 11.4 was painless, 12.1 not so.