Apper authentication popups don't pop up

I have just updated from OpenSuSE 12.3 to 13.1 on a dual-opteron PC (kernel 3.11.6-4-desktop, KDE 4.11.3), and I can no longer use Apper to update. I can check for updates with it, but when I try to apply them, I see no authentication dialogue popup, I receive a notification that I have failed to authenticate, and no update occurs. With Apper set to check for updates daily, I then receive more similar notifications but no authentication dialogues every time it tries to check for updates, which it does every few minutes. Other authentication dialogues–YaST, kwallet, CUPs–work OK. I have used YaST’s Onlime Update module to update, but it has far fewer updates on offer than Apper. Any suggestions?


Right click on the tray (panel) and select “System Tray Settings”. I usually right click just above the triangle for hidden icons.

In the tray settings, look at the “Extra Items”. There should be one for “Software Updater”. Make sure that is checked.

This sounds to me like a permissions issue, that happens if your user session is not correctly registered with logind.

Please post the output of:


ben@linux-3j1n:~> loginctl
1 0 root seat0

1 sessions listed.

ben@linux-3j1n:~> loginctl
1 0 root seat0

1 sessions listed.

Are you logged in as root?

If not, how are you logging in and get to the X session exactly?

No, I’m logged in as a user. The computer is set to boot to level 3. I then login as root, run kdm, and log in as user.

And how do you run kdm? I’m asking because it’s kdm that should register the user session with logind and apparently this does not happen in your case.
Does it work if you run kdm with “rcxdm start” or “init 5”?
(loginctl should show your user session)

I run the command “kdm” and then enter the user name and password in the dialog that appears once X-windows is launched.

Try with “rcxdm start” or “init 5”, please, and check if your user session is registered then with “loginctl”.

Do I enter “recdm start” or “init 5” at the root prompt, or are these flags for the “kdm” command?

Just enter either “rcxdm start” or “init 5” at the root prompt, instead of “kdm”.

I used “rcxdm start” instead of “kdm”, got the kdm login page and logged in as user. I ran "loginctl and got this:

en@linux-3j1n:~> loginctl
2 0 root seat0
3 1000 ben seat0

2 sessions listed.

So I do now have the user’s session listed as well as root’s.

I tried the apper updater (via the system tray icon), and it seems to have worked, though it behaved differently from what I am used to–the list of updates appeared, and then the list of applications to be installed, but when I clicked “apply”, the window closed, and there was a popup notification that suggested updating was in progress, rather than a progressive listing of the downloads and installations, followed by a recheck for updates. But a later check on apper via the kickoff menu indicated the system was now up to date. So I suppose it is working. I shall use “rcxdm start” to launch the K desktop in future. Is “kdm” now a deprectaed command?

Many thanks. If I have more trouble, I will be back.

Yes. Just click on the updater’s system tray icon to show the progressive listing of the current downloads and installations again.

I shall use “rcxdm start” to launch the K desktop in future. Is “kdm” now a deprectaed command?

I don’t think that you were ever supposed to run “kdm” directly.
The xdm init script takes care of much more like setting up the keyboard layout for X, switching to failsafe mode if the boot option “x11failsafe” is specified, and so on.
Also it calls the DM that is set as standard in /etc/sysconfig/displaymanager, so if one day you don’t want to use kdm anymore, just change it there…