Aperture pointing to e820 RAM. Ignoring - Loss of 64MB


Opensuse 11.1
athlon X2 4600
motherboard : gigabyte GA-M55S-S3
2 X 2GB ram
nvidia 8500 PCI-E

I have just upgraded my desktop from 1GB to 4GB (2X2GB) and added a sata drive.

I am missing 64 MB

> free -m
total used free shared buffers cached
Mem: 3961 885 3075 0 26 583
-/+ buffers/cache: 275 3685
Swap: 4102 0 4102

In dmesg it shows:-

Checking aperture…
No AGP bridge found
Node 0: aperture @ 20000000 size 32 MB
Aperture pointing to e820 RAM. Ignoring.
Your BIOS doesn’t leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ 20000000
PCI: MCFG area at f0000000 reserved in E820

I have a pci express card so agp shouldn’t be used ?

There is no IOMMU option in my bios…

If i add to the kernel line in grub to limit memory to 2GB I do not get the 64MB loss


As an experiment I tried the 32bit distro, I compiled a kernel with pae (up to 64GB) and I do not get the errors, I also have all my ram - i.e no loss.

Also when I use 32bit or limit the memory to 2GB in 64 bit the nvidia diver seems faster ??

I’ve tried iommu=noaperture in grub - this stops the message but I still get the loss.

Anyone any ideas - I know it is only 64MB but would like to stop the errors.

Yes, I noticed the same thing. I don’t have an IOMMU setting in the BIOS either. So I’m just ignoring the problem. I have plenty of RAM anyway and 64MB is nothing, and the price of that small chunk of RAM is certainly not worth spending more than 5 minutes over.

My, what a long way we have come. I used to have machines where 64MB was all the memory it had.