apache2 problems

I wanted to setup a home web server on my openSUSE 11.0 so I used yast to install the LAMP package openSUSE provided.

I ran using ‘rcapache2 start’ and it at first gave me an error “Invalid command ‘ExtendedStatus’, perhaps mis-spelled or defined by a module not included in the server configuration…”

then I did a bit of look around online and here’s my httpd.conf at ‘thotheolh private pastebin - collaborative debugging tool

Now it throws me a “(99)Cannot assign requested address: make_sock: could not bind to address…”

I tried to make it bind to my localhost/ address but it couldn’t.

How should I solve this ?

Is there some sort of ready made out of the box apache + php5 + mysql solution without all this hassle and problems ?

That’s not the standard httpd.conf that comes with openSUSE. The standard httpd.conf doesn’t have IfModule directives in it. Those are contained in included config files.

Did you copy your httpd.conf over from another distro? Are you using some foreign tool like webadmin? There’s something you haven’t told us.

What Ken said. If you use Yast to install and set up the Web server, it’s almost painless. For example, I’ve never had to run “rcapache2 start” myself; Yast set all that up for me.

If you are migrating the server, set up a skeleton with Yast on your Opensuse 11 system. Then transfer the content (ie., the pages and images) and tweak as needed to get what you want. But let Yast do the majority of the intial setup.

I am sure it’s yast’s installation. I haven’t used any outside sources other than whatever is in the repository given to me by yast.

I did install from yast a gnome apache admin tool something like ‘gadmin’ ? I forget it’s name.

But overall, it’s all yast provided to what I know. I did actually tried to download httpd from apache’s website and I only manage to run ./configure and that’s as far as I can get before apache provided httpd failed.

I think my ./configure needs some parameters according to some search on Google but I am not sure and I gave up on trying to install anything without yast support as far as I can.

Since I didn’t make it to do an install properly for the apache provided httpd rather than yast provided, I doubt it would actually exist on the system.

How did I uninstall everything to do with httpd , apache , php5 and reinstall everything again (without reinstalling the OS).

I have successfully uninstalled the entire LAMP that might be in the OS and successfully reinstalled it just using yast and installing every single module for LAMP that yast can provide. It worked… but now… when I go to localhost via my firefox it could go to the default index.html for apache.

I decided to install phpMyAdmin from yast as well and when I tried to access it via the browser, it says “Access forbidden … You don’t have permission to access the requested directory…etc…” all those related to http error 403.

I also tried to install eyeOS and I got the same error 403 while trying to access it via the browser.

I remembered I am the one who installed it so why can’t I access the things I installed ?

phpMyAdmin works fine here. Did you install apache2-mod_php5 and all needed php5 modules, and activate php5 in Apache via YaST? Look in /var/log/apache2/error_log for clues. My guess is you don’t have PHP5 enabled so it’s trying to download the php file but it’s not allowed from that directory.

I have managed to fix the error 403 by tweaking the /etc/apache2.default-server.conf, setting the values for ‘Options’ and ‘AllowOverride’ to ‘All’. After the tweak, the error 403 didnot occur and when I go to http://localhost/phpMyAdmin , it list a whole list of files and folders in my browser. I guess this is a sign that the error is solved by the php module is not turned on.

So how do I switch it on ?

ok. thanks for the hint that php5 is not switched on. You are right on the spot. I used the Yast’s HTTP Server and PHP5 is disabled. I switch it on and restarted apache and I am in phpMyAdmin when I refreshed the browser.

Thanks a lot :slight_smile:

I’ve never used PhpMyAdmin on my server, but it’s not too difficult to
use a LAMP server without it.
As for the default index.html, you can set the directory for Apache to
use. It sounds like it’s using /srv/www/htdocs (as it is set to do).
In your httpd.conf or default-server.conf files, is there a section
between <Directory> tags with other directories?
Are you wanting the pages to be accessed from the local computer, from a
home network, from a specific place outside, or from anywhere?

I am working from within my home network. I managed to get it started. The reason is because the settings are being commented out from the start. Just need to uncomment it for it to work.