apache2-2.4.33 fails to start with cacti 1.2.14 on leap 15.1


I’ve used cacti over years on old suse systems like 11.2, 12.3, leap 42.1
Now I try to use it on Leap 15.1.
I’ve installed apache2 from repository some time ago (lp151.8.9.1)
Now I’ve installed cacti. Not working. After upgrading apache2 to newest version still not working.
Versions are:

-- Unit apache2.service has begun starting up.
Oct 07 19:02:56 gw1 start_apache2[7975]: httpd-prefork: Syntax error on line 210 of /etc/apache2/httpd.conf: Syntax error on line 119 of /etc/apache2/default-server.conf: Syntax error on line 15 of /etc/apache2/conf.d/cacti.conf: Expected </DirectoryMatch> but saw </Directory>
Oct 07 19:02:56 gw1 systemd[1]: apache2.service: Main process exited, code=exited, status=1/FAILURE
Oct 07 19:02:56 gw1 systemd[1]: Failed to start The Apache Webserver.

Any hints?

The error is pretty clear. Your /etc/apache2/conf.d/cacti.conf has an error, it seems like it has <DirectoryMatch> as an opening tag and </Directory> as the closing tag. Tags need to match, <Directory> </Directory>, <DirectoryMatch> </DirectoryMatch> etc.

Please copy paste the file here and encase it in CODE tags and we’ll fix it.

Your right. Thanks!!
This is the default config file which comes with the opensuse cacti version, which is wrong :frowning:

Corrected and now cacti starts but login does not work because it does not recognize php script inside.
I have already enabled php7 module in apache with
a2enmod php7
but still not showing login screen, only the opening dialog window to ask to open with which application or to save…

The exact error may be important.

Assume your other dependencies are installed…
From the Project source page,