Apache on 11.4

I’ve a server with opensuse 11.4 (from a 11.3 upgrade), but I can’t run Apache… I’ve tried latest version (official repository and Apache repository), but it give me always same error:

[error] (38)Function not implemented: apr_socket_accept: (client socket)

I’ve have removed and reinstalled apr/apr-utils also, but nothing…

what’s the problem?!!


Hello radarino, welcome to the forums.

I see that you got no response since yesterday. All I can say is that I would stick to the official oss repository. That worked for me “out of the box” so far. The error you are seeing is known to google:

Bug 294827 – Apache Hanging - Function not implemented: apr_socket_accept: (client socket)
Gentoo Forums :: View topic - [SOLVED] Apache: error with apr_socket_accept

Hope this helps a bit. Otherwise try to give some more details.

I’m going to check your links… but I’ve missed some details:
I’m running the 11.4 server on a virtualized machine (Xen), with a OpenSUSE 11.1 as dom0.

I’ve just tried a fresh 11.4 installation on a Virtualbox machine and all (apache) works well

Probably the error is caused by the different kernel version :frowning: