apache isn't working properly on opensuse tumbleweed

I have installed LAMP following instructions from this site, I also installed apache2-example-page, the “It works” works great but when I changed /srv/www/htdocs/index.html to something else firefox said “could not establish connection”.

I have added apache2 to the firewall exceptions and I added it to /etc/sysconfig/SuSeFirewall2.conf but it still doesn’t work.

I tried konqueror so that I see if it is the browser, knoqueror didn’t work either so there must be another problem, what is it ?

ps: not only changing index.html doesn’t work, also I created test.php and put it in /srv/www/htdocs and I got the same error, I tried putting test.php in /srv/www/htdocs/mytest and still got the same error.

This will be moved to Tumbleweed, … and is CLOSED for the moment.

Moved from Applications and open again.

ok so I made a workaround and the problem was solved, phpMyAdmin.conf contained these lines

<Directory /srv/www/htdocs/phpMyAdmin/libraries>
  Order allow,deny
  Deny from all

on starting apache it was giving syntax errors on them so I commented them and it worked, but I doubt this is a good solution, why didn’t it recognize Order and Deny ? I tried changing Order to “order” and still gave the same syntax errors, it said maybe there are some modules needed.

Is there a more robust solution ?

Because of changes in Apache 2.4.
See here:

Which version of phpMyAdmin did you install from where?
If it’s the package included in openSUSE, you should probably file a bug report.
This should just work on a default installation.

Is there a more robust solution ?

What do you mean with “more robust”?

Apparently you could enable the module “mod_access_compat” (with “a2enmod auth_compat”), then the “old” directives should be recognized again.
But this could also cause other problems I think.

I installed it from the package included in openSUSE, the version is 4.4.9, so where do I file a bug report ?

I mean a solution that is not a workaround :slight_smile: .

In openSUSE’s Bugzilla:

(same username/password as here)

I mean a solution that is not a workaround :slight_smile: .

Well, no idea whether you consider enabling the mod_access_compat (with “a2enmod access_compat”") a workaround… :wink:
I tried it over the weekend in a VM (I don’t use Tumbleweed myself) and it worked.

But it probably would be better to rather fix the phpMyAdmin package (i.e. make it compatible with the current Apache version, by using the new directives).

Changing your configurations by switching to the new directives is the real solution.

Using the compatibility module is a (temporary) work around.

Right. As that configuration is part of the phpMyAdmin package (and added by openSUSE), a bug report against openSUSE should be filed.

(Or branch the package yourself on OBS, change it, and submit it back… :wink: )

Btw, it works fine as-is in 13.2, I just tried it again.

I can’t find tumbleweed version in bugzilla page, I see factory, distribution , opensuse.org(project not distribution),13.1,12.3, no tumbleweed.

So do I file it under factory or opensuse.org ?

Tumbleweed is just the latest published snapshot of Factory.

or opensuse.org ?

No, that’s for the websites/wiki pages and project related things, it explicitely states “The openSUSE project (not the distribution)”. :wink: