Apache Error 403 Suse 13.1 (Typo3 Paket 6.2.12)

Wunderschönen Guten Morgen,

Ich habe ein Problem das ich einfach nicht lösen kann:

Ich bekomme einen 403 Error wenn ich versuche die Typo3 Startseite über meinen Apache Server zu öffnen.

Lösungsansätze:

Ich habe bereits sämtliche Berechtigungen wie in diesem Thread gesetzt und bin mir auch relativ sicher das diese stimmen. (kann aber gerne auch noch einmal die Berechtigungen hier posten)
https://forums.opensuse.org/showthread.php/499018-apache-error-403-Opensuse-13-1/

Dies hat mich auch weitergebracht. Ich kann Dateien (index.html/index.php) ohne Probleme im Browser öffnen aber sobald ich versuche die index.php meiner Typo3 installation zu öffnen kommt wieder der 403 Fehler wie wenn er diese gar nicht finden würde… ich tippe auf einen Fehler in der Konfiguration so das der Server Symlinks nicht folgt, leider hat auch die Option +FollowSymLinks in der httpd.conf nicht gebracht. Ich bin langsam echt am verzweifeln.

PHP5 läuft auch (falls jemand auf die idee kommt das der interpreter nicht an ist)

Hier nochmal meine vorgehensweise bei der Installation falls es hilft

Typo3 Installation

  1. Terminal öffnen
  2. Als root anmelden (su)
  3. Aktuelle Typo3 Version ins Verzeichnis /srv/www kopieren
    cp /var/run/media/adminlr/UUI/typo3_src-6.2.12.zip /srv/www
  4. Entpacken der Typo3 Version 6.2.12
    cd /srv/www
    unzip typo3_src-6.2.12.zip
  5. Symbolische links und .htaccess Datei erstellen
    ln -s /srv/www/typo3_src-6.2.12 /srv/www/htdocs/typo3_src
    cd htdocs
    ln -s typo3_src/typo3 typo3
    ln -s typo3_src/index.php index.php
    cp typo3_src/_.htaccess .htaccess
  6. Berechtigungen anpassen
    cd /srv/www
    chown -R wwwrun htdocs
    chgrp -R www htdocs
    chmod -R 644 htdocs
    chmod u+x /srv/www/htdocs
    service apache2 restart
  7. Index.php erlauben
    vi /etc/apache2/httpd.conf
    Zeile 166: index.php hinzufügen
    Option +FollowSymLinks hinzufügen
  8. PHP5 aktivieren
    a2enmod php5

Ich hoffe mir kann jemand helfen

Gruß
H2F

403 heisst “Forbidden”, also verboten.
Laut deiner geposteten Vorgehensweise dürfte es nicht an den Dateiberechtigungen liegen.

Hier nochmal meine vorgehensweise bei der Installation falls es hilft
Typo3 Installation

5. Symbolische links und .htaccess Datei erstellen
ln -s /srv/www/typo3_src-6.2.12 /srv/www/htdocs/typo3_src
cd htdocs
ln -s typo3_src/typo3 typo3
ln -s typo3_src/index.php index.php
cp typo3_src/_.htaccess .htaccess

Vielleicht liegt das Problem ja in der .htaccess Datei?
Welche Rechte hat die? (Da es eine versteckte Datei ist, haben deine chmod, chown und chgrp Aufrufe weiter unten womöglich keinen Effekt auf sie)
Welchen Inhalt?
Und probiers vielleicht mal ohne.

  1. Index.php erlauben
    vi /etc/apache2/httpd.conf
    Zeile 166: index.php hinzufügen

Das ist definitiv nicht notwendig! index.php wird automatisch gesucht/gefunden wenn php aktiviert ist.
Und ich persönlich halte es für schlecht, die von der Distribution mitgelieferten Config-Dateien zu ändern. Das kann zu Problemen bei Updates führen, weil die Dateien dann nicht mehr angepasst werden.
Das “FollowSymlinks” sollte nicht notwendig sein, wenn du den Inhalt des typo3_src Ordners einfach nach /srv/www/htdocs/ kopierst anstatt Symlinks anzulegen. Aber auch wenn nicht, das sollte wohl eher in einer .htaccess Datei, oder in /etc/apache2/config.d/ bzw. /etc/apache2/vhosts.d/ gesetzt werden.

Ich würde daher raten, die httpd.conf zu löschen und das Paket apache2 neu zu installieren (“zypper in -f apache2” oder “Unbedingt Aktualisieren” in YaST), um das Default zurückzubekommen.

Anonsten wäre auch mal ein Blick in Apaches Error Log (/var/log/apache2/error_log) eine gute Idee. Vielleicht gibts da nähere Informationen warum der Zugriff verboten ist.

Vielen dank für die Infos,

Nur nochmal kurz nebenbei: ich kenne mich nicht perfekt aus, weder mit linux noch mit apache oder generell mit Berechtigungen

Ich verwende Symbolische Links da ich mehrere verschiedene Typos mit einer Source betreiben will, die htaccess hab ich einfach aus der Typo3 Quelle übernommen und noch nichts daran gemacht (wahrscheinlich ist das auch eines meiner Probleme)

Hier der Error_Log

[Wed May 06 09:04:50.793137 2015] [autoindex:error] [pid 4305] [client 127.0.0.1:58460] AH01276: Cannot serve directory /srv/www/htdocs/: No matching DirectoryIndex (index.html,index.html.var) found, and server-generated directory index forbidden by Options directive
[Wed May 06 09:04:51.493487 2015] [autoindex:error] [pid 4305] [client 127.0.0.1:58460] AH01276: Cannot serve directory /srv/www/htdocs/: No matching DirectoryIndex (index.html,index.html.var) found, and server-generated directory index forbidden by Options directive
[Wed May 06 09:06:25.933803 2015] [mpm_prefork:notice] [pid 4288] AH00170: caught SIGWINCH, shutting down gracefully
[Wed May 06 09:06:26.110692 2015] [ssl:warn] [pid 4406] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 06 09:06:26.111714 2015] [mpm_prefork:notice] [pid 4406] AH00163: Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1k configured – resuming normal operations
[Wed May 06 09:06:26.111729 2015] [core:notice] [pid 4406] AH00094: Command line: ‘/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND’
[Wed May 06 09:06:28.152308 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:29.161173 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:30.807777 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:32.026869 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:32.324755 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:32.721325 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:33.611038 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:34.182937 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:34.484234 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:06:34.607842 2015] [core:error] [pid 4423] [client 127.0.0.1:58467] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:07:46.173264 2015] [core:error] [pid 4424] [client 127.0.0.1:58468] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:07:47.144541 2015] [core:error] [pid 4424] [client 127.0.0.1:58468] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:08:41.581605 2015] [mpm_prefork:notice] [pid 4406] AH00170: caught SIGWINCH, shutting down gracefully
[Wed May 06 09:08:41.734986 2015] [ssl:warn] [pid 4475] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 06 09:08:41.735942 2015] [mpm_prefork:notice] [pid 4475] AH00163: Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1k configured – resuming normal operations
[Wed May 06 09:08:41.735965 2015] [core:notice] [pid 4475] AH00094: Command line: ‘/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND’
[Wed May 06 09:08:43.578189 2015] [core:error] [pid 4492] [client 127.0.0.1:58475] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:08:44.533760 2015] [core:error] [pid 4492] [client 127.0.0.1:58475] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:08:45.329307 2015] [core:error] [pid 4492] [client 127.0.0.1:58475] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Wed May 06 09:13:59.511720 2015] [mpm_prefork:notice] [pid 4475] AH00170: caught SIGWINCH, shutting down gracefully
[Wed May 06 09:13:59.655183 2015] [ssl:warn] [pid 4737] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 06 09:13:59.656362 2015] [mpm_prefork:notice] [pid 4737] AH00163: Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1k configured – resuming normal operations
[Wed May 06 09:13:59.656378 2015] [core:notice] [pid 4737] AH00094: Command line: ‘/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND’

ja da stimmt etwas nicht… aber warum sagt er

  1. das symbolische Links nicht erlaubt sind bzw. ich kein recht auf das Verzeichnis habe? liegt das nur daran das auf dem index.php link root rechte statt www:wwwrun liegen? (siehe Berechtigungen)
  2. das er keine passende Datei im Verzeichnis findet obwohl hier die index.php liegt? Auch diese eine Berechtigung?

Berechtigungen Verzeichnis…

www:

drwxr–r-- 2 wwwrun www 4096 4. Mai 13:23 cgi-bin
drwxr–r-- 4 wwwrun www 4096 6. Nov 2013 htdig
drwxr–r-- 2 wwwrun www 4096 6. Mai 09:37 htdocs
drwxr–r-- 2 wwwrun www 4096 28. Sep 2013 perl-lib
drwxr–r-- 3 wwwrun www 4096 6. Mai 09:31 typo3_src-6.2.12

htdocs:

-rwxr–r-- 1 wwwrun www 5472 6. Mai 09:02 .htaccess
lrwxrwxrwx 1 root root 19 6. Mai 09:37 index.php -> typo3_src/index.php
lrwxrwxrwx 1 wwwrun www 15 4. Mai 15:20 typo3 -> typo3_src/typo3
lrwxrwxrwx 1 wwwrun www 25 4. Mai 15:20 typo3_src -> /srv/www/typo3_src-6.2.12

wie man sieht hat er tatsächlich noch nicht überall die gleichen berechtigungen, aber warum? wenn ich diese doch rekursiv runterbrechen lasse…

Ich hoffe das ich nicht wirklich einfach nur zu dämlich bin den Fehler auf eigene Faust zu finden aber naja. Ich werde die nächsten 2 Stunden mal versuchen ob ich es mit den neu gewonnenen Infos auch selbst hinbekomme.

Gruß
H2F

EDIT:

Ich habe nun versucht die Berechtigung des Links und der htaccess datei zu bearbeiten (habe aber nicht in die htaccess reingeschaut), das hat nicht geklappt
mir ist aber aufgefallen das im Source Ordner die Berechtigung der index.php auch passen sollte:

-rwxr–r-- 1 wwwrun www 1573776 16. Apr 09:32 ChangeLog
-rwxr–r-- 1 wwwrun www 7364 16. Apr 09:32 composer.json
-rwxr–r-- 1 wwwrun www 691 16. Apr 09:32 .editorconfig
-rwxr–r-- 1 wwwrun www 5472 16. Apr 09:32 _.htaccess
-rwxr–r-- 1 wwwrun www 921 16. Apr 09:32 index.php
-rwxr–r-- 1 wwwrun www 9479 16. Apr 09:32 INSTALL.md
-rwxr–r-- 1 wwwrun www 18425 16. Apr 09:32 LICENSE.txt
-rwxr–r-- 1 wwwrun www 9420 16. Apr 09:32 NEWS.md
-rwxr–r-- 1 wwwrun www 5578 16. Apr 09:32 README.md
drwxr–r-- 9 wwwrun www 4096 16. Apr 09:32 typo3

am Ende habe ich im VZ /srv/www/htdocs die .htaccess datei gelöscht, ergebnis bleibt gleich : Fehler 403

Wie im ersten Post erwähnt: wenn ich nun eine FESTE php Datei, also keinen symlink in den ordner werf, gibt er mir diese ganz normal aus.

Gruß
H2F

Ok.
An sich sollte das mit den Symlinks ja funktionieren, mit der entsprechenden Konfiguration.
Aber ein falsches oder unlesbares .htaccess kann auf jeden Fall den Zugriff verbieten.

Die Berechtigungen schaun ok aus, aber bitte poste mal den Inhalt wie schon vorgeschlagen.
Vielleicht musst du da was anpassen, und wie gesagt, ich denke du solltest die “Option +FollowSymlinks” eher da drin setzen.
Evtl. schaltet die aktuelle Datei ja auch speziell FollowSymlinks aus…

ja da stimmt etwas nicht… aber warum sagt er

  1. das symbolische Links nicht erlaubt sind bzw. ich kein recht auf das Verzeichnis habe? liegt das nur daran das auf dem index.php link root rechte statt www:wwwrun liegen? (siehe Berechtigungen)
  2. das er keine passende Datei im Verzeichnis findet obwohl hier die index.php liegt? Auch diese eine Berechtigung?

Tja, die Fehlermeldung sagt, dass Links entweder nicht erlaubt sind (sollte aber durch die Option “+FollowSymlinks” erlaubt werden), oder die entsprechende Datei auf die der Link zeigt nicht lesbar ist.

Kannst du vielleicht mal die /etc/apache2/httpd.conf posten? Vielleicht hast du die Änderung ja an einer falschen Stelle gemacht?

Der Besitzer des Links ist egal. Der Link selbst hat sämtliche Rechte für alle Benutzer.
Und die Berechtigungen der eigentlichen Dateien scheint auch in Ordnung zu sein.

Also das Wahrscheinlichste ist dann, dass eben die “Option +FollowSymlinks” nicht beachtet oder überschrieben wird, denke ich. (vor allem wenn eine tatsächliche index.php Datei in htdocs funktioniert…)

Berechtigungen Verzeichnis…

Schaut eigentlich ok aus.

wie man sieht hat er tatsächlich noch nicht überall die gleichen berechtigungen, aber warum? wenn ich diese doch rekursiv runterbrechen lasse…

Wie bereits angedeutet, ein rekursives chmod ignoriert versteckte Dateien/Verzeichnisse (also welche die mit einem ‘.’ beginnen).

Also hier die aktuellen Fakten:

Die .htaccess Datei im VZ /srv/www/htdocs ist gelöscht
Apache habe ich neu installiert wie du es beschrieben hast, dementsprechend sollte die httpd.conf auch wieder den Standard haben, Ausschnitt:

forbid access to the entire filesystem by default

<Directory />
Options None
AllowOverride None
Order deny,allow
Deny from all
</Directory>

use .htaccess files for overriding,

AccessFileName .htaccess

and never show them

<Files ~ “^.ht”>
Order allow,deny
Deny from all
</Files>

Immernoch Error 403, jetzt funktionieren auch andere html/php dateien nicht mehr in dem ordner https://forums.opensuse.org/images/icons/icon7.png

Gruß
H2F

In welchem Ordner? /srv/www/htdocs/?
Äh, also das sollte nicht sein.
Bekommst du da auch Error 403?
Wenn .htaccess gelöscht ist, kanns dann eigtl. nur an den Dateiberechtigungen liegen…

Im Zweifelsfall poste bitte die Berechtigungen dieser “anderen” html/php Dateien.

Jedenfalls sollten wir mal schauen das Apache prinzipiell wieder funktioniert, dann können wir versuchen das (vermutliche) Symlink-Problem zu lösen.

Hi,

Hatte heute leider keine Zeit mehr das ganze noch einmal zu überprüfen aber ddirekt morgen früh werde ich sowohl die Berechtigungen als auch die konfig nochmal überprüfen ob ich nicht doch etwas übersehen habe, danach poste ich nochmal alles wichtige.

H2F

So,

ich habe die Berechtigungen noch einmal gesetzt, tatsächlich gehen die html/php Dateien im VZ htdocs jetzt wieder.

Nun habe ich die index.html die zum Test in htdocs lag wieder gelöscht um zu schauen ob er eventuell nun dem Symlink folgt, leider Fehlanzeige.
Wieder Error 403 -.-

Berechtigungen htdocs:

lrwxrwxrwx 1 wwwrun www 19 6. Mai 09:37 index.php -> typo3_src/index.php
lrwxrwxrwx 1 wwwrun www 15 4. Mai 15:20 typo3 -> typo3_src/typo3
lrwxrwxrwx 1 wwwrun www 25 4. Mai 15:20 typo3_src -> /srv/www/typo3_src-6.2.12

Berechtigungen in der Typo3 Source:

-rwxr–r-- 1 wwwrun www 1573776 16. Apr 09:32 ChangeLog
-rwxr–r-- 1 wwwrun www 7364 16. Apr 09:32 composer.json
-rwxr–r-- 1 wwwrun www 691 16. Apr 09:32 .editorconfig
-rwxr–r-- 1 wwwrun www 5472 16. Apr 09:32 _.htaccess
-rwxr–r-- 1 wwwrun www 921 16. Apr 09:32 index.php
-rwxr–r-- 1 wwwrun www 9479 16. Apr 09:32 INSTALL.md
-rwxr–r-- 1 wwwrun www 18425 16. Apr 09:32 LICENSE.txt
-rwxr–r-- 1 wwwrun www 9420 16. Apr 09:32 NEWS.md
-rwxr–r-- 1 wwwrun www 5578 16. Apr 09:32 README.md
drwxr–r-- 9 wwwrun www 4096 16. Apr 09:32 typo3

PHP5 ist an

a2enmod php5
“php5” already present

aktuellste Fehlermeldung aus dem Apache Error Log:

[Thu May 07 10:52:27.922436 2015] [core:error] [pid 9500] [client 127.0.0.1:59358] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php
[Thu May 07 10:52:28.782160 2015] [core:error] [pid 9500] [client 127.0.0.1:59358] AH00032: Symbolic link not allowed or link target not accessible: /srv/www/htdocs/index.php

Jetzt ist nur noch die Frage: warum lässt er den symbolischen Link nicht zu, bzw. wieso ssollte er nicht darauf zugreifen könnenhttps://forums.opensuse.org/images/icons/icon5.png

H2F https://forums.opensuse.org/images/icons/icon11.png

Ok, das ist schon mal gut.

Jetzt ist nur noch die Frage: warum lässt er den symbolischen Link nicht zu, bzw. wieso ssollte er nicht darauf zugreifen könnenhttps://forums.opensuse.org/images/icons/icon5.png

Naja, normalerweise sind SymLinks halt nicht erlaubt, aus Sicherheitsgründen nehme ich an (die könnten ja irgendwo hinzeigen und sogar Zugriff auf das komplette Filesystem ermöglichen).
So wie ich das verstehe, sollte “Options (+)FollowSymLinks” das aber erlauben.

Jedenfalls kann ich dein Problem hier mit einem simplen Test nachvollziehen, ich werd mich mal etwas weiter damit rumspielen und melde mich falls ich eine Lösung finde… Nur mal soviel: Setzen von “Options FollowSymLinks” in .htaccess scheint nicht zu funktionieren, genausowenig wie in der Apache Config. Hm.

Nur mal soviel: Setzen von “Options FollowSymLinks” in .htaccess scheint nicht zu funktionieren, genausowenig wie in der Apache Config. Hm.

Ja, genau das habe ich auch schon beides ausgetestet, ebenfalls ohne Erfolg…

aber das kann doch einfach nicht sein, ich meine es gibt doch etliche Leute die eine Typo Source für mehrere Homepages verwenden, bzw. generell einen SymLink für eine index Datei verwenden. In anderen Foren findet man sehr oft das die Option FollowSymLinks bei anderen funktioniert hat…

Es gibt aber noch ein paar andere Lösungsansätze im Internet wie beispielsweise statt

Deny from All, Allow from All
setzen aber das ist ja so weit ich weiß eine Sicherheitslücke, da man dann von extern auf Infos zugreifen kann die keinen Externen etwas angehen oder etwas derartiges.

Ich habe auch gelesen das es möglicherweise funktioniert wenn man

AllowOverride auf All
setzt aber ich halte mich da lieber an die Infos die du mir gibst, will ja nicht wieder was kaputt machen.https://forums.opensuse.org/images/icons/icon10.png

H2F

Ja ich weiß, ich hab auch schon etwas gegooglet… :wink:

Ein gängiger Weg um mehrere Homepages zu machen ist die Verwendung von VirtualHosts mit unterschiedlichen DocumentRoots, vielleicht gehts ja damit.

Mittlerweile hab ich aber entdeckt, dass zumindest ein Teil deines Problems vermutlich daran liegt, dass man scheinbar nicht (mit der Standard-config) auf andere Unterverzeichnisse in /srv/www/ zugreifen kann.
Wenn ich einen Ordner /srv/www/test/ anlege mit einer index.html (die kein SymLink ist) und ein Alias mache damit Apache das Verzeichnis findet, bekomme ich auch einen 503 Error wenn ich darauf probiere zuzugreifen.
Wenn ich meinen test Ordner nach /srv/www/htdocs/ verschiebe funktionierts.

Ich muss sagen, dass ich jetzt auch nicht der Experte in Sachen Apache Config bin (vor allem in Bezug auf SymLinks), obwohl ich schon Server aufgesetzt/konfiguriert habe (auf openSUSE Basis). Ist allerdings auch schon eine Weile her…


Ok, das Problem (dein ursprüngliches) ist scheinbar, dass die Konfiguration für /srv/www/htdocs in /etc/apache2/default-server.conf gemacht wird, nicht in /etc/apache2/httpd.conf:

DocumentRoot "/srv/www/htdocs"

#
# Configure the DocumentRoot
#
<Directory "/srv/www/htdocs">
        # Possible values for the Options directive are "None", "All",
        # or any combination of:
        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        #
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        #
        # The Options directive is both complicated and important.  Please see
        # http:///httpd.apache.org/docs/2.4/mod/core.html#options
        # for more information.
        Options None
        # AllowOverride controls what directives may be placed in .htaccess files.
        # It can be "All", "None", or any combination of the keywords:
        #   Options FileInfo AuthConfig Limit
        AllowOverride None
        # Controls who can get stuff from this server.
        Require all granted
</Directory>


(kann natürlich bei 13.1 etwas abweichen…)

Wenn ich dort statt “Options None” “Options FollowSymLinks” schreibe, funktionierts mit den SymLinks (in /srv/www/htdocs/). Wenn man das “AllowOverride” ändern würde (zu “All” oder so) könnte man das dann wahrscheinlich auch in der .htaccess “überschreiben”. (bin mir jetzt nicht sicher warum ich das in /etc/apache2/conf.d/ nicht überschreiben kann, nicht mal für /srv/www/test/ oder /test/, aber bitte, wahrscheinlich mache ich was falsch/hab was übersehen)

Also ist evtl. das die Lösung für dich.

Wie gesagt, die mitgelieferten Config-Dateien zu ändern halte ich persönlich nicht für die beste Idee. Die Configs werden dann bei Updates nicht mehr geändert, das kann vor allem dann zum Problem werden, wenn du auf eine neuere Apache Version updates/upgradest (z.B. gibts Änderungen in der Zugriffskonfiguration zwischen 2.2 und 2.4, die zu 403 Fehlern führen können), im Notfall müsstest du die Datei dann händisch anpassen.
Anderseits kann sowas natürlich auch passieren wenn du eigene Optionen in .htaccess oder /etc/apache2/conf.d/ oder wo auch immer setzt.

Und wie gesagt, um mehrere Homepages zu betreiben (mit unterschiedlichen DocumentRoots) nimmt man vielleicht besser VirtualHosts. Dann kann man natürlich alle Optionen für jedes DocumentRoot/jeden VirtualHost extra nach Belieben setzen.
Definitionsdateien für VirtualHosts kannst du in /etc/apache2/vhosts.d/ anlegen um nicht die Standarddateien ändern zu müssen. Das macht übrigens YaST auch.

Aber wenn die obige Lösung funktioniert, kannst du ja auch der Einfachheit halber dabei bleiben.

:slight_smile:

Hat einwandfrei funktioniert, musste nur in der default-server.conf das

FollowSymLinks
einfügen, dann war auch die .htaccess datei egal, die ich wieder in den htdocs Ordner verschoben habe.

So eine Kleinigkeit und Stunden von Arbeit xD

Vielen Dank für die kompetente Hilfe, ob ich in Zukunft noch auf vhosts umsteige überlege ich mir noch, aber da es wo ja jetzt auch funktioniert, warum nochmal arbeit machen?

Falls ich oder einer in meinem Bekanntenkreis noch einmal irgendwelche ähnlichen Probleme habe/hat, werde ich auf jeden fall dieses Forum empfehlen, da ich noch nie innerhalb von so kurzer Zeit derartig viele Sinnvolle Lösungsansätze erhalten habe :smiley:

MfG
High2Fly

Tja, die Kleinigkeit muss halt auch an der richtigen Stelle geändert werden.
Tut mir leid dass ich da nicht schon gestern drauf gekommen bin…

Tja, die Apache Konfiguration ist halt (zumindest in openSUSE) etwas dadurch verkompliziert, dass sie auf mehrere Dateien und Verzeichnisse aufgeteilt ist.
Das macht man so um veschiedene Sachen zu ermöglichen, z.B. können Distributions-Pakete die Konfiguration ergänzen indem sie eine Konfig-Datei in /etc/apache2/conf.d/ legen. Das apache2-mod_php und apache2-mod_perl Paket macht das z.B., aber auch apache2-doc um auf die Apache Dokumentation via http://localhost/manual/ zugreifen zu können… :wink:
Außerdem kann YaST so leichter Konfigurationen an legen/ändern.

Es wäre natürlich auch möglich das alles zu umgehen, indem man die httpd.conf komplett mit einer eigenen Version ersetzt (die den Rest nicht einliest), aber dann muss man sich auch wirklich um die gesamte Konfiguration selbst kümmern (z.B. Laden des PHP Modules und Erkennung von *.php Dateien als PHP Skripts).

Übrigens, (open)SUSE-spezifische Dokumentation für die Apache-Konfiguration gibts auch hier (hab danach aber auch erst jetzt geschaut…):
SUSE Documentation bzw. http://activedoc.opensuse.org/book/opensuse-reference/chapter-20-the-apache-http-server (da wird z.B. die benutzte Struktur der Konfigurationsdateien erklärt, und auch wie man VirtualHosts konfiguriert)
Ist jetzt nur als Referenz gedacht, du musst dir das nicht unbedingt durchlesen… :wink:

Vielen Dank für die kompetente Hilfe, ob ich in Zukunft noch auf vhosts umsteige überlege ich mir noch, aber da es wo ja jetzt auch funktioniert, warum nochmal arbeit machen?

Ja, richtig.

Falls ich oder einer in meinem Bekanntenkreis noch einmal irgendwelche ähnlichen Probleme habe/hat, werde ich auf jeden fall dieses Forum empfehlen, da ich noch nie innerhalb von so kurzer Zeit derartig viele Sinnvolle Lösungsansätze erhalten habe :smiley:

Danke für die Blumen.
Ich bemüh mich halt, man kann ja auch selber was dabei lernen… :wink:

Allerdings kann ich auch nicht immer bei allen Problemen helfen.