apache doesn't start on 11.2

I just upgraded my home machine to 11.2 but apache is not starting automatically. I tried deleting apache2 in YaST and reinstalling it but it still doesn’t start. It doesn’t appear as an icon in YaST under network services either. There’s a log directory for it but no logs. There’s an /etc/apache2 directory.

I haven’t tried starting it manually because (a) I don’t want to destroy any evidence and (b) I want it to work automatically in future.

Is there something else I should be doing? Or how to diagnose?

Thanks, Dave

Start yast, then go to

System → System Services (Runlevel)

and activate apache2. This should do the trick.

Thanks; that seems to have fixed it. I wonder why that was necessary; I haven’t needed to do it on other machines.

And … perhaps not surprisingly, it hasn’t made the icon appear in YaST Network Services, so there’s obviously still something about the installation that isn’t quite kosher.

I think I’ve found out what it is. Instead of starting apache, go to YaST software management, choose the pattern view and select the Web and LAMP server pattern. Restart YaST and the HTTP server is now there. Select it and configure.