Apache access from internet

I configured apache server for few sites. All works perfectly in local network.
But when I try to download files from external network - there are some problems.
I can download file only if it size is no more then 255 bytes.

--2019-06-28 20:21:06--
Connecting to connected.
HTTP request sent, awaiting response... 200 OK
Length: 2215 (2.2K) [application/x-genesis-rom]
Saving to: ‘README.md.3’

README.md.3                                               0%                                                                                                                              ]       0  --.-KB/s    in 0s      

2019-06-28 20:21:06 (0.00 B/s) - Connection closed at byte 0. Retrying.

And all works it file has size less then 256 bytes:

--2019-06-28 20:21:48--
Connecting to connected.
HTTP request sent, awaiting response... 200 OK
Length: 255 [application/x-genesis-rom]
Saving to: ‘README2.md’

README2.md                                              100%=============================================================================================================================>]     255  --.-KB/s    in 0s      

2019-06-28 20:21:48 (77.8 MB/s) - ‘README2.md’ saved [255/255]

Can anyone help with this? I have no idea what is wrong. Disabling firewall didn’t help

Probably a restriction of your ISP?

All works before install 15.1.

No errors in access log: - - [29/Jun/2019:00:25:29 +0700] "GET /README.md HTTP/1.1" 200 2215 "-" "Wget/1.19.5 (linux-gnu)"

php files downloads successfully, all other - no

--2019-06-28 21:00:23--
Connecting to connected.
HTTP request sent, awaiting response... 200 OK
Length: 380 [text/html]
Saving to: ‘test.php’

test.php                                                100%=============================================================================================================================>]     380  --.-KB/s    in 0s      

2019-06-28 21:00:23 (27.7 MB/s) - ‘test.php’ saved [380/380]

By “download from from…” do you really mean “upload to server” since you’re the server?

If so,
A common question…

IIRC there can be a similar setting in the apache config as well…


You might need to clarify a bit…

If you’re running the command from your Apache server,
wget isn’t related to Apache, so it won’t be an Apache problem.

You’ll have to look at some other cause.
Consider how big your file is, only a few megabytes? Tens or hundreds of megabytes or larger?
Are you behind a firewall that might be filtering? Or something installed on your machine besides openSUSE?

Or, are you actually downloading files to a client?
If so, and the files are being downloaded from your Apache server,
Then it’s a common question
And, IIRC there may also be an Apache config setting that limits file size…


Well, in fact you do not download the PHP file, but the HTML file that is created by Apache executing the PHP file.

I wonder what

is and if Apache does something with that .md file.

Just trying.

I found this in the apache coniguration mime.types:

application/x-genesis-rom                        gen md

What means that a file that ends in .md is send by HTTP as application/x-genesis-rom. But that seams to be some ROM files for (game) consoles. Could it be that those have a restriction?

Thanks all.
Don’t know what exactly I did. But now it is worked. Seems I just restarted apache

EnableSendfile Off

Solved this problem.

I read the Apache documentation about EnableSendfile, but do not see how it helped here :(.

But when it helped, I assume we should not complain :wink:

In any case, thanks for reporting back. It might help others.

Hello all,

I wonder if this is related to this bug?


I was banging my head against a bug in apache where pages were failing to serve js scripts.

It looked like headers were being sent, but the files were failing.


ethtool -K eth0 tx-scatter-gather on

Fixed it for me.