Anyone Using wicd? Some advice please

If you use wicd. Do you / have you removed the native networkmanager packages? For me that’s kde4.

I installed wicd on my Dell Studio 1537 laptop last weekend. Last week it was running openSUSE-11.1 with KDE-4.3.1. It worked on our home wireless network. I then used the laptop on a business trip to France, connecting to two different networks (one at the hotel, and one at the place where our meetings too place).

In essence I followed this guide: Wicd - openSUSE

I don’t recall having to remove any applications. By changing (under YaST) “Network Setup Method” to the “Traditional Method with ifup” one is in essence disabling the Network Manager.

Last night I updated the laptop to KDE-4.3.2 and wicd is still working.

I read this from the wicd page

So it’s a really nice idea to remove NetworkManager from your PC while “wicd” is in. Or disable it completely (if you’re skilled enough to do it).

So was wondering. I see it’s easy to disable NM in the System Settings, though it seems to do that anyway.

Thanks Lee

Last time I installed it was in Ubuntu and Gnome, for my netbook. The installation if Wicd automatically uninstalled (or at least disabled) Network Manager then.

I have set the networking to use traditional method, uninstalled networkmanager.

Here is an interesting thing (maybe not a useful thing, but, hey, you can’t have everything):

I used to have lots of trouble with NM cr*pping all over the screen, but somewhere, in the process of lots of updates to try to get a workable KDE 4.x, that problem seems to have gone away. I look at what I am running and I get

 ps -ef | grep -i etwo
root      3087     1  0 13:40 ?        00:00:03 /usr/sbin/NetworkManager
root      3122     1  0 13:40 ?        00:00:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
markw     6502     1  0 13:44 ?        00:01:47 /opt/kde3/bin/knetworkmanager
root     11259  3087  0 19:34 ?        00:00:00 /sbin/dhclient -d -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/ -lf /var/lib/dhcp/ -cf /var/run/nm-dhclient-eth0.conf eth0

So I seem to be running the kde3 version of knetworkmanager under kde4 (when did that happen? how did that happen?) and it seems to be working well. Odd.

Something different seems to happen under Gnome, but that seems to work well - maybe even better with wireless hotspots. So, I’ve no idea how I got here, but I’m a bit unwilling to mess with it, in case I mess it up and can’t get back! Roll on 11.2, when I guess things will get a bit less ragged, at least as far as kde4 is concerned.

kde3 NM works fine in kde4. I use it ATM.