Anyone use Mycroft? How'd you get it working?

Howdy, I thought I’d give mycroft voice assistant a try, installed the plasmoid from the standard repo. When I opened it, I never saw a pairing code (for my account at, and when I said “Hey Mycroft,” no response though the microphone seems fine with any other app. Tried on 2 laptops with nearly identical Tumbleweed installs. Has anyone out there had more luck with this app, and do you enjoy using it or is it just a novelty?

Okay, I may have a line on why this isn’t working. The contents of /usr/share/plasma/plasmoids/org.kde.plasma.mycroftplasmoid/contents/code/ are as follows:


cd /home/$USER/mycroft-core/
./ all
paplay /usr/share/sounds/freedesktop/stereo/dialog-error.oga

However, there’s no directory /home/gef/mycroft-core, nor any file named anywhere on my system per kfnd. Reviewing the file list for package mycroft-core, I don’t see it listed. Filing a bug report.

This might help…

Thanks Malcolm, that thread seems focused on git-based install, which didn’t work for me, perhaps unsurprisingly because the short list of distros where it’s supposed to work doesn’t include opensuse. Furthermore, that thread also refers to scripts which seem to be missing from the zypper-based installation. The appimage didn’t work for me either, so my next step is to try it on Neon under virtualbox, in order to find out if it looks like something that would be useful to my workflow.

PS: Here’s what happens when I try the git-based installer, which after cloning the git requires a script to download dependencies,

                    Welcome to Mycroft!  

This script is designed to make working with Mycroft easy.  During this
first run of dev_setup we will ask you a few questions to help setup
your environment.

Do you want to run on 'master' or against a dev branch?  Unless you are
a developer modifying mycroft-core itself, you should run on the
'master' branch.  It is updated bi-weekly with a stable release.
  Y)es, run on the stable 'master' branch
  N)o, I want to run unstable branches
Choice [Y/N]:  Y - using 'master' branch 
fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

The repository version is a few release behind, I would suggest asking the maintainer to update to the 20.2.2 version? (email address here…)

Note: Did you see the read me part in the post install output (%post in the spec file) about configuration?

No, I missed that. Thank you. Now, if I understand, systemctl --user start mycroft-target in the package takes the place of, and better, the plasmoid launches that automatically. That’s great in theory, but alas even with manual start I see no change in behavior: When I open the plasmoid, I see internet content, and I see an icon that shows mic enabled. However, when I click the slider, I get a connection error, and when I say, “Hey Mycroft, pair my device,” nothing happens. And when I type, “pair my device” in the input field, nothing happens then, either.

Neon was a bust. After a lengthy install process, I shut down, took a snapshot, and now the thing hangs on boot. Know anybody who actually uses Mycroft and likes it?

Okay, the GUI is a lost cause, but I got the latest version of mycroft-core working, to the extent that it works (turns out downloading a zip file from git and unzipping it isn’t the same as using the git command itself).

Evidently, I can’t enunciate words like time or weather, or much of anything really, in a way Mycroft understands. So here’s hoping the project matures, but it’s not ready yet.

By contrast, Serenade amazes me, but it’s not a general purpose voice assistant, just a tool to write software using your voice. Alas, I’m no prorammer. It works on linux with Visual Studio Code using about a dozen languages including java(script), python, ruby, and sundry c variants. I worked through the python version of the short tutotial, and it understood everything I said, even when I deviated from the tutorial’s script. Alas, I didn’t understand all the code I was dictating, just enough to get the gist. For anyone who is a coder, I’d recommend a look. Seems to be available only as an appimage, but even so it’s less than a 100MB, whereas mycroft took a 2GB each on my root and home partitions.

What I’ve realized in the course of experimenting unsuccessfully with mycroft is that most of what I’d hope it could do is lready handled by krunner; a voice-enabled version of krunner would be a pretty good start on a digital secretary.

An update for the sake of completeness: Plasmoid from package works with git-based install; just run “~/mycroft-core/” before openng plasmoid. However, the performance is still unusable, even though it’s using google’s speech-to-text engine. I can go to which uses the same engine and get high accuracy, so I don’t know why it’s so bad with mycroft. Even if it does understand me, the krunner integration is broken.

Open Assistant (also git-based install) gets better accuracy just using pocketsphinx, but it’s still at the proof of concept stage with a tiny command set which you can expand by writing python modules. And I couldn’t get susi or stephanie to install at all.

Maybe the default training set???