Anyone tried Xrdp on 15.3? I'm at my wits end trying to get Xorg to work there.

Xrdp using Xorg and Xvnc on Tumbleweed latest work great.

But under 15.3 rc3, it just immediately goes down after logging through session panel.

I’ve looked and looked, but fear there’s just something wrong with the build of Xrdp.

Not interested in other versions… looking for people that are testing this under 15.3 rc3 in particular.

Works for me on a fully updated system this morning (not sure if that makes it rc3) and can log in with Plasma no problem using the standard windows client. My system currently reports:

julian@Progress:~> cat /etc/os-release 
NAME="openSUSE Leap"
ID_LIKE="suse opensuse"
PRETTY_NAME="openSUSE Leap 15.3"

This is on a system that was upgraded from Leap 15.2 but as I say had updates applied only a few hours ago.

Current version of Xrdp on my installation is from the “Main Repository (OSS)”

Just done a fresh install from the following download: openSUSE-Leap-15.3-NET-x86_64-Build151.1-Media.iso

Just added Xrdp, and stopped the firewall and started xrdp (from memory that’s all I have to do!).

When trying to Xrdp in I got (Link to screen shot):

I can however start an Xvnc session with:

Xvnc -ac -listen tcp -SecurityTypes None :20 &

and then access via VNC Viewer on port 5920 so VNC looks like it’s working.

OK, looks like there is an issue with /etc/xrdp/

I run a very customized version of this on my systems, hence I saw no problem.

In that file if I substitute

#  SESSION="gnome"
  case $SESSION in



  case $SESSION in

Then using Xrdp with either Xvnc or Xorg sessions comes up with a functional Xterminal window. Again this is using the Windows Xrdp client from Windows 10.

So it defaults to “gnome”, which I didn’t install. If I change it to “plasma” it all works fine for me.