Anyone getting repeated knotify4 crashes in opensuse 11?

I recently upgraded to KDE 4.1 beta2. Any time KDE 4 initiates a notification event, the crash reporter pops up and tells me knotify4 has crashed. If multiple notifications chain up (like new message notifications from Kopete), multiple crash report dialogs will show up and clutter the screen. I have temporarily worked around this by disabling the notification sounds in KDE settings->Notifications. I switched the radio box from “use kde sound system” to “no sound”. Apparently the knotify crashes only happen when it interacts with the sound server. Has anyone experienced this? Is there a way to fix this so the sound works as well?

Yeah I am getting it too, and there seems to of been a bug report filed.

Yeah, it was mentioned as a bug in another thread as far as the latest kde 4 beta goes. Thanks for the workaround, that will work for me until the bug is taken care of.

I Am getting this too, but I didnt find kde-settings to stop notifications system…
Can someone help?
Tnx for any help

Could you be more specific? I did find that it stopped the issue for me using the work-around above.

Go to your KDE menu and click Configure Desktop. Click on Notifications. The setting to turn off the sound should be in there.

Thanks for the work around :slight_smile: I was getting pissed of :frowning:

I have a clean openSUSE 11.0 installation (so KDE 4) and I have frequent knotify crashes, too.


Now I see,
thank you for the fast answer
I am new in this forums :slight_smile:

No problem, guys, glad to help. I really miss the KDE login sound though. :stuck_out_tongue:

:confused:YES! But as soon as I looked here I found an answer. Thank you OpenSUSE community!

Now U can try kde 4.0.84 from the factory repositories,
and enable sound notification again :smiley:
one click install link:

You don’t have to turn off sound. There is an option to use an external program for sound notifications. I used mplayer.

Thanks for the tip. However, its fixed in latest beta so YAY! All the sounds are back.

hi ,
it’s wierd, because the crash notfication just poped up when i rebooted my system at the 3rd time. After the installation left everything seemed to work pretty fine.
I’ll try after the updates to turn off the soundnotification,too.
i’ll edit this replay after i’ve got the real error msg of it, because this may help to solve the problem easier.



This problem should no longer occur with KDE 4.1.3. This thread was for pre-release 4.1.

I got a similar problem in OpenSuSE 11.3 using KDE 4.4 or KDE 4.5, but was able to work around it by switching the Phonon source to the VLC pulseaudio backend instead of Xine.

Having the same problem here. I thought it was me using KDE apps (kopete) with XFCE as the desktop. Running 11.3, did not have this problem in 11.1. Thanks for info for the workaround. I was searching on why kopete keeps disconnecting and reconnecting to my jabber server.

Dave W

How did you go from 11.1 to 11.3?

Create a new user account does it have the same problems?

I always do a fresh install, and a clean home directory.