Any way to use HP wireless scanner in opensuse?

I’ve been able to add my HP printer to CUPS (after installing hplip) but ONLY with the connection format of When I tried it with hp:// it did not work and when I tried it via hplip’s hp-setup it did not work. As a result, I am unable to use hplip’s GUI. So I cannot scan, I can only print. How do I get this working for scanning?

The problem with SANE is that it requires the printer to be connected to a computer. It won’t work with a wireless printer as far as I can tell (and yes, it takes ip addresses but only of a computer with sane on it and a scanner attached to it).

I’m using the latest version of hplip and can scan wirelessly with my printer. What printer are you trying to connect to? What version of hplip are you using?

I’m at work right now and do not have access to my Linux box. I’ll check the settings when I get home and post them here.

Thanks. Can you also tell me how you were able to hook it up through hplip or via an “hp:” protocol?

I connected the printer via USB to set it up first (as they say to do) and it never worked. It kept saying it could not get the printer onto the network.

I’m using an HP Officejet 6500 Wireless
HPLIP: version 3.9.8-15 (from openSUSE repository)

The printer will need to be setup using a Windows computer, through USB. I tried everything and could not get it to work through Suse. The Windows based installer will get it setup to use the wireless.

Once that is done, go to YaST->Hardware->Printer and see if it is shown there. I can’t remember if I had to add it or if it was already shown. Either way highlight the printer and then click on the configure button. The only thing you will need to do is set the proper drivers for your printer model.

Please post back with any questions or results.

PS: The printer is set to hp:…

But I did exactly that. I had originally set it up in Windows and I’m able to get the printer when I set it up via the socket: protocol, but if I do that, then hplip doesn’t see it.

Can you tell me what settings you have in YAST?

The way I did it was as follows. I’m not at my PC with the printer connected so this is mostly from memory and trying a dummy install.

Make sure your HP printer has an IP address. You can either configure one from it’s from panel or through HP’s windows setup.
In oS
I then installed HPs driver which got from their web site. I guess you could use YAST instead.
Make sure your printer is on and it’s wireless radio is on. do not plug it into the PC with the USB cable.
The YAST way. HP-toolbox method follows below.
In Yast go to printers and choose add a printer. It’ll scan for printers and most likely come up with nothing.
Click the connection wizard.
Choose TCP port (AppSocket/Jetdirect) under Access network printer.
In the IP address box type in the printer’s IP address.
Now test the connection.
Choose the manufacturer and press OK.
It should then install the printer after which you can set the default settings.

The HP-toolbox way (not sure if this is part of the default hplib or part of the HP driver I got from the HP site.
Start the HP-toolbox from the cli.
It should automatically open the add new printer wizard as none are installed yet.
Click on advanced options and check the manual discovery box.
Add the IP address of your printer and click next.
It should now present you with the printer.
Should be self explanatory from there.

Good luck.

Just a short post to thank everyone for this thread. I’m hoping to purchase an HP Multifunction WLAN capable printer before xmas, and reading of the difficulties and hopefully solutions, of others is a good way (and hence a good thread) for me to learn off of. I hope we get additional inputs.

The above instructions are good. A couple other tips.

The latest HPLIP etc is here Index of /repositories/Printing/openSUSE_11.1, or in Packman.

The packages in Packman are generally out of sync with the openSUSE repo so you’ll need to make a choice.

Pays to reserve the chosen printer IP against its mac address in your router, to avoid potential conflicts and printer re-configs in other attached hardware if the printer IP is reset for any reason.

Find a cheap source for your consumables!


Yes good tip. Saves a lot of headache.

Now that’s not so easy. Price of consumables is getting ridiculous, not to mention they quietly keep reducing the ink volumes in the cartridges. Disposable cartridges is such a waste of resources, money and creates unnecessary pollution.

I think that is the way I did it. It was so long ago, though. It is one of those things that “just worked” for me. I haven’t had to mess around around with it.

hp-toolbox is part of the hplip package. There was another one, something like hp-setup, that you had to run first, I think (but don’t quote me on that).

hp-setup: gets run from the installer. More information here. General Help information

To setup the scanner part you have to do it through Yast’s Scanner icon.

I set my printer up to use a fixed IP address, that saved me hours of headaches. I alwasy set it up to be a repeat of the initial IP number, ie, or etc, makes it easier to remember :).

Plus as someone already said, change to the packman version of hplip as it’s newer.

Oh, and don’t forget the firewall!


Wow, this has been driving me crazy! OK, here’s what I had to do:

YAST -> Hardware -> Scanner

Then I added the scanner (clicked the “Add” button) by choosing HewlettPackard OfficeJet 6300xi since there was no 6500 option. It didn’t work the first time but the second time I did it, it worked!!

Oh, one more thing: I was even able to scan directly from GIMP!! “growbag” you’re a genius!

I have noticed one annoying thing:

If I don’t have the HPLip application in the system tray, I can’t scan from GIMP.

Also, I can’t scan at all from open office. Anyone know how to do this?