Any version of linux work with Acer Aspire 4730z??

I stumbled across posts by another user on this forum who hasn’t posted in 2 years but had in his tag line that he was running opensuse 13.2 on an Acer Aspire 4730Z.

I tried to install this version on my laptop. It installs. But the bootloader fails to get past the ramdisk initialization.

I tried Kali and Debian linux, neither would even boot past the intro screens to get to the installation area.

Ubuntu was like openSuse in that it installed but grub would always hang. I didn’t turn off the silent and quiet options before overwriting that to try opensuse.

I don’t know if the insydebios that these machines come with is such trash that it won’t allow any linux to work properly. I’ve looked carefully at the EFI v. bios loading. This machine was loading via bios when windows 7 was on it (that’s how I originally got this hand me down). When I managed to get debian to boot live and ran tests it was also booting via bios then too.

I’m desperate for some help here. I was thinking if I could get ubuntu, opensuse or one of the other versions that had keys for secureboot to install I could then chain and use the bootloader to load other versions of linux I wanted like Kali. BTW, the bios is 1.22. It shows no options to change between legacy or EFI. It shows no options to change between secureboot being enabled vs. off. I was told by another well informed coder that if it was booting via bios that secureboot wasn’t enabled and shouldn’t be a concern.

Again, if any one has any knowledge about how to get opensuse or any version of linux installed on this type of laptop I would be grateful.

For me the strange thing in your story is that you tried an old and unsupported verion of openSUSE, but not a current one.

And about it being EFI or not and using secure boot or not, that should be found out by the installer without you having to worry. But again, I do not know this about 13.2. Try 15.0.

I appreciate your response. I’m not quite sure why my attempt to install a version, regardless of age, which was reported as installed on the same exact laptop model as the one I’m working on is strange. So far as empiricism goes, if one person indicates results with specificity, then another person ought to be able to replicate that with the same exact things specified. Hence my attempt with that particular version.

At this time opensuse 15 is being downloaded. I have no hopes of it working however. I fully expect it to fail. I would have expected the other version to have worked based on the other user’s profile but these Acer Aspire’s are absolute garbage and I would suggest no one buy them, ever. In my 22 some years of computing, programming, using various os’s, I have never come across this issue with trash bios’s like Insyde, which cripple the user options in the bios and potentially lock out the ability to install linux.

If I don’t hear from someone with a working installation on a matching or similar model for guidance my next step is to wipe it and put the original OS back on, Windows Vista. Just a warning for any one else who might stumble across this post and message regarding these machines and linux. I really thought I’d have a shot at getting one version to work the more I dug and read but this particular model is quite the headache. If I get it working with opensuse 15 I will be back to post about the success. Lacking that presume it to have failed.

Again thanks for the time and feedback.

You may be correct to assume that when somebody succeeded in installing 13.2 on that hardware two years ago, you must be able to repeat that. The problem is that nobody here will have a 13.2 anymore and thus, even if you would have described your problem more detailed, giving any advice is problematic.

Thus my idea that starting installing 15.0 and then reporting here with a good problem description might bring you quicker to success.

BTW, did you try to contact through a PM with that member that 2 years ago reported success? It might be that (s)he, in the mean time, also switched to a supported version on this hardware. But many members only visit the forums when they run into problems and will not browse the new threads to see of they mention " Acer Aspire 4730Z". Thus a more active way of drawing attention might help.

I note from surfing that it has been possible to get versions of GNU/Linux running on this old Acer Aspire 4730Z. Some OLD examples:

Assuming this is a 64-bit (and not 32-bit) laptop, and that the laptop hard drive is large enough, I suspect there is a reasonable chance of succeeding with openSUSE, … especially if patience is shown and any installation errors are reported on the forum, for forum users to help. It may thou, be an iterative install process, as any installation errors encountered are addressed one by one.