Any openSUSE-12.3 Intel-7260 wireless experience ?

I have a colleague who is considering installing openSUSE on their Sony Vaio Pro-13 laptop, which has an Intel-7260 wireless device.

I’ve read of Ubuntu, Arch Linux, and Fedora users struggling with this device, and having to install from GIT custom firmware for the device.

with respect to openSUSE-12.3, I note that the firmware for this device was only included in the kernel-firmware-20130714git version, where the change history for Mon Jul 29 2013 by jeffm at has in the “Updated to git snapshot 2013/7/14” comment:

  - iwlwifi: add firmware for 7260 / 3160 devices

That suggests to me if my colleague installs openSUSE-12.3 with a ‘wired’ connection, and if they then install the kernel updates (including the kernel-firmware-20130714git version) there is a good chance their wireless should work in the 1st reboot after the kernel-firmware update.

So as a ‘confidence’ check, I was curious if any of our openSUSE forum membership have any tidbits/advice ?

I am not sure if these link will be of any use to you.

iwlwifi - Linux Wireless

Intel 7260 Firmware not loaded |

Thanks … at this stage, where I am collecting information prior to doing a test, its hard for me to say what may be of interest. I did note the following additional links:

  • Ubuntu thread with Intel 7260 information, starting in post#7 in that Ubuntu thread (where it references a June firmware patch for the kernel-firmware update) that may be in the end-July openSUSE firmware update. The Ubuntu user notes the wireless works for them after their updates (but they do not give the version of their updated kernel
  • this blog of a Fedora-19 user who noted it did not work with Fedora kernel (3.9.8) , but then after some testing installed the 3.10.0-0.rc7 kernel build, patched it and tested it and it worked for them. openSUSE-12.3 has a 3.7.10-1.16 kernel, so that suggests to me that the users who claim a 3.7.11 RC kernel is necessary are referring to kernels that have not been back patched. I suspect the recent openSUSE-12.3 kernels may have been back patched (as I note the firmware is included in the latest 12.3 kernel-firmware).

I was curious if any of our openSUSE membership have already tackled this ?

What I may do, is pass to my colleague a USB stick with openSUSE-13.1 M4 in a liveUSB boot (with its 3.11 RC6 ?? ) , and get them to see if they can boot to that USB stick and have their wireless work. That would be in addition to trying a regular openSUSE-12.3 liveUSB boot (with the 3.7.10-1.16 kernel) .

If you build a live cd image on SUSE Studio, it will add all the updates to your image…

Thanks for the suggestion. I confess I’ve never tried to use SUSE Studio. I can see it taking time to learn that. … It is something I would like to learn some day, … I’m not sure thou if this is that day.

I guess it might be worth while trading off => the effort of doing a SUSE Studio liveCD build and installing only once ? vs the effort of installing openSUSE-13.1 twice.

ie install 13.1 once as M4 and then again install the GM of 13.1 when it comes out in mid-Nov.

Its also easy to test 13.1 M4 with existing live KDE .iso files (installed on a USB stick)

I note for M4 quality:

Whether that is stable enough for a new user to play with for 2.5 months until 13.1 GM comes out, is not something I know. I do note that the Sony Vaio Pro-13 ultrabook has an SSD drive and USB_3.0 ports. My experience on my Toshiba Ultrabook is the software copy part of a fresh openSUSE-12.3 install with USB-3 (USB stick & USB port) and SSD drive took only 4.5 minutes ! So if the 13.1 M4 liveUSB stick boots and the wireless works, I may suggest they consider installing 13.1 M4 on an interim basis until the GM came out, and then do a re-install 3 months later. As long as one does not have too many custom apps, a re-install should be quick.

We tested openSUSE-13.1 M4 liveUSB boot on the Ultrabook , but turns out 13.1 M4 had a 3.10.x kernel. The Intel-7260 wireless did not work. I’m hoping today (or in the next few days) openSUSE-13.1 beta1 when made available for downloading, will have a 3.11 kernel (with a .iso of a liveDVD available for downloading). The plan is to download that, create a liveUSB of 13.1 beta1 and test that with this Intel 7260. My research (for example on this Intel thread: … has suggested the Intel 7260 wireless should work with the 3.11 kernel.

Would be my advice too.
@Lee: Studio is not difficult, IMHO there’s no steep learning curve, if you want some guidance there … I use Studio quite a lot (f.e. to produce installable images where Packman and latest KDE are already included). The fact that no massive update is needed after install saves a lot of time in my case.

I burned openSUSE-13.1 RC2 KDE .iso file to a USB-3.0 stick for my colleague and then with that 13.1 RC2 USB stick booted their Sony Pro (which has a Intel-7260 wireless device) They were able to boot 13.1 RC2 with that USB stick ok (so the 13.1 RC2 UEFI/EFI fix boot booting worked for them). Also important, 13.1 RC2 has the 3.11.6-3-desktop kernel packaged by SuSE-GmbH and it works ok with the Intel-7260 wireless which is the subject of this thread. :slight_smile:

So this is good news. My colleague (with my advice) now needs to decide if we install 13.1 RC2 and update later to 13.1 GM (via zypper) or wait for the GM version. I’ve never updated from a RC version to a GM version via Zypper, so if we take that approach (with my colleagues PC) it will be a first for me.

With 13.1 you don’t have to do anything special in that case.
The repo URLs won’t change anymore, the new packages are just copied into the repo.
So you should get updated to GM automatically, either by “zypper up” or by your desktop’s update applet.

But 13.1 GM is in less than a week anyway (Nov. 8th).