Any openSUSE-11.1 Gnome users using wireless?

Are there any openSUSE-11.1 Gnome users using wireless?

My wife suggested giving our rather old Fujitsu-Siemens Amilo 7400M laptop to my mother, as that old laptop is actually newer than my mother’s ancient Dell Dimension 2100 desktop. My mother has moved to a small apartment, and a laptop may be more convenient to her. The complication here is that Fujitsu-Siemens Amilo 7400M laptop uses the Intel i855GM graphics which stopped working for the Intel driver on that laptop for every kernel after the 2.6.27 kernel.

Hence I will only put openSUSE-11.1 on that laptop. Currently its running KDE-4.4.4 on openSUSE-11.1 which works great for my wife and I, but for EVERY POWER ON, to get the Intel Pro 2100 wireless to work, we always need to go to YaST > Network Devices > Network Settings and navigate a few more menus to get the laptop to connect to our home LAN (WPA encryption, SSID is not hidden). Going to YaST each boot is ok for my wife and I but it won’t work for my 84 year old mother (to connect to her wireless). (Note also knetworkmanager under KDE-4.4.4 does not work properly with the kernel in 11.1 - my understanding is this was fixed in later kernels, BUT unfortunately those later kernels are not compatible with the Intel graphic driver for i855GM graphics).

Hence for my mother to use this laptop, I see the options are to either:
(1) stay with KDE4 and tell my mother to ONLY use the wired connection on the laptop, or
(2) stay with KDE4 and find some way to automate upon boot a connection to the last configured WLAN (which I don’t know how to do/setup), or
(3) install a Gnome desktop that works easier in setting up wireless (if it works easier than YaST) each boot to Gnome.

I note Gnome in openSUSE-11.2 was superior (over KDE4) for connecting to a WLAN, in that it was very easy and intuitive. But I do NOT recall how Gnome functioned in openSUSE-11.1.

So my question is, how easy/friendly was Gnome-2.24.1 in openSUSE-11.1 for connecting to a WLAN? I don’t want to go through the effort to replace openSUSE-11.1 with its nicely functioning KDE-4.4.4 (for everything BUT wireless) with Gnome-2.24.1 only to find its wireless connectivity friendliness is no better (no more user friendly) than that of KDE.

**Are there any openSUSE-11.1 user views here wrt the wireless on this older Gnome version ? **
(please - no KDE vs Gnome desktop comments OTHER than wireless, and please no openSUSE-11.2 nor 11.3 update recommendations as they don’t work (with Intel graphic driver) on this laptop)

Edit: … hmmm … I may just download an openSUSE-11.1 Gnome LiveCD and give it a try from the liveCD.

OK, so I downloaded and burned to a CD the 32-bit openSUSE-11.1 Gnome iso file, creating a liveCD. I then booted our Fujitsu-Siemens Amilo 7400M laptop to this Gnome liveCD. It came up nicely with the Intel driver, and wireless was a BREEZE to connect. Indeed in openSUSE-11.1, Gnome is significantly easier than KDE to connect via wireless. My 84-year old mother will not have any trouble with the wireless in Gnome. Its very intuitive.

BUT the sound setup in 11.1 Gnome is bad. I got it working, but the volume levels were about 1/2 of what I can get with KDE. I messed around for 15 minutes, but since I’m not familiar with Pulse Audio I did not get far. The pulse audio volume control app refused to run (kept crashing) and I suspect that may have been a bug that was fixed. … Frankly, the audio set (with Pulse) is SO bad in Gnome, I am still in a quandary wrt this laptop. I don’t want to thrust a laptop with Gnome on my mother with such a horrible audio setup. … (I note audio works GREAT with KDE).

Which leads me to ask a question (and I think I need to start a new thread), if I know the SSID and Password, can I simply have a script run upon boot (preferably before run level 3 is complete and before run level 5) that would automatically connect to the specific SSID, assigning the password?

If so I could use KDE. I simply want to create an easy way for my mother to connect to to ONLY her SSID.

I also had problems; I have a Ralink RT2501USB Wireless adapter which apparently only works with rt73usb driver. But, I did not have it, nor was I able to install it. So, eventually I upgraded tot openSUSE 11.3 (Gnome) (where this driver is included in the package) but now my printer does not work. There are a lot of posts about this rt73 driver. Could this be the problem ?


… ok … but by the appearance of it in 11.1 your problem was not the KDE nor Gnome desktop per-se, but rather was the driver functionality.

In 11.1 KDE the problem is the knetworkmanager does not work well. So even IF one has the correct driver, openSUSE-11.1 KDE was NOT user friendly for setting up the WLAN. However on the other hand, if one has the correct driver, Gnome’s network manager in 11.1 Gnome does well and the WLAN network setup is easy.

I think it unlikely. I recommend you post this problem on a separate thread.

i have a Dell Inspiron 8100 running opensuse 11.1

i have it setup with kde 3.5 (i don’t really want to move to kde 4 yet specially since this laptop is old). I bought a Cisco AIR-CB21AG-A-K9 adapter on ebay for $20 new. the adapter works out of the box using the ath5k driver. i’m also running the gnome-network manager (nm-applet) that gets installed by default. i can simply set up all my connections and then just connect to whichever network by just clicking it without having to do anything within yast. if your adapter does not work effectively, then you can try this setup. it works to the point where i can use aircrack-ng effectively.


Thanks for the suggestion. I’ll keep that in mind if I run into trouble with this Fujitisu Siemens Intel 2100 PRO wireless (but thus far it works well).

So I bit the bullet and installed Gnome on this laptop. I immediately installed all of the pulse audio updates (for 11.1) and as near as I can determine that has cured the significant audio problems I observed with Gnome on the openSUSE-11.1 liveCD (which wasn’t pretty). But now its good !! Or saying it differently, at this point in time on openSUSE-11.1, it appears that audio is working ok in Gnome.

Maybe I’ll come to revise my negative opinion of Gnome and sound.

So I now have the Fujitsu-Siemens Amilo 7400M laptop’s Intel Corporation PRO/Wireless LAN 2100 [8086:1043] working with openSUSE-11.1 Gnome. I’m trying to set this up for my 84-year old mother. It is important that everything ‘just work’.

When I switch on the laptop, I get prompted twice for a password … the first time for the wireless LAN password (see jpg below):](

and the second time for a keyring password that I do NOT want to use (see jpg below):](

Please, can any one suggest how I can:

    1. have the 1st dialog box wireless password stored WITHOUT using keyring ?
    1. disable the 2nd dialog box to use keyring from appearing.
      Or is using keyring the only way in which for me to proceed ? (I confess I have no clue on this).

My 84-year old mother will likely never use this laptop out side of her apartment. So I prefer to have her wireless automatically log on to her wlan as soon as she switches on the laptop. Having it automatically connect to her wlan also makes it easier for me when I am maintaining her laptop remotely, and I need to reboot it after a kernel or xorg or other update (and hence want the wireless to automatically connect).

Do our resident gnome-wireless users have some advice?

Thx in advance.

If you simply enter no passwords for the keyring it will tell you with a warning that it will store the passwords in a less secure way as encrypted files (and I guess that is what you want). At least it worked that way for me on my laptop with gnome before I switched back to kde. Gnome NM then connected automatically to the network without prompting me again for something after every login.

Saw this working exactly this way this afternoon. Enter no passwords, and keyring will not be used. Some apps do ask for a password a second time, or ask if you want to store the password in the config file.

Knurpht wrote:

> Saw this working exactly this way this afternoon. Enter no passwords,
> and keyring will not be used. Some apps do ask for a password a second
> time, or ask if you want to store the password in the config file.
I just want to add some info which might help if someone is in trouble because she/he entered
something and later forgot it. It is very easy to reset keyring to its original state if
something went wrong by deleting the right files in ~/.gnome2/keyrings

Of course all stored passwords are then lost and asked again.

openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce 9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX 3600M | 4GB Ram