any madwifi drivers included with 11.0

after i installed 10.3 gnome, my Netgear WG511T 108Mbps Cardbus adapter, Atheros AR5212 802.11abg, pciid: 168c:0013 did not find have any madwifi drivers to connect to the internet. with 10.3 there werent any madwifi drivers installed from the 10.3 installation… i had to install madwifi drivers myself so i could connect to the internet.
will i have to do the same thing with opensuse 11.0???
are any madwifi drivers included in the 11.0 installation??

you’ll have to download them, or, if you also have a wired connection,just add the repo & install with YaST


last time with opensuse 10.3 i installed madwifi drivers - & madwifi-kmp-default-0…9.3.3_2.6.22.16_0.2-0.1.i586 rpm’s… this time with a clean installation of opensuse 11 now i see in the network setup, hardware tab under module name i see ‘ath5k’. does that mean i need an ath5k driver or does it mean thats what installed with opensuse 11??? kernel on 11.0 is
i have ar5212/ar5213 netgear cardbus wg511t
oh yeah where is the network manager next to the clock? i dont see one to use to connect to the internet. i had one on 10.3… how can i add one next to the clock
so what madwifi drivers do i need??

sorry ! kernel on 11.0 is
is kernel on 11.0 is

Added madwifi-0.9.4-1.i586.rpm & madwifi-kmp-pae-0.9.4_2.6.25.5_2-1.i586.rpm with yast install software and they installed, but when i type in a terminal su to root modprobe ath_pci, i get
linux-html:/home/os # modprobe ath_pci
linux-html:/home/os #

i typed lsmod and ath_pci is in list
still only one light lit up… how come other light in network card doesnt go on, is it a different command i need to type???

that looks ok, you won’t get any visual response when modprobing unless there’s an error. have you set it up in YaST now ? as for network manager applet, you may have to start it maually then configure it to start. go to SuSEmenu - ssytem - dektop applet & start it from there


i had to reboot for both netgear cardbus card lights to start blinking. i thought in a linux system you didnt have to reboot for drivers and programs to work like in windows

well i did a fresh install of opensuse 11 and it detected my wireless card out of the box as “ath5k”, didnt installed any madwifi driver or anything… i guess you dont have to install anything… i havent… and my wireless works fine

nope you don’t necessarily need to reboot. but, sometimes a recalcitrant module will need a re-boot.


yes, i saw the ath5k in the module name under network devices but only one light was on, on my card. both didnt light up so i dont know what when wrong ??? now i have two options in module name ath_pci and ath5k, if i choose ath5k only one light works on netgear card

And you don’t have to.
Maybe there was some conflict with modules or networkmanager, and rebooting might have been a faster way to fix it rather than searching how to do it. :slight_smile:

Hello, Diablo1. I have a Netgear WG311t and was in the same boat untill I saw this lovely thread specially this post and this one

Have a browse. There is a good way to get it all working that got me going wirelessly. I also have a post in there on how to enable WPAsince this was not working for some strange reason.

I do not know if the repos will work (they should) since I have not tested them. I have done a update through them which worked fine.

Hope this helps and good luck!

how do i get ath5k working? i seem only to get one light blinking on my netgear card with ath5k… i have no problem getting the madwifi drivers madwifi-0.9.4-1.i586.rpm & madwifi-kmp-pae-0.9.4_2.6.25.5_2-1.i586.rpm installed and running but want the newer ath5k working… i checked on madwifi website and my ar5212 should work with ath5k…

in opensuse 11.0 do i still have to Blacklist the ath5k module if in the network card setup under the hardware tab i pick ath_pci from the drop down menu instead of ath5k

Try uninstalling madwifi fully, blacklist ath_pci, and select Ath5k in the hardware network settings in Yast. Haven’t tried this myself to be honest so if it’s wrong advice anyone can correct me :wink:

by uninstalling madwifi, do i just delete madwifi from the yasts software management then hit accept ?

are the commands to disable and enable both ath_pci and ath5k these: to enable MadWifi at a later time and disable ath5k you can
su to root command: athload madwifi

To revert back to ath5k you can run
su: athload ath5k

i deleted my madwifi drivers that i installed from yast then hit accept…

then in su to root i typed echo “blacklist ath_pci” >> /etc/modprobe.d/blacklist
checked blacklist and blacklist ath_pci was at bottom of blacklist file

then checked ath5k was in module name and it was.

but only one solid light on my netgear card, the second is dark…

what did i miss if anything?