Any hope for Realtek 8811CU wireless LAN 802.11ac USB NIC working

I see several threads mentioning other Realtek USB dongles but not the >Realtek 8811CU wireless LAN 802.11ac USB NIC

Any hope at all of it being able to be setup in Leap15 and Leap 15.1 when It is released?

AFAIK, user Sauerland’s 8812AU driver should work with that device…

Can you post the 8811cu output from the command;


Need the usb id’s to confirm the driver is compatible.

Output for lsusb Realtek usb device in BOLD.

]bill@linux-ipxi:~> lsusb 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 005 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 001 Device 004: ID 03f0:bf2a Hewlett-Packard  
**Bus 001 Device 005: ID 0bda:c811 Realtek Semiconductor Corp.  **
Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 003 Device 002: ID 413c:2105 Dell Computer Corp. Model L100 Keyboard 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Output for usb-devices (Realtek information)

**T:  Bus=01 Lev=01 Prnt=01 Port=02 Cnt=02 Dev#=  5 Spd=480 MxCh= 0 
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1 
P:  Vendor=0bda ProdID=c811 Rev=02.00 
S:  Manufacturer=Realtek 
S:  Product=802.11ac NIC 
S:  SerialNumber=123456 
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA 
I:  If#= 0 Alt= 0 #EPs= 5 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none) **

Looks like one user got it to work…

Probably easier to go find one that has OTB support…

I think you are right. I have been looking for a different one that has OTB support.
I don’t think she will be happy with one that has an antenna on it as she moves the PC quite a bit during the day.

So far my wife’s laptop is doing her well with just onboard 2.4G. I will ask her if she want is ‘faster’ or if she is satisfied with it as it is.

Thanks for the link. I believe I did run across that one in my search travels and put link to it somewhere.
So thanks to you I have it again IF I want to tackle another problem child.

PS, Global Mods Attention!!
Someone really needs to fix that ‘reputation’ thing so that we can add to a members reputation more than once or twice! Just saying…

I downloaded that zip file in malcolmlewis’s post above, unzipped it and turned the results into a .tar.gz file.
I have made an attempt to do .rpm from it, but am kind of leary of pulling the trigger to complete the rpm.

I would rather pour acid in my eyes than look at yet another long and confusing ‘how to make an rpm’ web site, or watch another 30 minute boring video.

NOT that they haven’t been instructive, they have, but… the boring factor is putting me to sleep! End of whine!

I found this
And installed it via ‘dkms’. My understanding is it should be added to a kernel update(??).

It is the driver for my USB WiFi dongle, and it is now recognized by Network Manager.

First I tried the Realtek driver(rtl8821AU) from the YaSt repository, but could never get it to work.

I did not follow the instructions, opting for the downloaded zip file.
Getting the archive with ‘wget’ did not get an extractable structure so I winged it.

I am not sure it it is faster on our system, but time will tell.

There are two links on github for this WiFi dongle driver.

The second link is a later Realtek driver.
The first link is a driver from the CD that came with the dongle.
It’s all in the descriptions at the top of the pages.

Tried to install it on my wife’s laptop, and it errored out. Was about an hour trying to find out why.
It was a missing ‘bc’ sh command! I’dve thought that would have been installed when dkms and all of it’s dependencies was put in.
Oh well, what ever, it is now in her machine and working.

Since the YaSt version of rtl8821AU didn’t work out, I didn’t try one of user Sauerland’s version of 8812AU.

‘lsusb’ command always found the Realtek WiFi dongle, so all I had to do was run ‘

modprobe 8821cu

to get the dongle actually working.

Just for Clarification:
This ID is not in the rtl8812AU_8821AU build by me:

modprobe -c | grep -i "0bda.*c811"

You can try this Repo after a fresh Installation without Updates:
or this for an updated openSUSE Leap 15.1:
This last Repo will automatically get the newest kernel-module-packages, if Leap 15.1 will get a newer kernel version.

Name of the package is:

Source of the package is from

/sbin/modprobe -c | grep -i "0bda.*c811"                                                                                                                                                
alias usb:v0BDApC811d*dc*dsc*dp*icFFiscFFipFFin* 8821cu

OK, thanks! The ‘dkms’ install from didn’t update with latest kernel like I though it would.
I downloaded the 2nd repo from your post above and installed it, and it got the dongle back up and working.

Honestly, I don’t remember seeing the ‘8821cu’ in your OBS when I was going through it. But I now know it is there IF needed for future kernel updates.

Again, Thanks!

Now I need to get your repo in YaSt to assure updates will be included.

You can enable the second link as Repo to get on kernel updates the new build package…

Also if the source are changed, I build it new.