Any chance to have Atom on openSUSE repos?

Hi, I’m currently using Atom text editor, pretty sure that somebody here already heard about it, it is developed by the guys at GitHub:

I downloaded the rpm from their website since it is not available on openSUSE repos, but this way is not the best one, since I have to manually check for updates every time.

Is there any chance to see it on our repos too? And, as a bonus, is there a way to propose new software for openSUSE (maybe with the ability to upvote proposals like openFATE but just for new software), instead of posting here on the forums?

Last I checked (awhile ago),
Atom was also deployed online, so you open in a browser with full functionality and never have to install.

Atom is actually the editor often embedded in other apps (and IDEs).

Atom by itself is a good foundation with long history, with basic functionality, which is why other development apps build on top of it.


Thank you for your feedback.

I’ve never heard about the webapp version of atom, I’ll try to find out more, even if I prefer to have a local version to work with (same thing as Gravit Designer).

It is indeed a good app, and pretty usable by itself even without being embedded in other apps. It is a full fledged editor that supports many coding features and extensible with plugins, basically you can say that it is a free alternative to Sublime Text.

I asked because I was thinking that is was a popular choice and I thought it could be useful to have it in our repo.

Looked at this again.
Atom has been around for a long time, and has undergone a few complete re-builds from the ground up.

Seems the current version doesn’t have a pure webapp implementation,
But you can install it by way of almost every major coding language… I see there are at least python and nodejs packages and I’d imagine there should be in all other major languages as well.


It supports all the major and most used languages, and it is built as a framework that can be extended with many plugins; even the core package, AFAIK, is made of basically several bundled and required plugins.

I’m using it for web development related languages, it has many features that unfortunately I could not find on Kate (I use Plasma and usually tend to prefer KDE apps).

The installation in itself was not a problem, it is built by GitHub itself and they provide a rpm too. But having it on the repo would mean having a more streamlined installation/update/maintenance process, instead of having to download the rpm from their site every time.

I once tried to figure out how to import GitHub projects into our OBS repositories, but it was beyond my level of expertise, I ended in losing too much time without a result.

I think it’s bad that one of the best editors around can’t be properly installed on openSUSE. The RPM on the Atom site works perfectly on Fedora, but is not fully compatible with the openSUSE RPM format. Alas. I need this editor since it supports markdown very well. It’s one of the reasons I can’t run openSUSE and run Fedora instead.

Just tested: rpm install works fine apart from the fact the the repo sig is missing from the package ( and this makes sense since it’s not signed by openSUSE ). After this atom runs fine here.
But … this is not much different from the webapp. It’s built on Electron, which actually sort of renders de webapp locally.

Following the instructions on the following page on the recommended way to install Atom editor on openSUSE (not configuring the repo, just downloading the RPM and installing), it appears to have been installed and initially appears to be working (didn’t explore all features).

I used the following command to download the RPM



/usr/share/atom/atom: error while loading shared libraries: cannot open shared object file: No such file or directory
So, at my workstation, Atom does not start after installing the RPM. What can I do about this issue?

zypper in ./DOWNLOADED_RPM

should work fine

Unless something else was used to update TW then the documented ‘zypper dup’. The missing library ( and it’s versioning ) are present on both my TW and Leap. So, Atom is not the issue, your install is.

It did work. Formally I tried to install it by using “rpm -i”
However, I reinstalled my image, because there were a lot of dependencies installed that I’d rather not have, like a lot of kde4 stuff.
For now I’m using Kate. It also does a good job. For MarkDown I use the Typora source. It also works great!
Still, for programmers, it would be a good thing to include Atom in the repos imho.
Thanks for the help.