Another wine doesnt install thread

Hello all. Firstly, I’m quite new to linux, so this is probably a PEBUAC issue. I’m trying to install Wine so that I can run Maple software (mainly because I’m used to it and don’t really want to learn sage or octave right now).

I’ve added to my repositories

When I run (as su)

zypper in wine

I get the following issue:

Problem: nothing provides needed by wine-1.7.13-331.1.x86_64
 Solution 1: do not install wine-1.7.13-331.1.x86_64
 Solution 2: break wine-1.7.13-331.1.x86_64 by ignoring some of its dependencies

Granted I probably need to acquire, but I’m worried installing it separately may cause issues.

Typically, if an install is complaining that a dependency file is then it’s no big deal to install it from whatever source you might find. Any existing processes on your system didn’t use it in the past and won’t likely in the future (avoiding the Linux version of DLL Hell).

So, now on to where you can find this file?

  • You can search in YAST2, just enter the file name and by default possibilities will be returned. Depending on your Desktop you may have checkboxes on the left that can modify your search.
  • You can search by commandline using zypper with the “wp” command (what provides?). wp may not work much longer (being deprecated) in favor of a modified search but for now it works. This will search the same repos as YAST, so generally do only YAST or zypper, repeating with the other isn’t likely to return anything different.
zypper wp
  • You can search at
  • You can do a general Internet search. There are large 3rd party listing like rpmbone and rpmfind that point to the file from not only openSUSE but other distros. Sometimes you can simply use an RPM from another distro like Fedora or Mandriva, YMMV.


Ok thank you, I’ll give that a try!

You need the correct “flavor” of wine either 32 or 64 bit to run windows software. I looked on the Maple website, and it appears they have linux compatible packages. So you might not need to load wine, you might just need to get Maple in a linux package.