Another USB question

Just new to openSUSE and just installed 11. I’m trying to automount my USB drive. I just move from Debian and it worked there.

With “fisk -l” I get:

Disk /dev/sda: 120.0 GB, 120060444672 bytes
255 heads, 63 sectors/track, 14596 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x90909090

Device Boot Start End Blocks Id System
/dev/sda1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 * 263 2873 20972857+ 83 Linux
/dev/sda3 2874 14596 94164997+ 83 Linux
Note: sector size is 2048 (not 512)

Disk /dev/sdf: 522 MB, 522321920 bytes
8 heads, 40 sectors/track, 797 cylinders
Units = cylinders of 320 * 2048 = 655360 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdf1 * 1 797 510000 b W95 FAT32

However, when I try to mount the device I get:

Can not mount volume
The volume uses the vfat file system which is not supported by your system.

Please help…

give the output of the following

grep ‘VFAT’ /boot/config-uname -r

ls /lib/modules/uname -r/kernel/fs/vfat

lsmod | grep vfat -

grep ‘VFAT’ /boot/config-

ls /lib/modules/

lsmod | grep vfat -
I get nothing ?? (did I enter it correctly?)


lsmod | grep vfat

(copy paste error)

lsmod | grep vfat
I still get nothing (return to prompt, no reply)

Was this with the usb drive connected?

No it wasn’t, but I just repeated with the usb drive in place and got same results.

reboot, leave the usb connected,- have you tried that

the info you gave shows the vfat module in the kernel

grep ‘VFAT’ /boot/config-

ls /lib/modules/

Unless anyone else has a suggestion. It should just plug and play


While I was waiting for your reply, I did try to reboot with the flash drive in place. It didn’t go well; box tried to boot from the flash drive. I removed it, rebooted again, and now everything seems to work. The drive mounted and I can see all of the contents.

Come to think of it, I received a large amount of updates and I don’t know if I had rebooted since then. Maybe something in them??

It must be getting late to think straight. I’ll try tomorrow and hopefully it will still be working.

Thanks for your help!!

A kernel update will give you the behaviour you observed.