ANOTHER thread on Splashy


There seems to be many threads on this - perhaps that should say something about how easy it is to use (or not)?

Anyway, having read the other threads, none of them get close to the problem I’m having. I’ve created a new theme, and it works when I do splashy test but it doesn’t activate on boot or shutdown.

I have tried mkinitrd, edited my LILO file, &c. - but to no proper solution.

Reading the man page on splashy it says

“/sbin/splashy boot”

   Used when booting your system. This is run automatically by a initrc script during boot.

   "/sbin/splashy shutdown"

   Similar in spirit to boot, but run during shutdown. This is run
   automatically by a initrc script during shutdown.

My question is: which scripts would these commands go in?

This is the contents of my lilo.conf file:

# Modified by YaST2. Last modification on Thu Jan 15 07:49:51 GMT 2009
menu-scheme = Wb:kw:Wb:Wb
timeout = 50
default = openSUSE
message = /boot/message
boot = /dev/disk/by-id/scsi-SATA_ST9408114A_3LE20Y00-part2

image = /boot/vmlinuz
###Don't change this comment - YaST2 identifier: Original name: linux###
    label = openSUSE
    append = "quiet resume=/dev/sda1 splash=silent showopts nohz=off clocksource=acpi_pm"
    vga = 0x317
    initrd = /boot/initrd
    root = /dev/disk/by-id/scsi-SATA_ST9408114A_3LE20Y00-part2


I actually solved this by removing Splashy and moving over to bootsplash+gfxboot] instead, which was actually a lot easier to configure.

But seriously, there are six threads on not being able to get Splashy to work. Can nothing be done to make this easier?