another suspend story...plz read!

so all that was needed a fresh install?

in my case - yes, it all it took :stuck_out_tongue:

i was too quick to feast. i mean suspend works superbly i’m happy, but…(there is always but isn’t it?..) wireless network connection won’t reconnect :(.
me very sad :frowning: very very sad…so close to real happiness…so close.

gnome or kde? is your card supported by madwifi or ndiswrapper?

KDE 3.5.9, and i guess it is supported or else it wouldn’t connect in the first place, isn’t it?

yeah it is supported no doubt, but which wireless card do u have?

hi snakeeyes,
my wifi card is:
Intel® PRO/Wireless 3945

Hi, I think this wireless card is supported by default without madwifi right?

Is this the driver module for your card? “ipw3945”, can someone confirm this?

following driver is installed on my system: iwl3945-ucode
there is driver ipw-firmware which is not installed.

Try this, start a text editor like “kwrite” as root and type in this


Save this file in /etc/pm/config.d and give it the file name “config”

What this does is tells the system to unload this module before suspend.

Once u save this file restart the machine and try suspend to ram now.

you evil genius :smiley: !!! IT WORKED!!!
please do tell me some more about background working of this simple one-liner. i really want to understand. or at least point me to the direction where i can find more information about this.
how did you come to this solution?
tell, tell please do tell…

nice to hear it worked :smiley:

I have been learing about power management tricks since I started with linux, but from your descripton the problem sounded like only that module was causing problems so it had to be unloaded first.

You can read about suse power management here:

Pm-utils - openSUSE

Suspend to RAM - openSUSE

Suspend to disk - openSUSE

Enjoy reading :wink:

hi snakeeyes :(,

i was once again to quick to cheer. i’m emotional i guess.
reconnection to wireless proved to be inconsistent. sometimes it seems to connect (connection bars showing up)but i can’t ping anything. and if i suspend with internet browser (opera) opened then it not even trying to reconnect (but this is very minor issue for me in this case).
i guess, if you are not tired, we have to dig deeper. i really want to get to bottom of this.

the problem seems to be that the wireless module isn’t reloaded after suspend, u could reload it manually for now though.

Alright then, lets try this, delete the file named config which u made last time.

Now go here:


Open a file called “50modules” as root with “kwrite” or “gedit”

Now in this line:


make it this


and this line


make it this


save and reboot and try suspend to ram now, I hope it works this time

hi snakeeyes,

still no go…:frowning:

i don’t know what to do…am i exaggerating necessity having suspend working? am i only one who doesn’t like to turn laptop off unless i’m going to sleep?..

ok…update to this story…

reconnect it does now…yey!!!but it takes two minutes till network manager start to reconnect. right after suspend i go to terminal to see whats going on:
top gives me average load 22. i’m guessing here - network manager has to wait for all other processes.
any ideas?..snakeeyes?

Hi, sorry for the late reply, can’t get online much today. As for this glad its starting to work but have u tried for now like disabling it in network manager and then re enabling it manually or shutting down network manager and restarting it. I think it could cause its reloading this module last but I will check just to be sure.