another suspend story...plz read!


as far as i have understood key to successful suspend to ram story is: powermanager, kernel and bios. just right combination of these three elements will give you full joy of laptop usefulness.
is this true?..if it is why tha F*** suspend works under ubuntu 8.04 and not under suse 11???
really…please someone explane me…i’m about through this laptop up against the wall…i’m no joking…

it’s whitelisted in s2ram and it’s still don work…

Hello !
What’s the brand and model of computer? What video card ?

Have you read this: S2ram - openSUSE, and tried a few parameter? What parameter did you use under ubuntu ? (under /etc/acpi-support/suspend (or "sleep).


Exactly try different parameters in the s2ram page and it will work and it will be very reliable.

i’ve read that page thoroughly before, and followed every step on it. still no go.
this is s2ram output:

Machine matched entry 559:
    sys_vendor   = 'TOSHIBA'
    sys_product  = 'Satellite A100'
    sys_version  = ''
    bios_version = ''
Fixes: 0x3  S3_BIOS S3_MODE 
This machine can be identified by:
    sys_vendor   = "TOSHIBA"
    sys_product  = "Satellite A100"
    sys_version  = "PSAA9E-0QG049DU"
    bios_version = "6.00   "
See for details.

video card is NVIDIA 7600 Go.

What parameter did you use under ubuntu ? (under /etc/acpi-support/suspend (or "sleep).

i have no idea, i just set it in powermanager to suspend to ram when lid is closed and that’s it. closed my lid, it went to sleep and when i opened it i continued my work.
in suse case it goes to sleep, but never wakes up (keyboard is dead).

Ubuntu doesn’t use software suspend like suse does I think, it has some own kernel suspend, u r lucky that yours works in ubuntu, I have never had mine work on any debian system.

Anyway can u tell us what parameters u have tried and sometimes some modules such as wireless card may interfere, r u using the same driver on ubuntu and suse, just give us as much detail as possible.

oh yeah with the video card, have u tried adding

Option “NvAGP” “1”

in the device section of xorg.conf

this is my xorg device section:

Section "Device"
  BoardName    "GeForce Go 7600"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"

where do i put option you talked of.

and about wifi drivers i assume there only one linux drivers for intel wifi modules so i guess drivers can’t be the reason. and i can’t go back and check it anyway, my laptop is suse only. before RC1 i had ubuntu, but when RC1 came out i came back to my fav distro.

and about parameters - just about all of them from s2ram suse page.

Alright then put it like this

Section “Device”
BoardName “GeForce Go 7600”
BusID “1:0:0”
Driver “nvidia”
Identifier “Device[0]”
Screen 0
VendorName “NVidia”
Option “NvAGP” “1”

still not working :confused: :frowning:

post out put of dmesg, u don’t have any built in intel vga card as well right?

i want to put here read out of my dmesg but is so big it gonna take up whole forum i think :o
is ther any way to attach here text file?

there should be a manage attachments link but if not just copy and paste and also make a bug report to that u can’t s2ram so they can fix it

i have already emailed s2ram developers. but i guess making bug report would get quicker response.
and i’m sorry but i think it not possible to attach files here, and i can’t just copy/paste it - this text spreads on 43 pages - it’s just antisocial to do so.
i will try to submit the bug and upload this file on bugzilla, then i post a link to that so you could take a look at it.

ok then I will see the report :slight_smile:

as i have prommised:

one more thing can u describe what really happens when u try to s2ram for example does the system go off, what happens when u turn it on, etc and u did do this a root user right, add this to your bug report.

I think its your specific laptop though

Hello !
Could also give the output of


attached to bug 402574

see the bug report


I suffer from the same problem like kartveli. I own Toshiba A200 model and the simptoms are the same as kartveli described. It goes in suspend normally, but on wake up computer hangs. I tried all combinations described on suse page.
The hard drive LED becomes active but the 5th LED(Multiple Digital Media Card Slot Access LED) never becoms active, normaly on resume this LED does become active.

I tried on openSuse 10.3 and 11.0(LIVE) and either case the problem is same. I also tried with Fedora Core 9 (LIVE) and suspend works superbly.

I hope this info is usefull…


for all interested:
bug is resolved. see please bug report.