Another sound thread. Audio/AC'97

Hello,

Ever since installing I have not had any audio output at all. Everything appeared to install fine, but no sounds were outputted. So, moronically, I decided to update my drivers etc. Now I don’t have a volume control on the appbar and YaST->Sound has an unconfigured device( edit->auto configure produces an error ).


lspci
00:1d.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host Controller


YaST->Sound->Edit->Auto

An error occured during the installation of

High Definition Audio/AC'97 Host Controller

The kernel module for snd-hda-intel for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

I’m aware that by trying to get audio working by myself I’ve actually made things a lot worse. Before the device was configured and I had the volume/mixer control on the appbar just no actual output. Now it seems far worse. At the time I had a “learn by doing” mindset :o.

Now, I’ve read a few threads here about sound and googled etc. I installed the alsa firmware and I’ve been through the “SDB Audio Troubleshooting” docs. I will try to provide everything that other people were asked for.

talsa : tsalsa.txt - nopaste.com (beta)
rpm -qa | grep alsa : nopaste.com (beta)
rpm -qa | grep pulse: nopaste.com (beta)
rpm -q libasound2: nopaste.com (beta)
uname -a: nopaste.com (beta)
cat /etc/modprobe.d/sound: nopaste.com (beta)
dmesg: nopaste.com (beta)

Thanks.

Glad to see you tried, but it looks to me like you did not follow the Troubleshooting guide exactly, but rather you decided to innovate.

Your /etc/modprobe.d/sound file is not the standard alsaconf nor yast created file. The entries in that file are causing all sorts of errors in your dmesg. It looks like you attempted to update your alsa to 1.0.17, but you failed mostly. … How did you try to do this attempt? By custom compile?

In particular, with an incomplete alsa update attempt (I think) then, if so, it looks to me like you are missing alsa-driver-kmp-pae

Anyway, I recommend you:

(1) rename your /etc/modprobe.d/sound file to somethingelse.

(2) update your alsa (again) by copying and pasting the following 6 zypper commands into a gnome-terminal/konsole one line at a time, and execute them one at a time in sequence:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia 
zypper install alsa alsa-devel alsa-utils alsa-tools alsa-tools-devel alsa-tools-gui alsa-plugins-maemo alsa-docs alsa-oss alsa-plugins alsa-plugins-pulse alsa-plugins-samplerate alsa-plugins-jack alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Between you and me, you installed WAY TOO MANY alsa apps. In linux, installing more is often NOT the best solution. I don’t even know what 1/2 of those alsa apps are, nor do. … Anyway, to be consistent, I suggested you try an update to all of them to the same consistent version.

(3) Then reboot. Then run alsaconf or YaST > Hardware > Sound (one or the other, but NOT both). Then run the tsalsa diagnostic script again, and also post here (again) your /etc/modprobe.d/sound file content.

Well, I tried to install/update a lot of different things. You can see in my download directory it’s an absolute mess.


geoff@esoteric:~/downs> ls
alsa-driver-1.0.17
alsa-driver-1.0.17.tar.bz2
alsa-driver-1.0.9rc4a
alsa-driver-1.0.9rc4a.tar.bz2
alsa-utils-1.0.17.git20080715-1.5.i586.rpm
code
common.zip
LinuxPkg_5.05.tar.bz2
netbeans-6.1-11.1.i586.rpm
netbeans-6.1-ml-cpp-linux.sh
netbeans-cpp-6.1-11.1.i586.rpm
netbeans-j2ee-6.1-11.1.i586.rpm
netbeans-java-6.1-11.1.i586.rpm
realtek-linux-audiopack-4.06a
realtek-linux-audiopack-4.06a.tar.bz2
realtek-linux-audiopack-5.01
realtek-linux-audiopack-5.01.tar.bz2
realtek-linux-audiopack-5.05
Release C++
Release C++.rar
ReleaseVB6.zip
ReleaseVBNET.zip
ReleaseVCsharp.zip
rtl8185_linux_26[1].1027.0823.2007.tar.gz
geoff@esoteric:~/downs> 

The last one I attempted was 1.0.17. It failed at make, I then ran make install followed by alsaconf( which failed on exit ).

Anyway, I ran through the steps you suggested. YaST->Hardware->Sound now has the card installed and configured. I get no output and no mixer/volume control on the appbar. I went in to the mixer in the YaST sound app and set both Master and Front to 75.

talsa: tsalsa.txt - nopaste.com (beta)

Current /etc/modprobe.d/sound:


alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-mpu401
alias sound-slot-0 snd-mpu401

Actually, scratch that. After posting I closed the YaPP sound app and it started my sound card. I’m now getting audio, but still no mixer/volume on the appbar. Thanks oldcpu, audio was the last bit of hardware I needed to get working :D.

fortuitous IMHO, as there is no need for a custom compile (yet). There are rpms as I pointed out.

I don’t think you did completely. You did not change your /etc/modprobe.d/sound file, as near as I can determine.

And it appears you did not update alsa-utils which was one of the alsa apps I recommend you update. I can’t tell what else you did not do. :mad:

Well this shows a major improvement. Your Asus P5RD1-V has an ALC880.

Great !! Thats progress. Its possible the mixer problem is related to the alsa-util version being wrong. alsamixer comes with alsa-utils. Why did you not update alsa-utils ?

I note in the ALSA-Configuration.txt file (which you must have seen as it came with the 1.0.17 tarball that you downloaded and tried to install) it says this about your ALC880:

	  Model name	Description
	  ----------    -----------
	ALC880
	  3stack	3-jack in back and a headphone out
	  3stack-digout	3-jack in back, a HP out and a SPDIF out
	  5stack	5-jack in back, 2-jack in front
	  5stack-digout	5-jack in back, 2-jack in front, a SPDIF out
	  6stack	6-jack in back, 2-jack in front
	  6stack-digout	6-jack with a SPDIF out
	  w810		3-jack
	  z71v		3-jack (HP shared SPDIF)
	  asus		3-jack (ASUS Mobo)
	  asus-w1v	ASUS W1V
	  asus-dig	ASUS with SPDIF out
	  asus-dig2	ASUS with SPDIF out (using GPIO2)
	  uniwill	3-jack
	  fujitsu	Fujitsu Laptops (Pi1536)
	  F1734		2-jack
	  lg		LG laptop (m1 express dual)
	  lg-lw		LG LW20/LW25 laptop
	  tcl		TCL S700
	  clevo		Clevo laptops (m520G, m665n)
	  medion	Medion Rim 2150
	  test		for testing/debugging purpose, almost all controls can be
			adjusted.  Appearing only when compiled with
			$CONFIG_SND_DEBUG=y
	  auto		auto-config reading BIOS (default) 

Hence you could try is backup your current /etc/modprobe.d/sound file and then edit it, changing it to something like:

alias snd-card-0 snd-mpu401
alias sound-slot-0 snd-mpu401
options snd-mpu401 model=auto

and restart alsa with rcalsasound restart and see if that improves things. If that is not successful, try in the place of “auto” one of the other above model codes. ie “asus”, or “asus-w1v” or “asus-dig” or “asus-dig2” or one of the many other model options, restarting alsa each time and testing your audio with each different /etc/modprobe.d/sound file.

Odd. I did a “rename /etc/modprobe.d/sound /etc/modprobe.d/sound.old” before running through the zypper lines. I’m not sure why the utils package was not installed. I just copied and executed each line in order.

It’s not too much of an issue, the lack of the appbar icon I mean, as I can get too the mixer through More Apps->Multimedia etc.

Hmm, if I do:


esoteric:/home/geoff # zypper install alsa-utils
Building repository 'multimedia' cache [done]
Reading installed packages...
'alsa-utils' is already installed.
Nothing to do.
esoteric:/home/geoff # 

Thats because the zypper commands I gave you deliberately removed the “multimedia” repository (with the “zypper rr URL”) after the update. This repository is updated every few days, and the rpms are very cutting edge and can break your sound. Hence if sound is working properly, the rpms should not be used. To get alsa-utils to install to a consistent version, try this ASAP (before it is changed):

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa-utils
zypper rr http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ 

I must be doing something wrong somewhere.


esoteric:/home/geoff # zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
Adding repository 'multimedia' [done]
Repository 'multimedia' successfully added
Enabled: Yes
Autorefresh: No
URI: http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/

esoteric:/home/geoff # zypper install alsa-utils
Building repository 'multimedia' cache [done]
Reading installed packages...
'alsa-utils' is already installed.
Nothing to do.

Maybe not. Maybe the rpm version you gave before is out of date. Can you type:
rpm -q alsa-utils

Even if alsa-utils is already installed, do NOT forget to run that 3rd command … "zypper rr < url > "


esoteric:/home/geoff # rpm -q alsa-utils
alsa-utils-1.0.17.git20080715-1.5
esoteric:/home/geoff # 

Hmmm … looks like its me making a mistake. This is the correct version.

Did you try this and any of the other codes? Any improvement in your mixer options?

I haven’t tried it yet. I intend too but I got caught up in fixing my wlan speeds.