Another sound problem

just installed suse 11.0 on a new box, am unable to get any sound whatsoever though:( been trying for 3 hours now. according to the computer the soundcard driver is installed…]( been reading all the threads on here but can’t seem to find a thing

Are you using Gnome? KDE3 ? KDE4 ?

You could start by working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE Pay attention to your mixer settings. Both PCM and Master Volume should be moved up.

Please use the recommended sound test (copy and paste the following into a gnome-terminal or kde konsole): speaker-test -c2 -l5 -twavand you should hear a ladies voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ 5 times.

If after working your way through the audio troubleshooting guide, you still are not able to get any sound from the “sound-test”, then we will need more information to help you. In that case, to provide more information, with your PC connected to the internet, please copy and paste the following into a gnome-terminal or a kde konsole:

wget -O && bash 

That will provide you a URL. Please post here ONLY the output URL. Do NOT post all the info , here. Just the URL.

In addition to the above (if seeking more help), please run the following, and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q padevchooser pavucontrol pavumeter paman paprefs
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

If you do get sound from the “sound-test” then your problem is likely an application config/codec problem.

did what you said, still no sound from the card (i’m using kde 4 and pcm and master were set ok)

output url:

OK, thank you.

Please do not forget this request:

aah forgot to post that one

***@linux-2z4o:~> rpm -qa | grep alsa
***@linux-2z4o:~> rpm -qa | grep pulse
***@linux-2z4o:~> rpm -q padevchooser pavucontrol pavumeter paman paprefs
package padevchooser is not installed
package pavucontrol is not installed
package pavumeter is not installed
package paman is not installed
package paprefs is not installed
walter@linux-2z4o:~> rpm -q libasound2
***@linux-2z4o:~> uname -a
Linux linux-2z4o #1 SMP 2008-06-07 01:55:22 +0200 i686 i686i386 GNU/Linux
***@linux-2z4o:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.PtEgHHcFBEE:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Please add alsa-firmware. Thats the very first recommendation in the troubleshooting guide. I’m very surprised you missed that. Then restart your PC and test. I may not help, but it might.

What happened to your pulse apps?

OK, this is typically the case with KDE4. No problems here.

Hmmm … I see you have an old kernel, and have not applied any of the security updates to your 11.0 kernel.

I’m a bit concerned here by this old kernel, because if we fix your sound, and you then update your kernel, that update could end up breaking the sound and you would have to use the knowledge you learned from this thread to do things over again.

Anyway, from the diagnostic script I see this in your mixer:
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Mono: Playback 88 [69%] -29.25dB] [on]
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Front Left: Playback 128 [50%] -25.40dB]
Front Right: Playback 128 [50%] -25.40dB]
when testing sound, I recommend around 95%, and then once one has sound, back off to a lower level to avoid distortion, In some not too common cases the sound volume control is not linear, and one gets no sound to 75% or so. I have no idea if you have one of those cases, but maybe it is prudent to try a higher volume setting?

Anyway, from the script I see you have a STAC9205. Searching the alsa web site for that codec I get this:
Search results for stac9205 - AlsaProject

I note this list in the ALSA-Configuration.txt file for 1.0.16 of alsa:

	  ref		Reference board
	  dell-m42	Dell (unknown)
	  dell-m43	Dell Precision
	  dell-m44	Dell Inspiron

Do you have a Dell ? Lets say you have a Dell Inspiron, … then what you could do is modify your /etc/modprobe.d/sound file (adding another line after the first) such that it looks like this:

options snd slots=snd-hda-intel
options snd-hda-intel model=dell-m44
# u1Nb.PtEgHHcFBEE:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and then restart your PC and test your sound. Check your mixer.

If “dell-m44” in that /etc/modprobe.d/sound file does not work, replace it with “dell-m42” , restart, and try again. The same goes for “dell-m43”.

If that does not work, we can look at an alsa update (I can give you some commands for that to make it easy) but I have read no indication that an alsa update is absolutely necessary.

thanks man! you’re a genius. i finally managed to get some sound out of my computer

Congratulations !!

Please, for my own edification, what steps did you follow that worked?

well basically it was the alsa-firmware that still had to be installed. As you said can’t believe i missed that part. Afterwards i had to do some playing around with PCM & master and all was fixed. We can conclude that it all came down to a lack of knowledge from my side i suppose… :slight_smile:

I’ve lost count of the number of times I’ve had something stump me for a while because either:

  • a lack of knowledge on my part as I never knew the answer (ie I was new), or
  • I once knew the answer and I forgot, or
  • I thought I knew the answer but I was confused with something else

< sigh > such is life. … Fortunately I’ve managed to get good help from our forum here, from IRC chat freenode #suse, and from colleagues at work who have forgotten more about Linux than I’ll ever know. :slight_smile: