Another problem with nvidia drivers

I did a fresh install of 42.1 on a Athlon II X2 system, which beforehand ran opensuse 12.2. The nouveau driver that came with it did a bad job, halting the system sometimes already before the boot screen of grub, sometimes after the plasma-screen was shown.
When halted, tty01 could not be reached either.

So I downloaded and installed the NVidia x86_64-304.131 driver, which should be suitable for the GeForce 7025/nforce 630a graphical card that is in the system. Blacklisted the nouveau driver, did mkinitrd, rebooted.

Now things are slightly better, in that the system hangs no more. But the plasma environment is practically unusable, because it is very slow: it can take minutes to react to a mouseclick, and sometimes in between the screen is rather garbled.

Funny thing is that indeed de nouveau driver is not present anymore, but lsmod shows no NVidia driver too.

Anyone any idea how to solve this? System is of my father in law, and he needs it desperately…

This suggests that the nvidia driver is not used at all, but rather some generic fallback.
Apparently something went wrong with the installation…

Why don’t you just install the RPM packages from the nvidia repo?

Uninstall the driver by running “NVIDIA-xxx.run --uninstall”, then follow the instructions here:
https://en.opensuse.org/SDB:NVIDIA_drivers

And yes, you do need the G02/304.xx driver for that chipset.

The nouveau driver that came with it did a bad job, halting the system sometimes already before the boot screen of grub

“before the bootscreen of grub” no graphics driver is used at all, and in particular not nouveau.
If your system already crashes/freezes at that point already, it might rather be a hardware problem.

Or do you mean plymouth, the boot splash?
Grub is the boot menu where you can choose which operating system to boot (openSUSE, “Advanced Options”, and e.g. Windows if that’s installed).

Thanks a lot for your fast response!
You may well be right in that it was the boot splash, not grub. The system has been running 12.2 happily for years, so I would be a very rare coincidence is there was a hardware problem just when installing 42.1…

Anyway, I deinstalled the .run, and installed the rpm according to your advice and the indicated instructions. That all went well. But there is not much result:
lsmod shows

nvidia 11419648 72
drm 385024 2 NVidia

and that is more than before, but less than I expected.
And the responses of plasma are still the same…

Any other thoughts?

The G02 nvidia driver does not work well. I have an Nvidia Geforce 6150LE card. I’m back to using nouveau (which also doesn’t work well).

Here’s the trick.

Edit “.config/kwinrc” with a text editor. Maybe login to the Icewm desktop to do that (at least Icewm works reasonablyt well).

Look for the line

OpenGLIsUnsafe=false

and change that “false” to “true”.

After that change, Plasma 5 should be usable. There won’t be any desktop effects. But you can later go into settings for Display and Monitor, and set it to use “XRender” for the compositing backend. That will get you desktop effects back, though not as fancy. And it should be reasonably stable.

Am Fri, 15 Jul 2016 13:26:02 GMT
schrieb jehojakim <jehojakim@no-mx.forums.microfocus.com>:

> Any other thoughts?
>
>

Install another (lightweight) GUI like XFCE/LXDE/IceWM/Fluxbox.


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

Funny thing to add, the monitor is not seen correctly by hwinfo after these steps. Beforehand (before blacklisting the nouveau-drivers, I think I remember) the Iiyama monitor was listed correctly in the hwinfo listing, connected to the GeForce card , now it shows a generic monitor, without a connection mentioned.

The graphics card is shown OK, with “Driver modules: “nvidia””.

Thanks a lot, that seems to do the trick! I’ll go further testing some things, but it seems to work now!