Another plymouth high resolution problem after nvidia install

I have 9500GT card and Opensuse 12.2, with nvidia proprietary driver.
After nvidia install, i have a plymouth in a wrong resolution (my resolution is 1920x1080).

Googled a lot of threads, and please correct me if i wrong:

  1. Nvidia driver working with framebuffer, that doesn’t support high resolutions like my (1920x1080).
  2. There’s only way to settle this, is to use uvesafb.
  3. Tried to install v86d and zypper cannot find this package.

Am i right?

Thank you,

Actually nVidia driver and framebuffer are mutually exclusive. This combination never worked reliably, and while it may have improved I would not use it. This means no eye candy during boot. Personally I do not care.

If you need pretty plymouth screen the only option is probably nouveau.

Thank you,

In Yast - System - Bootloader - Advanced options, you can see the available resolutions for GRUB and the konsole. On my laptop the default 1600x900 is not available during boot, max is 1200x800 IIRC.