Another Nvidia Problem. Sllooow Performance.

Computer is an old AcerPower 1000 that been maxed out on RAM and dual Core Athlon64.
OpenSuSE 11.3 of course. Computer ran like a scalded cat on 11.2.

Being a Linux n00b I initial upgraded to 11.3. The Nvidia 6150le graphics caused major problems I got it half butt installed but resolution was stuck so tonight I did a new install. As a side note imagine my surprised when all my files that I backed up and settings were still there.

I went through the instructions using nomodeset, setting NO_KMS to yes, blacklisting nouveau installing gcc, make, kernel-source-desktop and the Nvidia 256.35 drivers. I even removed nouveau altogether, after all that it was still loading.

The problem is the performance of the UI is terribly slow. Menus stutter and frames tear while opening. I had switched to Xrenderer before installing the proprietary drivers but has switched back to OpenGL.

The only “option” is to set animation to “instant” but that’s a crutch.
I’ve searched and did not find anything quite similar, the drivers are installed the performance is just slow.

Ideas besides downgrading to 11.2.

I had this problem and resolved it by removing the driver kernel module. Did you notice additional options in GRUB? I did and this is what gave me the clue that I had been a bit aggressive with the package selection.

The packages you need are:-
libXNVCtrl - NVidia Control Library
nvidia-gfxG02-kmp-default - NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs
nvidia-settings - Configuration Tool for nVidia GPUs
nvidia-texture-tools - NVIDIA Texture Tools
x11-video-nvidiaG02 - NVIDIA graphics driver for GeForce 6xxx and newer GPUs

You also need to de-select the
xorg-x11-driver-video-nouveau - Accelerated Open Source driver for nVidia cards

Like I said… this worked for me when I had exactly the same symptoms that you had. You will need a reboot to bring in the amended kernel.

By the way, I have never blacklisted anything, deleted anything or changed any settings. Just rebooted.

Hope this helps.

Thanks! Performance is much better! I was able to switch back to the them I used on 11.2.
Not as smooth but livable. Maybe some tweaking in the “new” control panel.

On reboot grub now has “opensuse”, “Desktop” and “windows” as boot options.
I assume the default is “correct” one to boot too for the new kernel?