Another Nvidia driver problem!

G,day
I have just installed the nvidia driver (173.14.12-0.1) through yast.
I rebooted my system just to be on the safe side but the driver wasn’t being used. After having a look at other nvidia problems I tried “sax2 -r -m 0=nvidia” (after init 3).
Sax2 started its own xserver etc. It came up with the wrong resolution so I adjusted it to the correct resolution and then tested it.
Somehow the resolution was worse than before.

I have tried a manual (hard way) install of the latest driver (that ended with a new install of opensuse 11).

Any help would be appreciated. I am a bit of a noob with the command line (I have only been able to edit the xorg.config file with kate in the past).

My system is:-
Intel E7200
2G ram
Nvidia GeForce 7600 GT
OS: Linux 2.6.25.18-0.2-default x86_64
System: openSUSE 11.0 (x86_64)
KDE: 4.1.3 (KDE 4.1.3) “release 51.1”

Thanks for your time.

As a first step, have you installed the nvidia-settings (Nvidia X Server Settings) application? Its also in Yast. Install and run it - it will tell you about the driver, openGL settings and X configuration. It should not be necessary to reinstall the system just to get the nvidia driver to work - at the most all you should have to do is log out and back in again.
Can you tell us how you established that the driver wasn’t being used after you installed it with Yast?

Thanks for the quick reply.
I tried glxgears. It just came up with errors.

Xlib: extension “GLX” missing on display “:0.0”.
glxgears: Error: couldn’t get an RGB, Double-buffered visual.

I do have nvidia-settings installed. This is what I got from it.

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server

I just tried to run nvidia-xconfig, I’ll just restart the xserver and see what has happened

O.k, things have turned ugly!

After restarting the xserver I have a stretched screen. It looks like the screen resolution is 640x480!
I have tried to run nvidia-settings but I am unable to see anything in what should be the bottom half of the screen.

I also tried running Nvidia-xconfig, but there was no change.

Any sugestions?

It Looks like my monitor has changed its own resolution to 640x517.
I have been looking at my monitors settings in Yast. It all looks good there, but its a bit hard to tell with the screen so stretched.
But if I boot into safe mode it is at its correct resolution of 1680x1050.
Ive had a look in xorg.confg and it looks fine to me (as far as my untrained eyes can see).

Anyone got any ideas?
Thanks.

Ok, can you tell me the output of entering this at the command line:

cat /etc/X11/xorg.conf | grep "Driver"

I’d expect to see kbd, mouse, and nvidia in there. If there is one called “nv” it means the driver is not loaded.
If the nvidia driver is loaded, then run sax2 again (as in your first post) to fix/choose the correct screen resolution.

If you can burn a CD with the inf file for you monitor, go back into sax2 and under the Monitor section, there’s a place where you can provide a driver disk. Even if it’s a Windows driver, it will work.

Sounds like your monitor may not be getting properly detected.

I haven’t been able to find the disk that came with the monitor.

I’ll see what I can get from the command line

Thanks

The output is
Driver “kbd”
Driver “mouse”
Driver “nvidia”

I’ll try sax2 again.
Just tried it… no change. Thanks anyway

What do you mean by “no change”? With sax2 running you should be able to change the resolution of the screen.

I can go through the motions of changing the resolution of the monitor in Sax2, but when I “test” the settings before saving, the resolution still hasn’t changed.

If I use the “nv” driver everything works as expected, except I don’t have 3d.

Confused as I am yet? :slight_smile:

Weird. Are you getting any errors in the Xorg log file?
Try looking (or grepping) through it for Errors or Warnings:

cat /var/log/Xorg.0.log | grep "(EE)"

or

cat /var/log/Xorg.0.log | grep "(WW)"

Well, this may be interesting, there seems to be a lot missing? I could not get all of the text, as it was off the screen. But here is what I could get. Thanks for hanging in there with me.

   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(WW) The directory “/usr/share/fonts/local” does not exist.
(WW) The directory “/usr/share/fonts/PEX” does not exist.
(WW) The directory “/usr/share/fonts/latin2/misc” does not exist.
(WW) The directory “/usr/share/fonts/latin2/75dpi” does not exist.
(WW) The directory “/usr/share/fonts/latin2/100dpi” does not exist.
(WW) The directory “/usr/share/fonts/latin2/Type1” does not exist.
(WW) The directory “/usr/share/fonts/latin7/75dpi” does not exist.
(WW) The directory “/usr/share/fonts/baekmuk” does not exist.
(WW) The directory “/usr/share/fonts/japanese” does not exist.
(WW) The directory “/usr/share/fonts/kwintv” does not exist.
(WW) The directory “/usr/share/fonts/uni” does not exist.
(WW) The directory “/usr/share/fonts/CID” does not exist.
(WW) The directory “/usr/share/fonts/ucs/misc” does not exist.
(WW) The directory “/usr/share/fonts/ucs/75dpi” does not exist.
(WW) The directory “/usr/share/fonts/ucs/100dpi” does not exist.
(WW) The directory “/usr/share/fonts/hellas/misc” does not exist.
(WW) The directory “/usr/share/fonts/hellas/75dpi” does not exist.
(WW) The directory “/usr/share/fonts/hellas/100dpi” does not exist.
(WW) The directory “/usr/share/fonts/hellas/Type1” does not exist.
(WW) The directory “/usr/share/fonts/misc/sgi” does not exist.
(WW) The directory “/usr/share/fonts/xtest” does not exist.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-0
(WW) NVIDIA(0): No valid modes for “1680x1050”; removing.
(WW) NVIDIA(0): No valid modes for “1600x1024”; removing.
(WW) NVIDIA(0): No valid modes for “1600x1000”; removing.
(WW) NVIDIA(0): No valid modes for “1400x1050”; removing.
(WW) NVIDIA(0): No valid modes for “1280x1024”; removing.
(WW) NVIDIA(0): No valid modes for “1440x900”; removing.
(WW) NVIDIA(0): No valid modes for “1280x960”; removing.
(WW) NVIDIA(0): No valid modes for “1366x768”; removing.
(WW) NVIDIA(0): No valid modes for “1280x800”; removing.
(WW) NVIDIA(0): No valid modes for “1152x864”; removing.
(WW) NVIDIA(0): No valid modes for “1280x768”; removing.
(WW) NVIDIA(0): No valid modes for “1280x720”; removing.
(WW) NVIDIA(0): No valid modes for “1024x768”; removing.
(WW) NVIDIA(0): No valid modes for “1280x600”; removing.

Well that is a problem. If you are connecting the display using a DVI port you could try using the analogue (vga) port if there is one.
The ‘Unable to read EDID’ message means that the video card cant work out what features (resolution etc) your display will support.

I have heard of a work-around/fix using the ‘Acquire EDID’ function on the nvidia-settings app, but have not actually done this myself. The idea being it creates a custom EDID which you then refer to into the Device scction of the xorg.conf file.

HTH

Take a look here Fixing Ugly DVI/HDMI Displays due to EDID bugs on nVidia drivers | analogbit.com it shows how to add a custom EDID to you xorg.conf file in the second half of the page.

Most monitor manufacturers, on their website, have a Windows driver posted, which is generally nothing more than an inf file that lists all the resolutions and refresh rates the monitor will support.

Just download that, burn it to a disc, insert it, start sax2 and indicate you have a driver disc for your monitor, browse to it, and the file should be read.

If that goes, your monitor will be listed in the list of monitor types and you can just select it, test, and save your settings.

—Sounds like your monitor isn’t being detected correctly, and/or the settings for it are just wrong.
When SuSE detects your monitor, it will attempt to set the resolution to the “native” settings. If that isn’t correct, or if you simply want a different resolution/refresh setting, the place to look is in sax2.
When sax2 is run (either by “sax2 -r”), or from the gui, the video card’s settings can be changed there.
–BUT, before you hit “save” or “test”, select “monitor”, and see what sax2 set as the defaults.
In the case of my 19inch,“1996F”, OfficeMax monitor, sax2 insists that it’s a (16", 5/4), when it’s a (19",4/3).
That could be the case here.
Hirschacker(Bob)

Problem Solved!**** Thanks so much for everyones help. I truly appreciate it. I finaly found my monitors disk, but it only consisted of a user manual. My monitor is not listed in Sax2 (Chimei CMV221D). Sax2 was trying Versa 15inch settings. I could change this manualy to “LCD” and then manualy change the display size and sync frequencies. All this would be saved. But the “test” would still revert back to 640x480. I could check the settings again and they were still setup correctly for my monitor.
The solution was to run the monitor through the analog input.
All is well now. The monitor had been running through the didital input for 6 months or more, so I don’t know why it played up just now.
Once again, thanks for your time and help!

I am trying to install openSUSE 11.1 on a rather old laptop to make it useful again. I am also getting the:

(WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

warning in my /var/log/Xorg.0.log file. Anytime X starts, via kdm or sax, or whatever, I just get a black screen. I have attempted wiping my xorg.conf file, but I just can’t seem to load X with the nvidia legacy driver. (I have a GeForce4 440 in this old beast).

The nv driver works fine, but with no 3D.

Everywhere I’m googling, it seems I need to try a custom edid file in xorg.conf, except I can’t grab the edid with nvidia-settings, since I can’t get the nvidia driver to load.

Is there another way to grab the edid file from the display on this laptop?