Another N00B fails to connect to internet

Hello Everyone!
I am complete newbie with OpenSuse. Previously I used Ubuntu and loved it. I thought I should give OpenSUSE a try. And after installing I don’t regret my decision.
But unfortunately, i can’t connect to internet. I have a pppoe connection and an ADSL modem. In ubuntu i used to configure the connection with “sudo pppoeconf”. Here in SUSE, things look much better since it has a GUI based configuration manager.
I set up the network settings and it could detect my modem. And configured the dsl settings. But don’t know why I still can’t connect. I am adding some screenshots. Please take a look.
I also tried this one: Bryan 手æœ* — 生活記趣 » How to connect to internet by PPPOE (KDE or Gnome) on Opensuse But my right-click isn’t working (yes, i will buy a new one)
Also ifconfig gives me: “bash: No such command” which is surprising.

OK, a long shot …

On the Hostname|DNS tab
uncheck Update DNS data via DHCP
under Name Servers enter the (DNS) name servers that your ISP uses
(in plain language, you’re telling it some numbers it ought to be able to work out for itself but can’t)

On my router, DNS is a tad flaky, so I’ve got into the habit of hard-coding the name servers on openSUSE (and Windows XP) - the trick seems to work.

As belt-and-braces, under Routing (or wherever it’s hiding) confirm that your Default Gateway is set to

  • cyberbuff,

other than Ubuntu, “normal” distributions allow you to become root on a console. So open a console and type
The prompt should become red after that. Now try
ifup dsl0
to check if your connection is working.


thanks for your reply. I will try unchecking that option. but about the name server, I really can’t figure out what it would be. Can you help me a bit

As for ifconfig not found, I suspect it’s 'cos /sbin isn’t on your path.

Here’s how I set mine up in .bashrc

export PATH=${HOME}/scripts
export PATH=${PATH}:/usr/local/bin:/usr/bin:/bin
export PATH=${PATH}:/usr/local/sbin:/usr/sbin:/sbin
export PATH=${PATH}:/usr/X11R6/bin
export PATH=${PATH}:/opt/kde3/bin

PS You may say you’re a noob, but it’s a pleasure to see someone documenting their problem(s) so well.

I thought you might not know your name servers. Sharing mine isn’t fair to my ISP so I can’t say for sure if this will work:-

OpenDNS | Providing A Safer And Faster Internet

Try those two numbers at bottom right.

Before you do that, maybe the name server numbers you need are listed on your router? Also, you’re presumably posting from another machine, rummage around in there for them.

In OpenSUSE 11.1 change DNS to openDNS - openSUSE Forums

HowTo …

thanks again…i will try with the opendns numbers…I am currently on Windows, on the same machine…is there any chaance to get the name servers on windows?
Anyway, here are some results:

linux-6dsv:/home/dutta # ifconfig
dsl0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:594 (594.0 b) TX bytes:494 (494.0 b)

eth0 Link encap:Ethernet HWaddr 00:16:76:46:4F:54
inet addr: Bcast: Mask:
inet6 addr: fe80::216:76ff:fe46:4f54/64 Scope:Link
RX packets:1355 errors:0 dropped:0 overruns:0 frame:0
TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:128039 (125.0 Kb) TX bytes:29770 (29.0 Kb)
Interrupt:21 Base address:0x2000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:56 errors:0 dropped:0 overruns:0 frame:0
TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3464 (3.3 Kb) TX bytes:3464 (3.3 Kb)

linux-6dsv:/home/dutta # ifup dsl0
interface dsl0 is up
Checking for network time protocol daemon (NTPD): unused

Here’s how to set the openDNS ones on Windows XP - don’t break Windows though - I’m saying so 'cos the ones your ISP gave you might be in there already

PS I’m out of my depth setting up a DSL modem - the DNS is a long shot - but it’s what worked for me on two openSUSE 11.0 boxes.

PPS can you ping from Linux? - that would strongly suggest it’s DNS related.

thanks kj44. I tried with the opendns thingy. and here is my network information:

Oh dear. I’m a bit confused by that default route and subnet mask. I could be barking up the wrong tree :o

Anyway, you can still go into openSUSE, uncheck that tickbox as I suggested, put in the openDNS nameservers from their website (it’s all documented there in the forum link) and give it a go.

In OpenSUSE 11.1 change DNS to openDNS - openSUSE Forums

Make a note of the default route in Windows. Try the one I suggested ( and if that gives no luck, try yours.

Oh, and try pinging from openSUSE.

ok. i will try…have you seen the network information dialogue box? does it say something wrong?

ok. i tried to edit resolv.conf and found this alreadey there:

search site

The dialog box isn’t wrong, it’s not what I expected. So I’m being cautious about my own diagnostic abilities.

Your /etc/resolv.conf is what I’d expect. I wouldn’t have suggested editing it, I’d have recommended staying within the GUI. (You edited it, didn’t you?)

The puzzle now is, why isn’t resolv.conf matching what you have in the GUI? What I do know is that openSUSE does some stuff “behind the scenes” so I’d still advise you to enter those two nameservers in the GUI, uncheck that “Update DNS via DHCP” tickbox and let openSUSE configure itself.

Oh, and ping an IP address, we can be more confident it is a DNS problem if the ping comes back.

ok i tried to ping with “ping” After a long time it gave me “bash: ping unknown host”. What’s now?

You pinged with a name not an IP address. I looked the IP address up for you:

> host has address has address has address

So try

> ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=243 time=113 ms
64 bytes from icmp_seq=2 ttl=243 time=115 ms

If it comes back as it did for me, you’re getting onto the internet but something isn’t converting hostnames to IP addresses - that’s DNS’ job and we’re on the right track.

If it doesn’t come back, then I can’t help you immediately.

Ok, i tried to ping with the ip but it gave me: “Destination unreachable” What’s next?

someone? Please…I really need this.

Ok the fist screen capture you posted had the Network Settings windo.w Global Settings tab.
There are two settings near the top

  • User controlled with NetworkManager
    o Traditional Method with ifup

make sure you select the traditional method with ifup.
NetworkManager is a bit incomplete yet with handling all network connections types. Switch it to ifup and proceed with the defaults settings, (you may need to delete and reinstall the dsl modem to reset to the defaults). This might clear up the problem. (no guaranty on this! :slight_smile: let me know what happens…

ok. i will. BRB.