Another Issue With the latest Major Updat.

That update showed up yesterday, but I noticed that one package was changing from x86_64 to i585 arch. This change pulled in over 40 i586 packages. Obviously, waiting for that to be fixed seemed wise. That problem is gone today, but at least one new one popped up. Currently, I have this package installed:

Information for package libx265-188:
Repository     : @System
Name           : libx265-188
Version        : 3.3-1.3
Arch           : x86_64
Vendor         :
Installed Size : 15.3 MiB
Installed      : Yes
Status         : up-to-date
Source package : x265-3.3-1.3.src
Summary        : A free H265/HEVC encoder - encoder binary
Description    : 
    x265 is a free library for encoding next-generation H265/HEVC video

The update wants to keep that package (!?) and install this package:

Information for package libx265-192:
Repository     : Packman repository (openSUSE_Tumbleweed)
Name           : libx265-192
Version        : 3.4-1.2
Arch           : x86_64
Vendor         :
Installed Size : 15.3 MiB
Installed      : No
Status         : not installed
Source package : x265-3.4-1.2.src
Summary        : A free H265/HEVC encoder - encoder binary
Description    : 
    x265 is a free library for encoding next-generation H265/HEVC video

Shouldn’t the package ownership switch repos and the original package be replaced by the new one?


These are two different packages with different names.

After today’s update, I checked for orphaned packages

zypper packages --orphaned

and libx265-188 showed up. So I removed it.

I suspect this was all related to a temporary problem on the packman sites.

Yesterday’s package is the same as today’s one (libx265), right? I guess there was some outdated dependency on *-188, which was updated in the meantime.

$ zypper se --requires-pkg libx265-188
Loading repository data... 
Reading installed packages... 
S | Name         | Summary                                    | Type 
i | libavcodec58 | FFmpeg codec library                       | package 
i | vlc-codecs   | Additional codecs for the VLC media player | package 

Although both packages depend already on libx265-192. So after the upgrade it should be possible to remove the *-188 package. I suppose there’s a technical reason why the old package wasn’t marked for removal. nrickert’s message confirms nothing is pulling the old one as dependency.

Thanks for the info. The update went well, but I did have to remove the old libx265 after it completed.


Technically, the old package was named “libx265-188” and the new package is named “libx265-192”. The “188” and “192” are part of the package name, and not just a version number.

Here’s my guess as to what happened (which might be wrong).

Packman was replacing “libx265-188” with the newer “libx265-192”. So it got to the point where the 64-bit version of “libx265-188” was removed, but the newer replacement was not yet there. And then Packman had problems – I think I saw mention of a disk failure. So we were doing our Tumbleweed update at a time when Packman was a bit messed up. And that’s why we were switched to the 32-bit version. But all was fixed for today’s update, and we installed the 64-bit version of “libx265-192”.

I have a similar problem, however it says:

Problem: problem with installed package libx265-188-3.3-1.3.x86_64
Problem: calibre-4.17.0-1.1.x86_64 requires, but this requirement cannot be provided

If I click the option “keep obsolete libx265-188-3.3-1.3.x86_64” it comes with more and more problems to Keep other obsolete packages. I don’t want to break calibre. I had these messages 7 times with more and more "keep obsolete package … " before I cancelled out. SO what is the option? I had before:

Solution 2: deinstallation of calibre-4.17.0-1.1.x86_64
 Solution 3: break calibre-4.17.0-1.1.x86_64 by ignoring some of its dependencies

Shall I uninstall calibre and install afterwards or wait for the update or just try to remove the libx265-188-3.3-1.3.x86_64 and intall the 192 version even though it might break any dependencies?

Further to my previous email when I try:

zypper rm libx265-188
Reading installed packages...
Resolving package dependencies...

The following 163 packages are going to be REMOVED:
  MPlayer MediathekView akonadi-calendar-lang akonadi-calendar-tools akonadi-calendar-tools-lang akonadi-import-wizard
  akonadi-import-wizard-lang akonadi-plugin-calendar akregator akregator-lang amarok amarok-lang audacity audacity-lang
  baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools
  baloo5-tools-lang baloo5-widgets baloo5-widgets-lang calibre chromium dolphin dolphin-part dolphin-part-lang ffmpeg-4
  ffmpegthumbs ffmpegthumbs-lang gegl-0_4 gegl-0_4-lang gimp gimp-lang gimp-plugin-aa gimp-plugins-python gmplayer
  gstreamer-plugins-libav gwenview5 gwenview5-lang k3b k3b-lang kaccounts-providers kaccounts-providers-lang kaddressbook
  kaddressbook-lang kde-cli-tools5 kde-cli-tools5-lang kdepim-addons kdepim-addons-lang kdepim-runtime kdepim-runtime-lang
  kfilemetadata5 kfilemetadata5-lang khotkeys5 khotkeys5-lang kinfocenter5 kinfocenter5-lang kmail kmail-account-wizard
  kmail-account-wizard-lang kmail-lang kmailtransport kmailtransport-lang kontact kontact-lang korganizer korganizer-lang
  ksysguard5 ksysguard5-lang ktnef ktnef-lang ktorrent ktorrent-lang libKF5AkonadiCalendar5 libKF5Baloo5
  libKF5CalendarSupport5 libKF5EventViews5 libKF5IncidenceEditor5 libKF5MailCommon5 libKF5MailTransport5
  libKF5MailTransportAkonadi5 libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5 libKPimGAPITasks5
  libKPimImportWizard5 libavcodec56 libavcodec57 libavcodec58 libavdevice57 libavdevice58 libavfilter5 libavfilter6
  libavfilter7 libavformat56 libavformat57 libavformat58 libchromaprint1 libgegl-0_4-0 libgimp-2_0-0 libgimpui-2_0-0 libheif1
  libkgapi-lang libksieve libksieve-lang libksysguard5 libksysguard5-lang libopencv3_4 libqt5-qtwebengine libx265-188
  libxine2-codecs mbox-importer mbox-importer-lang messagelib messagelib-lang motion mpv mpv-bash-completion opensuse-welcome
  opensuse-welcome-lang otter-browser patterns-kde-kde patterns-kde-kde_plasma pim-data-exporter pim-data-exporter-lang
  pim-sieve-editor pim-sieve-editor-lang pipewire-spa-plugins-0_2 plasma-browser-integration plasma-browser-integration-lang
  plasma5-addons plasma5-addons-lang plasma5-desktop plasma5-desktop-emojier plasma5-desktop-lang plasma5-session
  plasma5-session-wayland plasma5-workspace plasma5-workspace-branding-openSUSE plasma5-workspace-lang plasma5-workspace-libs
  powerdevil5 powerdevil5-lang python3-qtwebengine-qt5 sddm sddm-branding-openSUSE sddm-theme-openSUSE signon-plugin-oauth2
  signon-ui smplayer smplayer-lang smplayer-skins systemsettings5 systemsettings5-lang transcode vlc vlc-codecs vlc-opencv
  vlc-vdpau youtube-dl

The following 2 patterns are going to be REMOVED:
  kde kde_plasma

163 packages to remove.
After the operation, 1.1 GiB will be freed.

I installed libx265-192 and tried zypper dup and had messages as before (previouos post) and if I try to remove libx265-188 I have the same messages that 163 packages need removing as above.

OK there are obviously none of your knowledgeable guys available so I tried a few things. First the command zypper se --requires-package for libx265-188 showed the same packages as for libx266-192 so I removed libx265-188 with the command

rpm -e --nodeps libx265-188

now the zypper dup command comes up with the following problem:

Problem: calibre-4.17.0-1.1.x86_64 requires, but this requirement cannot be provided
  deleted providers: libQt5Core5-5.14.1-2.2.x86_64
 Solution 1: Following actions will be done:
  keep obsolete libQt5Core5-5.14.1-2.2.x86_64
  keep obsolete libQt5Gui5-5.14.1-2.2.x86_64
  keep obsolete libQt5DBus5-5.14.1-2.2.x86_64
 Solution 2: deinstallation of calibre-4.17.0-1.1.x86_64
 Solution 3: break calibre-4.17.0-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): 1
Resolving dependencies...
Computing distribution upgrade...
4 Problems:
Problem: libQt5Network5-5.15.0-1.2.x86_64 requires libQt5Core5 = 5.15.0, but this requirement cannot be provided
Problem: libQt5Widgets5-5.15.0-1.2.x86_64 requires libQt5Gui5 = 5.15.0, but this requirement cannot be provided
Problem: plasma5-workspace-libs-5.18.5-2.2.x86_64 requires libQt5DBus5 >= 5.15.0, but this requirement cannot be provided
Problem: vlc-qt-3.0.10-5.4.x86_64 requires

When I again try to keep the obsolete package it goes on and on and asks to keep more obsolete packages. What now?

I don’t have a good answer.

The Tumbleweed systems that I recently updated don’t have calibre installed. But maybe I will run into that problem tomorrow when I update another system.

I did run into a calibre problem a few weeks ago. I checked for orphaned packages, and then tried to remove them. And removing would have caused issues for calibre. But that problem seems to have gone away. I think it was because some needed packages had not yet been updated.

Given the factory mailing list note about the recent update, it is probably a similar issue. Some of the packages needed by calibre may be among those that are not successfully building with gcc10. So you probably have to wait for it to clear up.

I guess solution 3 is the easy out. It might make calibre unusable. Or maybe it just makes a few calibre functions not work for now. But it keeps it there for future updates to pull in what is needed when they become available.

Well I use calibre quite frequently. I see no point upgrading a system when a programme I use then becomes unusable. May be it is solved soon

Version 4.18.0 is in the queue by the looks (18 hrs ago)… Just need to wait for it to make it’s way into a snapshot…

Thanks for the info malcolmlewis and nrickert, I will try tomorrow again.

For the time being:

erlangen:~ # zypper in calibre 
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides needed by calibre-4.17.0-1.1.x86_64
 Solution 1: do not install calibre-4.17.0-1.1.x86_64
 Solution 2: break calibre-4.17.0-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 
erlangen:~ # flatpak search calibre
Name          Description          Application ID                  Version       Branch       Remotes
Calibre       E-book manager       com.calibre_ebook.calibre       4.17.0        stable       flathub
erlangen:~ # flatpak install calibre
Looking for matches…
Found similar ref(s) for ‘calibre’ in remote ‘flathub’ (system).
Use this remote? [Y/n]: 
Found ref ‘app/com.calibre_ebook.calibre/x86_64/stable’ in remote ‘flathub’ (system).
Use this ref? [Y/n]: 

com.calibre_ebook.calibre permissions:
    ipc      network      x11      devices      file access [1]      dbus access [2]     system dbus access [3]

    [1] host
    [2] org.freedesktop.Notifications
    [3] org.freedesktop.NetworkManager, org.freedesktop.UDisks2

        ID                                              Branch            Op           Remote            Download
 1. ✓] org.freedesktop.Platform.GL.default             19.08             u            flathub             3.1 MB / 85.1 MB
 2. ✓] org.freedesktop.Platform.Locale                 19.08             u            flathub            20.3 kB / 318.3 MB
 3. ✓] org.freedesktop.Platform.VAAPI.Intel            19.08             u            flathub             1.0 kB / 8.7 MB
 4. ✓] org.freedesktop.Platform                        19.08             u            flathub           854.9 kB / 238.5 MB
 5. ✓] com.calibre_ebook.calibre                       stable            i            flathub           133.8 MB / 144.2 MB

Changes complete.
erlangen:~ #