Another Compiz-fusion problem.. Done everything--?

I tried everything so i wouldnt be wasting your time… I’m kinda new to Opensuse, played with Ubuntu then got bored of it. I know how to build things, use terminal, etc.
Alright, I’m running Opensuse 11.0 on an HP laptop. Nvidia GeForceGO 6150. THe default Compiz-fusion work (7.04) without doing anything related to my graphics card. It worked fine with it. Could rotate the cube, etc.
I installed 7.8 (Compiz Fusion - openSUSE)
ran rpm -qa | grep compiz in the terminal, everything about matched, all was 7.8. I logged out, but when I logged back in i only had one workspace, no effects, and no bars (minimize, maximize, exit). I tried a slu of commands in the terminal, and downloading the one-click install for my nvidia (NVidia - openSUSE). Compositions enable, i believe aiglx is enable. But nada. It wouldnt work. Tried reinstalling several times, all with the same problems. So i downgraded back down to 7.04, the default. Works fine, though some plugins (snow, aquarium thing) wont work.
Driver problem?

I don’t know what to do…

Hi
Have you tried the latest nvidia driver released today, 177.80?

There is a thread in the chit-chat section with a link.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 9:24, 1 user, load average: 0.09, 0.22, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

There an error with the page, all GeForce Linux 32-bit drivers aren’t available. Brings up a 404 not found on the site.
I do have a 32-bit i believe, chose it so i wouldn’t have to build so many things, though i have an amd64.
Is it a driver problem that I’m facing? I’m running the 7.04 version of compiz fusion, and it works almost correctly.

In 7.8 i had no bars (minimize, exit, etc) and in 7.04 when i open up an application, say the terminal, it will open up at the top of the screen, with no bar also.

Hi
Download from here;
http://www.nvidia.com/object/unix.html


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 10:46, 1 user, load average: 0.56, 0.16, 0.20
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Click on the link you gave me, then click on Linux|A32. Page not found.

iseil@linux-nv81:~> grep Composite /var/log/Xorg.0.log
(**) Extension “Composite” is enabled
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is

Hi
Works fine for me?
Try wget;


wget
http://us.download.nvidia.com/XFree86/Linux-x86/177.80/NVIDIA-Linux-x86-177.80-pkg1.run


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 11:11, 1 user, load average: 0.27, 0.19, 0.13
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I still can’t reach this link… It says page not found!

Hi
Just ran the wget command, works here?


wget
http://us.download.nvidia.com/XFree86/Linux-x86/177.80/NVIDIA-Linux-x86-177.80-pkg1.run
--2008-10-08 20:29:15--
http://us.download.nvidia.com/XFree86/Linux-x86/177.80/NVIDIA-Linux-x86-177.80-pkg1.run
Resolving us.download.nvidia.com... 128.242.186.216, 128.242.186.201
Connecting to us.download.nvidia.com|128.242.186.216|:80... connected.
HTTP request sent, awaiting response... 200 OK Length: 21083031 (20M)
[application/octet-stream] Saving to: `NVIDIA-Linux-x86-177.80-pkg1.run'

Maybe it’s your ISP’s DNS (I use openDNS) or clear your browser cache?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 15:11, 2 users, load average: 0.29, 0.23, 0.17
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

ok, it’s downloading now, wget http://us.download.nvidia.com/XFree86/Linux-x86/177.80/NVIDIA-Linux-x86-177.80-pkg1.run.

Maybe i was clicking the wrong link. I’m using the 32-bit opensuse 11.0, so i clicked this link: Linux Display Driver - x86
Does that link work for you?

Can i know how you install it…?

How do you reach the terminal with no openGL programs running?

Alright, alright, i hit ctrl+alt+backspace a bunch of times and it caused opensuse to stay in the pre=login terminal thing for 2 minutes.
sudo sh NVIDIA-Linux-x86-177.80-pkg1.run -q started to install, a few errors occurred.
Here’s the log:

-> Installing NVIDIA driver version 177.80.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the development tool cc in your path; please make sure
that you have the package ‘gcc’ installed. If gcc is installed on your
system, then please check that cc is in your PATH.

Hi
Here is my canned response :slight_smile:

Download the driver for your arch from;
Nvidia Unix Drivers

If you don’t have the kernel source etc installed then;


sudo zypper in kernel-source linux-kernel-headers kernel-syms
sudo zypper in -t pattern devel_basis devel_C_C++

Press ctrl+alt+F1 and login as your user :slight_smile:


su -
init 3

cd to the Nvidia Unix Driver you downloaded


sh NV*.run -q
sax2 -r -m 0=nvidia
init 5 && exit
ctrl+alt+F1
exit
ctrl+alt+F7

The ctrl+alt+F7 gets you back to the GUI (X session).

Now after a kernel update, you don’t need to run the sax2 command, just
the others to get to run level 3, rebuild the driver and exit.

Looks like you don’t have the development tools installed, so you need to run the zypper commands.


Cheers
Malcolm
(Currently feeling lost because the nntp gateway appears to have issues)

How exactly do i see what version i am running?

When i go into ctrl+alt+F1 my screen completely messes up, having lines running up and down. ctrl+alt+F7 is completely normal.

Rebooted my computer, everything worked fine. i used the

cat /proc/driver/nvidia/version

command to confirm version 177.80

NVRM version: NVIDIA UNIX x86 Kernel Module  177.80  Wed Oct  1 14:38:10 PDT 2008

Now to see if the compiz update will work.

Updated compiz-fusion. Nothing once more. Same problems as before.

python-compizconfig-0.7.8-2.2
libcompizconfig-0.7.8-2.2
compiz-fusion-plugins-unsupported-0.7.8-2.5
compiz-bcop-0.7.8-2.1
compiz-fusion-plugins-main-0.7.8-2.2
compizconfig-settings-manager-0.7.8-2.2
compiz-emerald-themes-0.6.0-16.1
compiz-0.7.8-3.1
compiz-emerald-0.7.8-2.2
compiz-manager-0.0.1_git080201-54.1
compiz-gnome-0.7.8-3.1
compiz-fusion-plugins-extra-0.7.8-2.2

is the problem still no bars?

open a konsole window and type: emerald --replace&