Another change screen resolution in suse 13.1 problem

Sorry to bother this forum with another problem in getting the screen resolution to run at max capability.

It is KDE 13.1 and it is a HP Compaq 6910p labtop, which can have a resolution of 1440x900. But it only runs at 1024x800 :frowning:

I have read a lot of other threads about this problem without success. And here I post infomation that was required on other threads:

Intel Graphics Card - 965 GM
SUSE Paste

I was trying to make the solution by making a X11.conf in /etc/X11/xorg.conf.d/50-monitor.conf, and to get info I used cvt and xrandr:
SUSE Paste

It seems like I have a problem with finding the right name for the screen (LVDS /1 ?). Using Configure Desktop -> Hardware -> Display and Monitor the name should be “default” (or maybe “Default Monitor”).

I tried to use the various information to make a 50-monitor.conf file:
Section “Monitor”
Identifier “Default Monitor”
Option “Preferred Mode” “1440x900”

HorizSync 56

VertRefresh 100

1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz

Modeline “1440x900_60.00” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

EndSection

And tried different variation of with/without modeline, hsync, vsync… with no luck.

Looking in the X11 logfile:
SUSE Paste

I got the feeling that 50-monitor.conf never was read? And when I tried to detect which driver was loaded I found this:
SUSE Paste

So I don’t think the Intel driver is loaded at all? When booting KDE Live USB stick the screen resolution is fine.

If it is wrong driver, could you give a hint on how to change the driver - thanks!

Jan

Remove “nomodeset” from your kernel boot line!
Then the intel driver would be used (you’re using fbdev now), which should automatically detect the correct resolution.
You can use YaST->System->Boot Loader->Boot Loader Options->Optional Kernel line Parameter for that.
A side note: Having “quiet” in there 3! times is also not really necessary. :wink:

And then you should of course also revert the changes to 50-monitor.conf…

Thank very much for your quick answer! Now it is running with high resolution :slight_smile:

Jan

On Wed, 11 Dec 2013 14:46:01 +0000, janoleholm wrote:

> Thank very much for your quick answer! Now it is running with high
> resolution :slight_smile:
>
> Jan

Also, be aware that openSUSE 11.3 has been out of support for quite some
time now. You may wish to upgrade, as you’ll not have received security
updates for a couple years now.

(Unless you’re using SLED or SLES, in which case, you’ll want to be over
on forums.suse.com in future)

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2013-12-12 00:32, Jim Henderson wrote:
> Also, be aware that openSUSE 11.3 has been out of support for quite some

The body of the message says 13.1. :slight_smile:

For some reason many of us tend to to guff on the subject title, and
only notice too late.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On Thu, 12 Dec 2013 00:53:06 +0000, Carlos E. R. wrote:

> On 2013-12-12 00:32, Jim Henderson wrote:
>> Also, be aware that openSUSE 11.3 has been out of support for quite
>> some
>
> The body of the message says 13.1. :slight_smile:
>
> For some reason many of us tend to to guff on the subject title, and
> only notice too late.

Yep, oh well - my mistake. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Sorry - that is my mistake !

I copy / paste from another thread and forgot to change from 11.3 to 13.1 in the headline :frowning:

Jan

Well, I guess you’re OK with my good deed for today :), see headline now.