Another broadcom issue with 11.4 (BCM4312) get deauthenticating (reason = 3)

Hi All

I have been upgrading (upgrade from 11.3 then fresh install to 11.4) and as usual with Broadcom I have problems.
On 11,3 I used the Pacman STA and was working fine.

for 11.4, I suppose that my BCM4312 will be supported after installing the b43 driver.

It actually woks, few seconds (but never had time to verify) …
Some background

lspci gives

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Using KDE network manager I can see the wifi AP around, including mine, the problem is when I wan to connect, using WPA2 (TKIP + EAS), I have the right password (I can connect from another station), but when I try here it keeps coming back asking from password … (I use the kwallet, but that should be out of scope) … Basically it always fails…

I did a dmesg and this shows up:

1075.615901] wlan0: authenticate with 00:13:10:1f:76:e7 (try 1)
1075.618184] wlan0: authenticated
1075.618551] wlan0: associate with 00:13:10:1f:76:e7 (try 1)
1075.621205] wlan0: RX AssocResp from 00:13:10:1f:76:e7 (capab=0x411 status=0 aid=3)
1075.621214] wlan0: associated
1081.561549] wlan0: deauthenticating from 00:13:10:1f:76:e7 by local choice (reason=3)

I have been reading around but no one seems have a working solution. Seems that reason 3 is story of backward compatbility, but what can I try ?

Thanks to read a Noob post :slight_smile:

I have this

04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Broadcom Corporation Device [14e4:04b5]
    Kernel driver in use: wl

And this works for me
Install Broadcom Drivers from Packman

Strange that did not work for me, the wireless was not showing any AP …

Have you checked with ‘rfkill’?

You may need to install it

zypper in rfkill


/usr/sbin/rfkill list

Then if necessary: as su -:

rfkill unblock all

Just check the driver is loaded

sudo /sbin/modprobe -wl

Thanks guys but still same problem,

With the 11.4 b43, nothing was blocked when I used rfkill list. However I did a modproble -l | grep bc and I got some bc63xx but no bc43 :frowning:

I removed the b43 and install the packman wl and wl-desktop, restart … Wireless does not show any AP.

Revert back, uninstall packman’s, reintall the b43 … I can see AP, but I am still get deauthenticated after few seconds (seems It does not get any IP from DHCP though) … I did run a command w hile ago to test the dhcpclient for wlan0 and it ends up in timeout (can’t remember the command …)
Where can I set a timeout on the wlan connection to have time to send a request for DHCP ?


I installed 11.4 alongside 11.3
And I found my wireless wouldn’t work in 11.4, although I had followed all the same steps as in 11.3 (the guide I posted earlier).
I never really fathomed it out, but it took a series of rfkill actions, modprobe wl and complete shutdowns (I can also add that wireless was not working in widows either)
Tests revealed that if I boot to 11.3, it all locks up the other OS’s wireless, including in windows.
But as I say, a bit of fiddling and it comes to life.

Of course, your problem might not be the same.
FYI: b43 doesn’t work for me and attempts to use it, render the same results as my booting to 11.3 did.


So I will try tomorrow

  • uninstall the b43
  • intall packman wl and wl-desktop
  • modprobe wl (not sure about the command though)
  • shutdown (complete), so far I was just rebooting

So far I did not see anything block using rfkill list … but I will check. With the 11,3 I have on another laptop (BCM4343 I think, it works perfect using packman’s…)

Will try this tomorrow, a bit fed up now :slight_smile:

Try switching the b43 driver to pio mode by adding the kernel module

Create a file /etc/modprobe.d/50-b43.conf with the following contents:


options b43 pio=1 qos=0

should solved the issues you describe. If you look in the kernel log I
found the b43 driver is complaining about dma errors; switching to pio
mode fixes this.

Thanks MasterPatricko .

Worked like a charm.


options b43 pio=1 qos=0

On 09/26/2011 10:06 AM, fabioxxxx wrote:
> Thanks MasterPatricko .
> Worked like a charm.
> /etc/modprobe.d/50-b43.conf
> options b43 pio=1 qos=0

Just a heads-up. When you get to 12.1 or later, you should be able to delete
this file. With kernel 3.1, the BCM4312 works for most people in DMA, not PIO mode.