Another Bootloader question

After several attempts I’ve finally installed Opensuse 13.2 along side Win 8.1 using the UEFI install on a new HP Envy 17 laptop. I created a separate boot/efi partition for linux which allows me to dual boot. The only problem I have is that it boots directly up to Win 8.1, but if I press the Esc key, then F9 I can select opensuse-secureboot and it boots up to 13.2. Must I do this every time to get to opensuse 13.2. I seem to recall someone posting a solution before, and I tried searching on “bootloader” but can’t seem to find it. I thought perhaps disabling fast boot would be the solution, but I don’t have that option in the Bios. Any help would be appreciated. Joe

A previous poster with a similar problem, found a BIOS setting for “Customized Boot”. I suggest you check whether that’s available.

Here’s the earlier thread: Big install problem with 13.2 and Tumbleweed on a Windows 8.1 netbook

I just noticed this part.

There is a “fast boot” option in Windows. It is a bit hard to find, as I recall. You do need to disable that. Otherwise it can cause problems if you want to mount a Windows disk in opensuse. However, it is not related to your problem.

Fast boot is a Windows function not a BIOS and it should be turned off. But Secure boot is a BIOS function and may or may not be part of the problem. Also there can be a problem if the net-book is 32 bit since openSUSE only supports 64 bit boot on EFI machines. Also you need to be certain to boot the install media in EFI mode some machines may boot it in legacy by default. The installer should tell you it is installing grub2-efi not just grub2

My HP laptop is 64-bit and has been installed in EFI mode. Later tonight I’m wiping the hard drive and just installing Opensuse 13.2. I already have an HP desktop running Win 8.1 and Opensuse 13.2. This should take care of the laptop problem. Thanks for all the replies. Joe

  1. To disable fast-boot, in windoze start cmd in admin mode and enter following command
powercfg /h off
  1. Regarding your problem - You say you have installed openSUSE in secureboot mode - Go into your BIOS firmware settings (by pressing F2 key at boot)
    > Boot order settings > See if you have entry for openSUSE and move it above windows bootloader

I have done the same for my laptop (system #1) which has got Insyde H2O EFI BIOS and on Lenovo Z580 which has Phoenix Tiano Secure Core EFI BIOS

Which BIOS firmware has your system got