Another attempt at netflix under opensuse

Okay so I waited a bit and gave openSUSE 12.3 a go, while very nice there is still one thing missing.
The ability to play netflix on opensuse.
I can do it in Ubuntu, I can do it on fuduntu, but not on openSUSE

Now I did request a package of this for opensuse over at openfate and it got rejected, I tried compiling it too and no luck.
Now this round things seem very close to getting it working but its still giving me errors, even after seemingly sucessfully converting the packages over from ubuntu via alien.
My issue seems to be sudo, I have tried sudo but to no avail and I get this:

** (zenity:14623): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited’ failed

** (zenity:14628): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited’ failed

** (zenity:14635): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited’ failed

** (zenity:14639): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited’ failed

** (zenity:14646): CRITICAL **: atk_bridge_adaptor_cleanup: assertion `inited’ failed

and yes zenity is installed

and non root terminal spits out the same error.
Is there any way to get sudo top bypass this in openSUSE?
I know openSUSE does use sudo but it seems limited to zypper.

Yeah I was surprised that there wasn’t a repo for this on OBS

generally, you cannot distribute propriety stuff through OBS

yeah thus another issue.

As for my issue I semi solved it, by trying an older version of netflix desktop with help from fuduntu.
But its a semi workaround as I was able to fix wine-compholio via alien but I cant get a link working to my wine firefox.
How can I get a workaround for this?
what I need to point to is located in /.netflix-desktop/drive_c/Program Files/Mozilla Firefox/firefox.exe but creating a desktop link fails.

This post might help you out

Yup manually creating a desktop link works, thank you.
I just had to create my own .desktop file and edit.
Kind of a pain though, never had that kind of issue before on other KDE’s or linux distros.

wget -c Download PostInstallerF from

tar -xvzf Netflixplayer.tar.gz


sh /usr/bin/

sudo zypper install zenity make sure all dependency’s are installed

sudo zypper install opencl-utilis

sudo zypper install wine-doors

sudo zypper install wine-tricks

Make sure to install all wine related software in yast2 software manager

Also install the debug Flash Netflix and Streampix in Linux - Fedora 18 - Blogs - Terminal-Insanity

install msttcorefonts from link below

          open wine-tricks and install adobe air, all codec related installs, NET.4.0, firefox 11  
            install silver light from the firefox browser in wine

make sure to set the audio settings in wine settings to match your systems sound card
Create a app icon for netflix in KDE
right click + edit applications
select new item
enter s(h /usr/bin/ )in the command block
check enable launch feed back and place in system tray
advanced tab work path (sh /usr/bin/
go back to general select the gray square to create icon
check other icons and browse
download a.png image of choice and save to my pictures
go back to kde menu editor which should still be open and select the image
here is the link to the icon image I used just right click save as
ICS Plates HD - netflix Icon | Icon Database

@ CHUCK5000000 If interested you can create an faq here and if you want you might include image through SUSE Paste (do set expiry date as non-expiring)