Annoying problems

OS 11.1, KDE. There is a bug reported into KDE-devel that has been labeled
as downstream. It is a problem with using the Login Manager Applet in the
Personal Settings control panel. You cannot make any changes as the applet
crashes. Hrmph.

The problem I am trying to solve is the login screen (kdm) has microscopic
text when output to 42" LCD. You can adjust the fonts all you like but KDM
overrides anything you set. This problem has existed since SuSE 10.2.

Also, on login I always get an error that Intel ICH7 with 1981B has failed
to init falling back to default. Haven’t found a resolution to that
either.

On Thu January 15 2009 10:43 am, GofBorg wrote:

> OS 11.1, KDE. There is a bug reported into KDE-devel that has been labeled
> as downstream. It is a problem with using the Login Manager Applet in the
> Personal Settings control panel. You cannot make any changes as the applet
> crashes. Hrmph.
>
> The problem I am trying to solve is the login screen (kdm) has microscopic
> text when output to 42" LCD. You can adjust the fonts all you like but KDM
> overrides anything you set. This problem has existed since SuSE 10.2.
>
> Also, on login I always get an error that Intel ICH7 with 1981B has failed
> to init falling back to default. Haven’t found a resolution to that
> either.
Have you tried manually editing kdmrc? I THINK that’s where all the configs
for the login screen are saved.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Can you try filing a bug in Novell Bugzilla?

On the login screen, I filed a Bug report on the visibility of that text, and also the almost meaningless labeling of the menus. It’s now classed as a duplicate, with an internally reported bug about the screen wallpaper, hiding the text.

Your issue being unable to change it, might explain why the text is so poor as it stands.

There again, it may be viewed as a different problem (and more serious as there’s no way to reconfigure). Having something purely text size and font related might help this get fixed right.

Rather than someone cutting corner and just altering the wallpaper.

The ICH7 supports a whole slew of stuff.

Does the AC97 audio work? I had errors on a box with AC97 on logging in, with a different chipset in notifications from KDE. 1981B ADI appears to be part of sound system.

Audio started working in more or less mysterious circumstances, and there were other more serious bugs pre-release, that wouldn’t get hit by others, so I haven’t filed a bug on that one.

Ran across this bug report which describes the problem.

An example of a bug reported early enough, but that wasn’t high priority enough to fix before release.

https://bugzilla.novell.com/show_bug.cgi?id=430362

> Ran across this bug report which describes the problem.
>
> An example of a bug reported early enough, but that wasn’t high
> priority enough to fix before release.
>
> https://bugzilla.novell.com/show_bug.cgi?id=430362
>
>
I will try this mentioned in the bug report and let you know if it works:

------- Comment #6 From Sami Lehtinen 2008-11-12 10:51:03 MST (-) -------
In OpenSuse beta 4, installing package phonon-backend-xine resolves the
problem for me …

FWIW, I’m not sure exactly what openSUSE has started doing with customizing the KDM themeing, but I’ve been frustrated too by the inability to tweak the settings. It doesn’t seem to respect any changes.

I wound up going with the upstream-branding for KDM and using the standard KDE/Oxygen theme.

As for the sound issue, I’d suggest you open a separate thread for that. OldCPU is our resident audio guru, and if you post with a specific title related to your audio problems, you’re more likely to get the right eyeballs on it.

Cheers,
KV

> As for the sound issue, I’d suggest you open a separate thread for
> that. OldCPU is our resident audio guru, and if you post with a specific
> title related to your audio problems, you’re more likely to get the
> right eyeballs on it.

Thanks. I added phonon-backend-xine and used the sound applet to move Pulse
Audio to preferred. Seems to have rectified the annoying pop-up error.
As for KDM theming, it’s been disappointing since the start of the 10.x
series. With 9.x most of the standard KDE stuff still worked.

You know, using SuSE 8.2 sometimes, I look and think, that’s pretty. Changes get made, they have impact and often seem good at time, but really they also seem to take as many steps backward.

10.3 & 11.1 don’t look any better from BIOS to Boot screen, even if the darn text was readable. I didn’t even notice for a long time, that it was still there, changing X sessions wasn’t a priority pre-release.

It’s great that you found a solution, if the work round solves same for me I’ll make a note in Bugzilla.