Annoying graphics issues at install, boot, and login. Hybrid graphics related?

First let me say that I have a hybrid graphics machine, an ACER V3-771G-9809 laptop. This has an Intel i7-3632QM processor in it, that apparently contains, on the die, a 4000 series Intel graphics chip. In addition, the machine has a separate NVIDIA 650M card. The laptop came with Windows 8 installed, and after some fiddling with the help of this forum, I have a working 12.3 install under UEFI Secure Boot. However, I had graphics resolution and brightness issues during the install, and continue to have resolution and brightness issues at Grub2 boot and kdm login. I am seeking advice on where to start on analyzing these problems.

  1. At install (from iso-image burned DVD) I have to edit the installation entry to use “nomodeset” on the linuxefi line or else the installation screens display so dim that they are unusable. With nomodeset they are appropriate brightness, and the install proceeds through the package installation and reboots to continue the automatic hardware configuration. However, during the automatic configuration the screens become totally dim again, and it was only from seeing subtle texture changes on what otherwise looks like a dark screen, that I realized the configuration completes, and the initial login screen appears. Pretty much typing blindly, I can login, and then in both the user and root accounts I get a completely acceptable brightness and resolution. This allows me to work.

  2. When I now ordinarily boot the machine to get the Grub2 menu, I get an incredibly coarse resolution display in a box (effectively 80 x 25 at very large point size?) within a box inside my 1600x900 screen. The character sizes are reminiscent of MS-DOS displays 25 years ago(320x240?), and are so large that none of the entries is completely visible on a line. For instance, the OpenSUSE 12.3 entry, which shows the kernel version ordinarily, only shows “OpenSUSE 12.3”. The “Advanced Options” line is cut off, and so is the Windows line. I know that the Boot Manager entry in Yast2 has some fields for graphics resolution, but changing them seems to have no effect upon the problem.

  3. If I select OpenSUSE 12.3 from the coarse character Grub2 menu, I get the initial(kdm?) login screen, but once again, it is so dim, that I am typing blind to enter a user name and password. However, when I succeed, I once again get user and root account displays with expected brightness and resolution.

During the 12.3 boot, it appears that both the i915 module is loaded to handle the on-chip Intel GPU, and the nouveau module to handle the NVIDIA board. At this point I am satisfied with graphics performance in the user space, which I assume is being handled by the i915 module. I have not loaded the proprietary NVIDIA drivers, nor am I interested at this point in the continuing primus/optimos/bumblebee evolution to get the two cards working together and optimally chosen for whichever application is running. All(!) I want is displays bright enough to read that make use of the native screen resolution available.

Where do I start on this? I am guessing the install and Grub2 issues are possibly independent of the kernel modules, since they haven’t been loaded yet. However, the login issue should be kernel module related. Can this all be handled by suitable editing of some configuration files? Is the hybrid nature of my graphics setup breaking something somewhere? Any advice appreciated. And if this post should be in the Hardware section, i apologize.

So, if you have not already done so, consider a kernel version upgrade to perhaps version 3.8.4: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums as this is where base graphic support starts and without a doubt kernel 3.8 works better with nVIDIA over 3.7, but can’t say about Intel per say.

Thank You,

The problem with the boot screen could be a configuration issue with Grub. In Yast go to System>Bootloader conf.>Alternatives… Is “Use graphical console” checked? On my system “Console resolution” is set to Autodetect, what’s yours? If set to Autodetect try another descent resolution, maybe Grub can’t autodetect your display? Exit Yast and reboot. In addition you’ll have to do at least something about Optimus, or it will eat your battery and generate a lot of heat, but this is not to say that you must use bumblebee. We’ll take care of that later.

I tried the update to kernel 3.8.4. The install goes fine, but when I try to boot I get the message:

/boot/vmlinuz-3.8.4-1-desktop has invalid signature

A UEFI system problem? I thought that shim(?) was the thing that was properly signed, so as to get around having to sign other binaries.

I can access 3.7.10 still (Fail Safe, I think, remember can’t read whole line),through the Advanced Options menu choice in Grub2, and when I go into /boot I basically see one of everything for both kernels. Is it as simple as deleting anything with 3.8.4 in the filename and remaking the links to get back 3.7.10? I don’t see a downgrade option in Software Management.

I realized as soon as I posted the last message that my last question was stupid. Of course it is more complicated than just deleting anything associated with the 3.8.4 kernel.

With regards to the Grub2 screen, the options were set on autodetect, and after trying a few alternatives I realized that the problem comes from choosing a vertical resolution larger than what the screen has (900). If I choose a 1024 x 768 resolution I get a quite acceptable menu screen, but it I choose 1280 x 1024, then it defaults back to something of much lower resolution. One thing I was struck by while looking at the available resolutions is that they are all either of 4 x 3 or 5 x 4 aspect ratio. Given that it is close to impossible to get a new desktop display in those aspect ratios, and certainly no laptop comes with these ratios anymore, I am surprised that Grub2 doesn’t offer some more modern resolution options. I personally dislike the 16 x 9 aspect ratio, and see no advantage to it except for watching movies, but I am not the demographic that laptops and desktops are directed at these days.

Thanks for goading me into trying the resolution options again and really analyzing the results. So one graphics annoyance gone, and two to go!

So for working with Grub 2, I can provide some help, have a look here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

Thank You,

So what about Optimus, is there anything in the BIOS setup regarding Optimus, or is this laptop an Optimus only?

The BIOS is almost completely inaccessible. Unlike desktop motherboards I have had, there are no options to turn off onboard hardware (LAN, sound,etc) at all. Certainly no MUX. No mention of video anywhere except for the fact that the machine has been set up to grab 2 GB of system memory for graphics, and this is not something that can be changed either. So it must be software switches to obtain this functionality. Right now this machine is powered from the wall, so I am really not too concerned about power issues. I would rather get a login screen I can read first before worrying about the power drain and performance balancing of the hybrid graphics.

I have found two solutions to the screen brightness problem at the kdm login screen. They may or may not work at the install also, but I am not about to do a re-install to find out. The first is a simple hardware solution. The keyboard has two “sun” icons over the arrow keys, picked out in blue, as are other icons on the function keys. At the dark kdm screen, if I press the Fn -Right Arrow combination I get illumination/backlight control in several steps. Pressing once makes the login screen totally visible. If I use this option, then when I log into my user accounts, this keyboard manipulation allows me to change the screen brightness also. An alternative, which I found cruising this forum, is to add “acpi_backlight=vendor” to the kernel line. At this point I have tried this out by editing the linuxefi command in Grub2. In this case I get appropriately bright screens throughout the boot process, even seeing the little clock going around as X starts up (or so I believe) as I have been used to seeing now for many years. The disadvantage of this approach is that the display brightness no longer responds to the keyboard when I am in my user accounts. I generally prefer a dimmer screen than what the system selects. So perhaps there is widget that exists to control screen brightness? If that were the case then I could make the kernel parameter change permanent.

Hi,

I think I’ve got the answer to your graphics issue (somewhat). I also have an optimus capable laptop (Sony Z series) and I had to do some fiddling with the bios to access the nvidia card rather than the on-board intel video. If all you want is the intel video to work then updating to later kernels should fix your problem, however, if you want to ever play games or use any sort of graphic acceleration then you need to do some slightly scary work on the bios.

This is a link to an unlocked bios for your laptop series. With this you should be able to enable your nvidia graphics and disable the built-in intel graphics. There might be a later version or one better suited for your laptop model. You should probably search around a bit.

Bios Mods -The Best BIOS Update and Modification Source - [UNLOCKED] Acer Aspire V3-771G Unlock Request

I had to do the same thing with my laptop some time ago and it has worked without issues for a few years now. Keep in mind that I have no idea if the above linked bios has any issues or whether it works properly, and beware that you could brick your laptop by flashing a different bios.

You might also look into setting up bumblebee to use both cards, but I always found it to be a huge hassle. Also keep in mind that enabling the nvidia card will drain the battery rather quickly and it is unlikely that you will be able to change the screen brightness.